aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-devtools/python/files/0001-Delete-the-version-limit-for-dosocs2.patch25
-rw-r--r--recipes-devtools/python/files/0001-Deleted-version-limit-for-dosocs2.patch25
-rw-r--r--recipes-devtools/python/files/0001-setup-py-delete-the-depends-install.patch34
3 files changed, 84 insertions, 0 deletions
diff --git a/recipes-devtools/python/files/0001-Delete-the-version-limit-for-dosocs2.patch b/recipes-devtools/python/files/0001-Delete-the-version-limit-for-dosocs2.patch
new file mode 100644
index 0000000..5773b8b
--- /dev/null
+++ b/recipes-devtools/python/files/0001-Delete-the-version-limit-for-dosocs2.patch
@@ -0,0 +1,25 @@
+From 3e3bef6aff2563e4bb206c1169b783a1c61308e5 Mon Sep 17 00:00:00 2001
+From: Lei Maohui <leimaohui@cn.fujitsu.com>
+Date: Fri, 25 Aug 2017 03:03:06 +0900
+Subject: [PATCH] Delete the version limit for dosocs2.
+
+Signed-off-by: Lei Maohui <leimaohui@cn.fujitsu.com>
+---
+ setup.py | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/setup.py b/setup.py
+index b35863f..1bae161 100644
+--- a/setup.py
++++ b/setup.py
+@@ -1,6 +1,6 @@
+ from setuptools import setup
+
+-_dosocs2_version = '0.16.1'
++_dosocs2_version = ''
+
+ install_requires=[
+ ]
+--
+2.7.4
+
diff --git a/recipes-devtools/python/files/0001-Deleted-version-limit-for-dosocs2.patch b/recipes-devtools/python/files/0001-Deleted-version-limit-for-dosocs2.patch
new file mode 100644
index 0000000..4daab5e
--- /dev/null
+++ b/recipes-devtools/python/files/0001-Deleted-version-limit-for-dosocs2.patch
@@ -0,0 +1,25 @@
+From f9b27dee4dc01dafec111957a1ad411f20bcb644 Mon Sep 17 00:00:00 2001
+From: Lei Maohui <leimaohui@cn.fujitsu.com>
+Date: Fri, 25 Aug 2017 03:17:19 +0900
+Subject: [PATCH] Deleted version limit for dosocs2.
+
+Signed-off-by: Lei Maohui <leimaohui@cn.fujitsu.com>
+---
+ setup.py | 1 -
+ 1 file changed, 1 deletion(-)
+
+diff --git a/setup.py b/setup.py
+index b35863f..9be6cd7 100644
+--- a/setup.py
++++ b/setup.py
+@@ -10,7 +10,6 @@ tests_require=[
+
+ setup(
+ name='dosocs2',
+- version=_dosocs2_version,
+ description='SPDX 2.0 document creation and storage',
+ long_description='',
+ url='https://github.com/DoSOCSv2/DoSOCSv2',
+--
+2.7.4
+
diff --git a/recipes-devtools/python/files/0001-setup-py-delete-the-depends-install.patch b/recipes-devtools/python/files/0001-setup-py-delete-the-depends-install.patch
new file mode 100644
index 0000000..41f6bb2
--- /dev/null
+++ b/recipes-devtools/python/files/0001-setup-py-delete-the-depends-install.patch
@@ -0,0 +1,34 @@
+From d282ba074625922d12615af676ac1f0e922db88f Mon Sep 17 00:00:00 2001
+From: Lei Maohui <leimaohui@cn.fujitsu.com>
+Date: Wed, 15 Feb 2017 23:23:53 +0900
+Subject: [PATCH] setup.py: delete the depends install
+
+Signed-off-by: Lei Maohui <leimaohui@cn.fujitsu.com>
+---
+ setup.py | 7 -------
+ 1 file changed, 7 deletions(-)
+
+diff --git a/setup.py b/setup.py
+index 527b161..b35863f 100644
+--- a/setup.py
++++ b/setup.py
+@@ -3,16 +3,9 @@ from setuptools import setup
+ _dosocs2_version = '0.16.1'
+
+ install_requires=[
+- 'jinja2',
+- 'python-magic',
+- 'docopt',
+- 'SQLAlchemy',
+- 'psycopg2'
+ ]
+
+ tests_require=[
+- 'pytest',
+- 'mock'
+ ]
+
+ setup(
+--
+1.8.4.2
+