aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-scanners/clamav/files/fix_systemd_socket.patch
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-scanners/clamav/files/fix_systemd_socket.patch')
-rw-r--r--recipes-scanners/clamav/files/fix_systemd_socket.patch25
1 files changed, 0 insertions, 25 deletions
diff --git a/recipes-scanners/clamav/files/fix_systemd_socket.patch b/recipes-scanners/clamav/files/fix_systemd_socket.patch
deleted file mode 100644
index 3e9abe2..0000000
--- a/recipes-scanners/clamav/files/fix_systemd_socket.patch
+++ /dev/null
@@ -1,25 +0,0 @@
-clamd not installing clamav-daemon.socket
-
-Fixes:
-__main__.SystemdUnitNotFoundError: (PosixPath('../security-build-image/1.0-r0/rootfs'), 'clamav-daemon.socket')
-%post(clamav-daemon-0.104.0-r0.core2_64): waitpid(3587571) rc 3587571 status 100
-warning: %post(clamav-daemon-0.104.0-r0.core2_64) scriptlet failed, exit status 1
-
-Upstream-Status: Pending
-Signed-off-by: Armin Kuster <akuster808@gmail.com>
-
-Index: git/clamd/CMakeLists.txt
-===================================================================
---- git.orig/clamd/CMakeLists.txt
-+++ git/clamd/CMakeLists.txt
-@@ -54,4 +54,10 @@ if(SYSTEMD_FOUND)
- install(
- FILES ${CMAKE_CURRENT_BINARY_DIR}/clamav-daemon.service
- DESTINATION ${SYSTEMD_UNIT_DIR})
-+ configure_file(
-+ ${CMAKE_CURRENT_SOURCE_DIR}/clamav-daemon.socket.in
-+ ${CMAKE_CURRENT_BINARY_DIR}/clamav-daemon.socket @ONLY)
-+ install(
-+ FILES ${CMAKE_CURRENT_BINARY_DIR}/clamav-daemon.socket
-+ DESTINATION ${SYSTEMD_UNIT_DIR})
- endif()