aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-scanners/checksec/checksec_2.6.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-scanners/checksec/checksec_2.6.0.bb')
-rw-r--r--recipes-scanners/checksec/checksec_2.6.0.bb21
1 files changed, 21 insertions, 0 deletions
diff --git a/recipes-scanners/checksec/checksec_2.6.0.bb b/recipes-scanners/checksec/checksec_2.6.0.bb
new file mode 100644
index 0000000..1ba3721
--- /dev/null
+++ b/recipes-scanners/checksec/checksec_2.6.0.bb
@@ -0,0 +1,21 @@
+SUMMARY = "Linux system security checks"
+DESCRIPTION = "The checksec script is designed to test what standard Linux OS and PaX security features are being used."
+SECTION = "security"
+LICENSE = "BSD-3-Clause"
+HOMEPAGE="https://github.com/slimm609/checksec.sh"
+
+LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=879b2147c754bc040c29e9c3b84da836"
+
+SRCREV = "2753ebb89fcdc96433ae8a4c4e5a49214a845be2"
+SRC_URI = "git://github.com/slimm609/checksec.sh;branch=main;protocol=https"
+
+S = "${WORKDIR}/git"
+
+do_install() {
+ install -d ${D}${bindir}
+ install -m 0755 ${S}/checksec ${D}${bindir}
+}
+
+RDEPENDS:${PN} = "bash openssl-bin binutils findutils file procps"
+
+BBCLASSEXTEND = "native"