aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-ids/suricata/libhtp_0.5.45.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-ids/suricata/libhtp_0.5.45.bb')
-rw-r--r--recipes-ids/suricata/libhtp_0.5.45.bb27
1 files changed, 27 insertions, 0 deletions
diff --git a/recipes-ids/suricata/libhtp_0.5.45.bb b/recipes-ids/suricata/libhtp_0.5.45.bb
new file mode 100644
index 0000000..cc8285c
--- /dev/null
+++ b/recipes-ids/suricata/libhtp_0.5.45.bb
@@ -0,0 +1,27 @@
+SUMMARY = "LibHTP is a security-aware parser for the HTTP protocol and the related bits and pieces."
+
+require suricata.inc
+
+LIC_FILES_CHKSUM = "file://LICENSE;beginline=1;endline=2;md5=596ab7963a1a0e5198e5a1c4aa621843"
+
+SRC_URI = "git://github.com/OISF/libhtp.git;protocol=https;branch=0.5.x"
+SRCREV = "8bdfe7b9d04e5e948c8fbaa7472e14d884cc00af"
+
+DEPENDS = "zlib"
+
+inherit autotools-brokensep pkgconfig
+
+CFLAGS += "-D_DEFAULT_SOURCE"
+
+#S = "${WORKDIR}/suricata-${VER}/${BPN}"
+
+S = "${WORKDIR}/git"
+
+do_configure () {
+ cd ${S}
+ ./autogen.sh
+ oe_runconf
+}
+
+RDEPENDS:${PN} += "zlib"
+