aboutsummaryrefslogtreecommitdiffstats
path: root/meta-tpm/recipes-tpm1/pcr-extend/pcr-extend_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-tpm/recipes-tpm1/pcr-extend/pcr-extend_git.bb')
-rw-r--r--meta-tpm/recipes-tpm1/pcr-extend/pcr-extend_git.bb26
1 files changed, 26 insertions, 0 deletions
diff --git a/meta-tpm/recipes-tpm1/pcr-extend/pcr-extend_git.bb b/meta-tpm/recipes-tpm1/pcr-extend/pcr-extend_git.bb
new file mode 100644
index 0000000..45da416
--- /dev/null
+++ b/meta-tpm/recipes-tpm1/pcr-extend/pcr-extend_git.bb
@@ -0,0 +1,26 @@
+SUMMARY = "Command line utility to extend hash of arbitrary data into a TPMs PCR."
+HOMEPAGE = "https://github.com/flihp/pcr-extend"
+SECTION = "security/tpm"
+LICENSE = "GPL-2.0-only"
+LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
+
+DEPENDS = "libtspi"
+
+PV = "0.1+git${SRCPV}"
+SRCREV = "c02ad8f628b3d99f6d4c087b402fe31a40ee6316"
+
+SRC_URI = "git://github.com/flihp/pcr-extend.git;branch=master;protocol=https \
+ file://fix_openssl11_build.patch "
+
+inherit autotools
+
+S = "${WORKDIR}/git"
+
+do_compile() {
+ oe_runmake -C ${S}/src
+}
+
+do_install() {
+ install -d ${D}${bindir}
+ oe_runmake -C ${S}/src DESTDIR="${D}" install
+}