aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-devtools/python/python3-adafruit-platformdetect_3.27.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-devtools/python/python3-adafruit-platformdetect_3.27.0.bb')
-rw-r--r--recipes-devtools/python/python3-adafruit-platformdetect_3.27.0.bb14
1 files changed, 14 insertions, 0 deletions
diff --git a/recipes-devtools/python/python3-adafruit-platformdetect_3.27.0.bb b/recipes-devtools/python/python3-adafruit-platformdetect_3.27.0.bb
new file mode 100644
index 0000000..45dc49d
--- /dev/null
+++ b/recipes-devtools/python/python3-adafruit-platformdetect_3.27.0.bb
@@ -0,0 +1,14 @@
+SUMMARY = "Platform detection for use by libraries like Adafruit-Blinka."
+HOMEPAGE = "https://github.com/adafruit/Adafruit_Python_PlatformDetect"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=fccd531dce4b989c05173925f0bbb76c"
+
+SRC_URI = "git://github.com/adafruit/Adafruit_Python_PlatformDetect.git;branch=main;protocol=https"
+SRCREV = "e1460098eeca5ea573f92814691bb378e15530d9"
+S = "${WORKDIR}/git"
+
+inherit setuptools3
+
+DEPENDS += "python3-setuptools-scm-native"
+
+RDEPENDS:${PN} += "python3-core"