aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-test/images/initramfs-test-image.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-test/images/initramfs-test-image.bb')
-rw-r--r--recipes-test/images/initramfs-test-image.bb21
1 files changed, 21 insertions, 0 deletions
diff --git a/recipes-test/images/initramfs-test-image.bb b/recipes-test/images/initramfs-test-image.bb
index e6aa886..3c19996 100644
--- a/recipes-test/images/initramfs-test-image.bb
+++ b/recipes-test/images/initramfs-test-image.bb
@@ -3,7 +3,13 @@ require recipes-test/images/initramfs-tiny-image.bb
DESCRIPTION = "Small ramdisk image for running tests (bootrr, etc)"
PACKAGE_INSTALL += " \
+ alsa-utils-alsaucm \
+ alsa-utils-amixer \
+ alsa-utils-aplay \
+ alsa-utils-speakertest \
bluez5 \
+ bootrr \
+ debugcc \
dhcpcd \
diag \
dropbear \
@@ -13,10 +19,14 @@ PACKAGE_INSTALL += " \
e2fsprogs-resize2fs \
e2fsprogs-tune2fs \
ethtool \
+ fastrpc \
gptfdisk \
+ i2c-tools \
iw \
lava-test-shell \
libdrm-tests \
+ lrzsz \
+ mybw \
pciutils \
pd-mapper \
qrtr \
@@ -24,15 +34,26 @@ PACKAGE_INSTALL += " \
strace \
tqftpserv \
usbutils \
+ util-linux-lscpu \
+ util-linux-taskset \
wpa-supplicant \
+ ${@bb.utils.contains('DISTRO_FEATURES', 'opengl', 'kmscube', '', d)} \
"
# We'd like to include extra packages provided by layers which we do not depend
# on. This can be handled by .bbappends, but then image recipes including this
# one would not get all these tools. So simulate dynamic bbappend here.
PACKAGE_INSTALL_openembedded-layer += " \
+ android-tools-adbd \
+ android-tools-adbd-cmdline \
+ cpufrequtils \
cryptsetup \
devmem2 \
+ lmsensors-config-libsensors \
+ lmsensors-sensors \
+ media-ctl \
+ read-edid \
+ yavta \
"
PACKAGE_INSTALL_networking-layer += " \