aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-support/fastrpc/fastrpc_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-support/fastrpc/fastrpc_git.bb')
-rw-r--r--recipes-support/fastrpc/fastrpc_git.bb12
1 files changed, 8 insertions, 4 deletions
diff --git a/recipes-support/fastrpc/fastrpc_git.bb b/recipes-support/fastrpc/fastrpc_git.bb
index d883b26..5d6acd7 100644
--- a/recipes-support/fastrpc/fastrpc_git.bb
+++ b/recipes-support/fastrpc/fastrpc_git.bb
@@ -1,16 +1,17 @@
-HOMEPAGE = "https://git.linaro.org/landing-teams/working/qualcomm/fastrpc.git"
+HOMEPAGE = "https://git.codelinaro.org/linaro/qcomlt/fastrpc.git"
SUMMARY = "Qualcomm FastRPC applications and library"
SECTION = "devel"
LICENSE = "BSD-3-Clause"
LIC_FILES_CHKSUM = "file://src/fastrpc_apps_user.c;beginline=1;endline=29;md5=f94f3a7beba14ae2f59f817e9634f891"
-SRCREV = "5a8320c46df8c0dbefe71d97a8273f417e8721f3"
+SRCREV = "06ef0e7ae56b9f7dde53fb92e8a4bc5a843af8a8"
SRC_URI = "\
- git://git.linaro.org/landing-teams/working/qualcomm/fastrpc.git;branch=automake;protocol=https \
+ git://git.codelinaro.org/linaro/qcomlt/fastrpc.git;branch=automake;protocol=https \
file://0001-apps_std_fopen_with_env-account-for-domain-kinds-whe.patch \
file://adsprpcd.service \
file://cdsprpcd.service \
+ file://sdsprpcd.service \
file://usr-lib-rfsa.service \
file://mount-dsp.sh \
"
@@ -28,7 +29,7 @@ SYSTEMD_PACKAGES = "${PN} ${PN}-systemd"
SYSTEMD_SERVICE:${PN} = "usr-lib-rfsa.service"
-SYSTEMD_SERVICE:${PN}-systemd = "adsprpcd.service cdsprpcd.service"
+SYSTEMD_SERVICE:${PN}-systemd = "adsprpcd.service cdsprpcd.service sdsprpcd.service"
SYSTEMD_AUTO_ENABLE:${PN}-systemd = "disable"
do_install:append() {
@@ -38,6 +39,7 @@ do_install:append() {
install -m 0644 ${WORKDIR}/usr-lib-rfsa.service ${D}${systemd_unitdir}/system
install -m 0644 ${WORKDIR}/adsprpcd.service ${D}${systemd_unitdir}/system
install -m 0644 ${WORKDIR}/cdsprpcd.service ${D}${systemd_unitdir}/system
+ install -m 0644 ${WORKDIR}/sdsprpcd.service ${D}${systemd_unitdir}/system
install -d ${D}${sbindir}
install -m 0755 ${WORKDIR}/mount-dsp.sh ${D}${sbindir}
@@ -47,8 +49,10 @@ FILES:${PN} += " \
${libdir}/rfsa \
${libdir}/libadsp_default_listener.so \
${libdir}/libcdsp_default_listener.so \
+ ${libdir}/libsdsp_default_listener.so \
${libdir}/libadsprpc.so \
${libdir}/libcdsprpc.so \
+ ${libdir}/libsdsprpc.so \
"
FILES:${PN}-dev:remove = "${FILES_SOLIBSDEV}"