aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-graphics/mesa/files/0002-meson.build-make-TLS-ELF-optional.patch
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-graphics/mesa/files/0002-meson.build-make-TLS-ELF-optional.patch')
-rw-r--r--recipes-graphics/mesa/files/0002-meson.build-make-TLS-ELF-optional.patch24
1 files changed, 12 insertions, 12 deletions
diff --git a/recipes-graphics/mesa/files/0002-meson.build-make-TLS-ELF-optional.patch b/recipes-graphics/mesa/files/0002-meson.build-make-TLS-ELF-optional.patch
index 3d87c97..043217c 100644
--- a/recipes-graphics/mesa/files/0002-meson.build-make-TLS-ELF-optional.patch
+++ b/recipes-graphics/mesa/files/0002-meson.build-make-TLS-ELF-optional.patch
@@ -1,4 +1,4 @@
-From a9253ee295c4684e20aee6022bc9f26c5fc68856 Mon Sep 17 00:00:00 2001
+From 8f767113d5b8a2ee89cd069d54243f8b0ac9a218 Mon Sep 17 00:00:00 2001
From: Alistair Francis <alistair@alistair23.me>
Date: Wed, 2 Sep 2020 15:28:50 -0500
Subject: [PATCH] meson.build: make TLS ELF optional
@@ -8,32 +8,29 @@ TLS GLX optional again" patch updated to the latest mesa.
Upstream-Status: Inappropriate [configuration]
Signed-off-by: Alistair Francis <alistair@alistair23.me>
-
---
- meson.build | 4 +---
+ meson.build | 2 +-
meson_options.txt | 6 ++++++
- 2 files changed, 7 insertions(+), 3 deletions(-)
+ 2 files changed, 7 insertions(+), 1 deletion(-)
diff --git a/meson.build b/meson.build
-index 5931260dd3d..23a3cd66156 100644
+index 9b4e5e28864..15eacbe6918 100644
--- a/meson.build
+++ b/meson.build
-@@ -453,9 +453,7 @@ endif
+@@ -509,7 +509,7 @@ foreach platform : _platforms
+ endforeach
- # Android uses emutls for versions <= P/28. For USE_ELF_TLS we need ELF TLS.
use_elf_tls = false
--if (not ['freebsd', 'openbsd', 'haiku'].contains(host_machine.system()) and
-- (not with_platform_android or get_option('platform-sdk-version') >= 29) and
-- (not with_platform_windows or not with_shared_glapi))
+-if not with_platform_windows or not with_shared_glapi
+if (not with_platform_android or get_option('platform-sdk-version') >= 29) and get_option('elf-tls')
pre_args += '-DUSE_ELF_TLS'
use_elf_tls = true
diff --git a/meson_options.txt b/meson_options.txt
-index 54e15e9f850..118eba3914d 100644
+index fd0d99f2f9a..f994c22ac61 100644
--- a/meson_options.txt
+++ b/meson_options.txt
-@@ -439,6 +439,12 @@ option(
+@@ -455,6 +455,12 @@ option(
value : true,
description : 'Enable direct rendering in GLX and EGL for DRI',
)
@@ -46,3 +43,6 @@ index 54e15e9f850..118eba3914d 100644
option(
'prefer-iris',
type : 'boolean',
+--
+2.34.0
+