aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-devtools/qemu/qemu-2012.01
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-devtools/qemu/qemu-2012.01')
-rw-r--r--recipes-devtools/qemu/qemu-2012.01/glflags.patch15
-rw-r--r--recipes-devtools/qemu/qemu-2012.01/larger_default_ram_size.patch22
-rw-r--r--recipes-devtools/qemu/qemu-2012.01/no-strip.patch19
3 files changed, 56 insertions, 0 deletions
diff --git a/recipes-devtools/qemu/qemu-2012.01/glflags.patch b/recipes-devtools/qemu/qemu-2012.01/glflags.patch
new file mode 100644
index 0000000..0814675
--- /dev/null
+++ b/recipes-devtools/qemu/qemu-2012.01/glflags.patch
@@ -0,0 +1,15 @@
+Upstream-Status: Inappropriate [configuration]
+
+Index: qemu-0.14.0/Makefile.target
+===================================================================
+--- qemu-0.14.0.orig/Makefile.target 2011-04-04 12:12:19.142871742 +0100
++++ qemu-0.14.0/Makefile.target 2011-04-04 12:12:21.772871742 +0100
+@@ -362,7 +362,7 @@
+
+ monitor.o: hmp-commands.h qmp-commands.h
+
+-LIBS += -lGL -lGLU
++LIBS += -lGL
+
+ $(obj-y) $(obj-$(TARGET_BASE_ARCH)-y): $(GENERATED_HEADERS)
+
diff --git a/recipes-devtools/qemu/qemu-2012.01/larger_default_ram_size.patch b/recipes-devtools/qemu/qemu-2012.01/larger_default_ram_size.patch
new file mode 100644
index 0000000..be8af8e
--- /dev/null
+++ b/recipes-devtools/qemu/qemu-2012.01/larger_default_ram_size.patch
@@ -0,0 +1,22 @@
+This patch is taken from debian. 128M is too less sometimes if distro
+with lot of packages is booted so this patch raises the default to 384M
+
+It has not been applied to upstream qemu
+
+Khem Raj <raj.khem@gmail.com>
+
+Upstream-Status: Pending
+
+Index: qemu-0.14.0/vl.c
+===================================================================
+--- qemu-0.14.0.orig/vl.c
++++ qemu-0.14.0/vl.c
+@@ -168,7 +168,7 @@ int main(int argc, char **argv)
+ //#define DEBUG_NET
+ //#define DEBUG_SLIRP
+
+-#define DEFAULT_RAM_SIZE 128
++#define DEFAULT_RAM_SIZE 384
+
+ #define MAX_VIRTIO_CONSOLES 1
+
diff --git a/recipes-devtools/qemu/qemu-2012.01/no-strip.patch b/recipes-devtools/qemu/qemu-2012.01/no-strip.patch
new file mode 100644
index 0000000..25e42da
--- /dev/null
+++ b/recipes-devtools/qemu/qemu-2012.01/no-strip.patch
@@ -0,0 +1,19 @@
+Subject: [PATCH] Upstream-Status: Inappropriate [configuration]
+
+---
+ Makefile | 2 +-
+ 1 files changed, 1 insertions(+), 1 deletions(-)
+
+diff --git a/Makefile b/Makefile
+index ffd3364..38d8352 100644
+--- a/Makefile
++++ b/Makefile
+@@ -288,7 +288,7 @@ install-sysconfig:
+ install: all $(if $(BUILD_DOCS),install-doc) install-sysconfig
+ $(INSTALL_DIR) "$(DESTDIR)$(bindir)"
+ ifneq ($(TOOLS),)
+- $(INSTALL_PROG) $(STRIP_OPT) $(TOOLS) "$(DESTDIR)$(bindir)"
++ $(INSTALL_PROG) $(TOOLS) "$(DESTDIR)$(bindir)"
+ endif
+ ifneq ($(BLOBS),)
+ $(INSTALL_DIR) "$(DESTDIR)$(datadir)"