aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-devtools/intltool
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-devtools/intltool')
-rw-r--r--recipes-devtools/intltool/intltool-0.50.0/use-nativeperl.patch20
-rw-r--r--recipes-devtools/intltool/intltool.inc20
-rw-r--r--recipes-devtools/intltool/intltool_0.50.0.bb19
3 files changed, 59 insertions, 0 deletions
diff --git a/recipes-devtools/intltool/intltool-0.50.0/use-nativeperl.patch b/recipes-devtools/intltool/intltool-0.50.0/use-nativeperl.patch
new file mode 100644
index 0000000..209861c
--- /dev/null
+++ b/recipes-devtools/intltool/intltool-0.50.0/use-nativeperl.patch
@@ -0,0 +1,20 @@
+OE has perl binary as 'nativeperl' in native sysroot so we look for it
+in order to avoid intltool searching and finding perl from /usr/bin
+on build system which may not have all the modules that it needs.
+
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+
+Upstream-Status: Inappropriate [OE specific]
+Index: intltool-0.40.6/intltool.m4
+===================================================================
+--- intltool-0.40.6.orig/intltool.m4 2009-02-14 14:12:28.000000000 -0800
++++ intltool-0.40.6/intltool.m4 2011-08-09 08:07:16.427347846 -0700
+@@ -110,7 +110,7 @@
+ AC_MSG_ERROR([GNU gettext tools not found; required for intltool])
+ fi
+
+-AC_PATH_PROG(INTLTOOL_PERL, perl)
++AC_PATH_PROG(INTLTOOL_PERL, nativeperl)
+ if test -z "$INTLTOOL_PERL"; then
+ AC_MSG_ERROR([perl not found])
+ fi
diff --git a/recipes-devtools/intltool/intltool.inc b/recipes-devtools/intltool/intltool.inc
new file mode 100644
index 0000000..5b7d69a
--- /dev/null
+++ b/recipes-devtools/intltool/intltool.inc
@@ -0,0 +1,20 @@
+DESCRIPTION = "Utility scripts for internationalizing XML"
+SECTION = "devel"
+LICENSE = "GPLv2"
+
+URLV="${@'.'.join(d.getVar('PV',1).split('.')[0:2])}"
+SRC_URI = "http://launchpad.net/intltool/trunk/0.50.0/+download/intltool-0.50.0.tar.gz"
+S = "${WORKDIR}/intltool-${PV}"
+
+DEPENDS = "libxml-parser-perl-native"
+DEPENDS_virtclass-native = "libxml-parser-perl-native"
+#RDEPENDS_${PN} = "libxml-parser-perl"
+RRECOMMENDS_${PN} = "perl-modules"
+RRECOMMENDS_${PN}_virtclass-native = ""
+
+inherit autotools pkgconfig perlnative
+
+export PERL = "${bindir}/env perl"
+PERL_virtclass-native = "/usr/bin/env nativeperl"
+
+BBCLASSEXTEND = "native"
diff --git a/recipes-devtools/intltool/intltool_0.50.0.bb b/recipes-devtools/intltool/intltool_0.50.0.bb
new file mode 100644
index 0000000..e3cfe05
--- /dev/null
+++ b/recipes-devtools/intltool/intltool_0.50.0.bb
@@ -0,0 +1,19 @@
+require intltool.inc
+LICENSE="GPLv2"
+LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f"
+PR = "r6"
+
+SRC_URI_append = " file://intltool-nowarn-0.50.0.patch \
+ ${NATIVEPATCHES} \
+ "
+
+#
+# All of the intltool scripts have the correct paths to perl already
+# embedded into them and can find perl fine, so we add the remove xml-check
+# in the intltool.m4 via the remove-xml-check.patch
+NATIVEPATCHES = "file://noperlcheck.patch \
+ file://remove-xml-check.patch"
+NATIVEPATCHES_virtclass-native = "file://use-nativeperl.patch"
+
+SRC_URI[md5sum] = "0da9847a60391ca653df35123b1f7cc0"
+SRC_URI[sha256sum] = "dccfb0b7dd35a170130e8934bfd30c29da6ae73bcd3ca4ba71317c977b2893d6"