summaryrefslogtreecommitdiffstats
path: root/recipes-core/mkl-dnn/mkl-dnn_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-core/mkl-dnn/mkl-dnn_git.bb')
-rw-r--r--recipes-core/mkl-dnn/mkl-dnn_git.bb25
1 files changed, 25 insertions, 0 deletions
diff --git a/recipes-core/mkl-dnn/mkl-dnn_git.bb b/recipes-core/mkl-dnn/mkl-dnn_git.bb
new file mode 100644
index 00000000..14f4cec4
--- /dev/null
+++ b/recipes-core/mkl-dnn/mkl-dnn_git.bb
@@ -0,0 +1,25 @@
+SUMMARY = "Intel Math Kernel Library for Deep Neural Networks"
+DESCRIPTION = "This software is a user mode library that accelerates\
+deep-learning applications and frameworks on Intel architecture."
+LICENSE = "Apache-2.0 & BSD-3-Clause"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=afa44a3d001cc203032135324f9636b7 \
+ file://tests/gtests/gtest/LICENSE;md5=cbbd27594afd089daa160d3a16dd515a \
+ file://src/cpu/xbyak/COPYRIGHT;md5=03532861dad9003cc2c17f14fc7a4efa"
+SECTION = "lib"
+
+inherit pkgconfig cmake
+
+S = "${WORKDIR}/git"
+SRCREV = "027de7603662a569366e15132ac80298902b96b8"
+SRC_URI = "git://github.com/intel/mkl-dnn.git;branch=rls-v0.19"
+PV = "0.19+git${SRCPV}"
+
+UPSTREAM_CHECK_GITTAGREGEX = "^v(?P<pver>(\d+(\.\d+)+))$"
+
+COMPATIBLE_HOST = '(x86_64).*-linux'
+COMPATIBLE_HOST_libc-musl = 'null'
+
+EXTRA_OECMAKE += "-DMKLDNN_LIBRARY_TYPE=SHARED"
+EXTRA_OECMAKE += "-DMKLDNN_THREADING=OMP"
+EXTRA_OECMAKE += "-DWITH_EXAMPLE=ON"
+EXTRA_OECMAKE += "-DWITH_TEST=ON"