aboutsummaryrefslogtreecommitdiffstats
path: root/dynamic-layers/openembedded-layer/recipes-bsp
diff options
context:
space:
mode:
Diffstat (limited to 'dynamic-layers/openembedded-layer/recipes-bsp')
-rw-r--r--dynamic-layers/openembedded-layer/recipes-bsp/amt/files/0001-CIM_Framework-CMakeLists.txt-turn-OFF-BUILD_LIBCIM.patch34
-rw-r--r--dynamic-layers/openembedded-layer/recipes-bsp/amt/files/lms_drop_rpath_2022.0.0.0.diff30
-rw-r--r--dynamic-layers/openembedded-layer/recipes-bsp/amt/lms_2022.0.0.0.bb39
-rw-r--r--dynamic-layers/openembedded-layer/recipes-bsp/amt/lms_2406.0.0.0.bb44
-rw-r--r--dynamic-layers/openembedded-layer/recipes-bsp/thermald/files/0001-Makefile-Fix-build-Issue.patch35
-rw-r--r--dynamic-layers/openembedded-layer/recipes-bsp/thermald/thermald_2.5.7.bb45
6 files changed, 124 insertions, 103 deletions
diff --git a/dynamic-layers/openembedded-layer/recipes-bsp/amt/files/0001-CIM_Framework-CMakeLists.txt-turn-OFF-BUILD_LIBCIM.patch b/dynamic-layers/openembedded-layer/recipes-bsp/amt/files/0001-CIM_Framework-CMakeLists.txt-turn-OFF-BUILD_LIBCIM.patch
deleted file mode 100644
index d3b10319..00000000
--- a/dynamic-layers/openembedded-layer/recipes-bsp/amt/files/0001-CIM_Framework-CMakeLists.txt-turn-OFF-BUILD_LIBCIM.patch
+++ /dev/null
@@ -1,34 +0,0 @@
-From 7f24e190bde4ee120e284cbdb59eed36ef8818f8 Mon Sep 17 00:00:00 2001
-From: Anuj Mittal <anuj.mittal@intel.com>
-Date: Thu, 10 Sep 2020 15:44:09 +0800
-Subject: [PATCH] CIM_Framework/CMakeLists.txt: turn OFF BUILD_LIBCIM
-
-BUILD_LIBCIM forces a check for libcmpisfcc in the top level makefile
-for openwsman while the cim plugin itself isn't built if DISABLE_PLUGINS
-is turned ON. This leads to an error when that library isn't present
-even though we're not building that part of the code at all.
-
-Turn OFF BUILD_LIBCIM in addition to DISABLE_PLUGINS.
-
-Upstream-Status: Submitted [https://github.com/intel/lms/pull/4]
-
-Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
----
- CIM_Framework/CMakeLists.txt | 1 +
- 1 file changed, 1 insertion(+)
-
-diff --git a/CIM_Framework/CMakeLists.txt b/CIM_Framework/CMakeLists.txt
-index 9d287f9..60219b3 100644
---- a/CIM_Framework/CMakeLists.txt
-+++ b/CIM_Framework/CMakeLists.txt
-@@ -53,6 +53,7 @@ externalproject_add (openwsman
- -DUSE_PAM=OFF
- -DENABLE_EVENTING_SUPPORT=OFF
- -DBUILD_SHARED_LIBS=OFF
-+ -DBUILD_LIBCIM=OFF
- ${WSMAN_STATIC_RUNTIME}
- ${WSMAN_ARCH}
- ${USE_TOOLCHAIN}
---
-2.26.2
-
diff --git a/dynamic-layers/openembedded-layer/recipes-bsp/amt/files/lms_drop_rpath_2022.0.0.0.diff b/dynamic-layers/openembedded-layer/recipes-bsp/amt/files/lms_drop_rpath_2022.0.0.0.diff
deleted file mode 100644
index e000a160..00000000
--- a/dynamic-layers/openembedded-layer/recipes-bsp/amt/files/lms_drop_rpath_2022.0.0.0.diff
+++ /dev/null
@@ -1,30 +0,0 @@
-From ec7d732a6a23e90be34840b0f1a57e5199d393cf Mon Sep 17 00:00:00 2001
-From: Alexander Usyskin <alexander.usyskin@intel.com>
-Date: Mon, 17 Jun 2019 13:27:33 +0300
-Subject: [PATCH] lms: drop rpath definitions
-
-Yocto fail to compile with this definitions.
-
-Upstream-Status: Inappropriate [configuration]
-Signed-off-by: Alexander Usyskin <alexander.usyskin@intel.com>
----
- CMakeLists.txt | 3 ---
- 1 file changed, 3 deletions(-)
-
-diff --git a/CMakeLists.txt b/CMakeLists.txt
-index e22ff05..14d5dd1 100644
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -112,9 +112,6 @@ install (DIRECTORY Docs/Licenses
- FILES_MATCHING PATTERN "LICENSE.*"
- )
-
--list (APPEND CMAKE_INSTALL_RPATH "${PROJECT_BINARY_DIR}/UNS/GMS_COMMON")
--list (APPEND CMAKE_INSTALL_RPATH "${PROJECT_BINARY_DIR}/WsmanClient")
--
- if (BUILD_TESTS)
- include (gtest.cmake)
- endif (BUILD_TESTS)
---
-2.7.4
-
diff --git a/dynamic-layers/openembedded-layer/recipes-bsp/amt/lms_2022.0.0.0.bb b/dynamic-layers/openembedded-layer/recipes-bsp/amt/lms_2022.0.0.0.bb
deleted file mode 100644
index 4b1e35f0..00000000
--- a/dynamic-layers/openembedded-layer/recipes-bsp/amt/lms_2022.0.0.0.bb
+++ /dev/null
@@ -1,39 +0,0 @@
-SUMMARY = "Intel(R) Local Managability Service"
-DESCRIPTION = "Intel Local Manageability Service allows applications \
-to access the Intel Active Management Technology (AMT) firmware via \
-the Intel Management Engine Interface (MEI)."
-
-LICENSE = "Apache-2.0"
-LIC_FILES_CHKSUM = "file://COPYING;md5=2ee41112a44fe7014dce33e26468ba93"
-
-COMPATIBLE_HOST = '(i.86|x86_64).*-linux'
-
-COMPATIBLE_HOST_libc-musl = "null"
-
-inherit cmake systemd features_check
-
-DEPENDS = "metee ace xerces-c libnl libxml2 glib-2.0 glib-2.0-native connman"
-
-EXTRA_OECMAKE += "-DPYTHON_EXECUTABLE=${HOSTTOOLS_DIR}/python3"
-
-REQUIRED_DISTRO_FEATURES= "systemd"
-
-FILES_${PN} += "${datadir}/dbus-1/system-services/*.service"
-
-S = "${WORKDIR}/git"
-
-SYSTEMD_SERVICE_${PN} = "lms.service"
-
-SRC_URI = "git://github.com/intel/lms.git \
- file://0001-CIM_Framework-CMakeLists.txt-turn-OFF-BUILD_LIBCIM.patch \
- "
-SRCREV = "597783800b000091e05855f1e7431555216e77da"
-
-SRC_URI_append = " file://lms_drop_rpath_${PV}.diff"
-
-do_install_append() {
- install -d ${D}${systemd_system_unitdir}
- install -m 0644 ${B}/UNS/lms.service ${D}${systemd_system_unitdir}
-}
-
-RDEPENDS_${PN} += "ace"
diff --git a/dynamic-layers/openembedded-layer/recipes-bsp/amt/lms_2406.0.0.0.bb b/dynamic-layers/openembedded-layer/recipes-bsp/amt/lms_2406.0.0.0.bb
new file mode 100644
index 00000000..bdf32576
--- /dev/null
+++ b/dynamic-layers/openembedded-layer/recipes-bsp/amt/lms_2406.0.0.0.bb
@@ -0,0 +1,44 @@
+SUMMARY = "Intel(R) Local Managability Service"
+DESCRIPTION = "Intel Local Manageability Service allows applications \
+to access the Intel Active Management Technology (AMT) firmware via \
+the Intel Management Engine Interface (MEI)."
+
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://COPYING;md5=2ee41112a44fe7014dce33e26468ba93"
+
+COMPATIBLE_HOST = '(i.86|x86_64).*-linux'
+
+COMPATIBLE_HOST:libc-musl = "null"
+
+inherit cmake systemd features_check python3native
+
+DEPENDS = "metee ace xerces-c libnl libxml2 glib-2.0 glib-2.0-native pkgconfig-native python3-packaging-native"
+
+# Enable either connman or networkmanager or none but not both.
+PACKAGECONFIG ??= "connman"
+PACKAGECONFIG[connman] = "-DNETWORK_CN=ON, -DNETWORK_CN=OFF, connman"
+PACKAGECONFIG[networkmanager] = "-DNETWORK_NM=ON, -DNETWORK_NM=OFF, networkmanager"
+
+REQUIRED_DISTRO_FEATURES= "systemd"
+
+FILES:${PN} += "${datadir}/dbus-1/system-services/*.service"
+
+S = "${WORKDIR}/git"
+
+SYSTEMD_SERVICE:${PN} = "lms.service"
+
+SRC_URI = "git://github.com/intel/lms.git;branch=master;protocol=https \
+ "
+SRCREV = "388f115b2aeb3ea11499971c65f828daefd32c47"
+
+do_install:append() {
+ install -d ${D}${sysconfdir}/lms
+ install -d ${D}${systemd_system_unitdir}
+ install -m 0644 ${B}/UNS/lms.service ${D}${systemd_system_unitdir}
+ install -d ${D}${sysconfdir}/udev/rules.d
+ install -m 0644 ${S}/UNS/linux_scripts/70-mei-wdt.rules ${D}${sysconfdir}/udev/rules.d/70-mei-wdt.rules
+}
+
+RDEPENDS:${PN} += "ace"
+
+CVE_STATUS[CVE-2018-1000535] = "cpe-incorrect: This CVE is for a different LMS - Lan Management System."
diff --git a/dynamic-layers/openembedded-layer/recipes-bsp/thermald/files/0001-Makefile-Fix-build-Issue.patch b/dynamic-layers/openembedded-layer/recipes-bsp/thermald/files/0001-Makefile-Fix-build-Issue.patch
new file mode 100644
index 00000000..ea86bc31
--- /dev/null
+++ b/dynamic-layers/openembedded-layer/recipes-bsp/thermald/files/0001-Makefile-Fix-build-Issue.patch
@@ -0,0 +1,35 @@
+From 1f6f4e29769adb9d49a3c4831dd2ba61f6ccbdce Mon Sep 17 00:00:00 2001
+From: Yogesh Tyagi <yogesh.tyagi@intel.com>
+Date: Mon, 11 Mar 2024 13:13:32 +0800
+Subject: [PATCH] Makefile: Fix build Issue
+MIME-Version: 1.0
+Content-Type: text/plain; charset=UTF-8
+Content-Transfer-Encoding: 8bit
+
+In case build directory is different from source, make sure make is able to find the correct input files.
+
+Fixes:
+| dbus-binding-tool --prefix=thd_dbus_interface --mode=glib-server --output=thd_dbus_interface.h ../git/src/thd_dbus_interface.xml
+| glib-compile-resources --generate-source thermald-resource.gresource.xml
+| Failed to open file “thermald-resource.gresource.xml”: No such file or directory
+
+Upstream-Status: Submitted
+https://github.com/intel/thermal_daemon/pull/436
+
+Signed-off-by: Yogesh Tyagi <yogesh.tyagi@intel.com>
+---
+ Makefile.am | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/Makefile.am b/Makefile.am
+index dd2ef10..cb19e17 100644
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -97,6 +97,6 @@ thd_dbus_interface.h: $(top_srcdir)/src/thd_dbus_interface.xml
+ $(AM_V_GEN) dbus-binding-tool --prefix=thd_dbus_interface --mode=glib-server --output=$@ $<
+
+ thermald-resource.c: $(top_srcdir)/thermald-resource.gresource.xml
+- $(AM_V_GEN) glib-compile-resources --generate-source thermald-resource.gresource.xml
++ $(AM_V_GEN) glib-compile-resources --generate-source --sourcedir=${top_srcdir} $<
+
+ CLEANFILES = $(BUILT_SOURCES)
diff --git a/dynamic-layers/openembedded-layer/recipes-bsp/thermald/thermald_2.5.7.bb b/dynamic-layers/openembedded-layer/recipes-bsp/thermald/thermald_2.5.7.bb
new file mode 100644
index 00000000..66765e56
--- /dev/null
+++ b/dynamic-layers/openembedded-layer/recipes-bsp/thermald/thermald_2.5.7.bb
@@ -0,0 +1,45 @@
+SUMMARY = "Linux thermal daemon"
+
+DESCRIPTION = "Thermal Daemon is a Linux daemon used to prevent the \
+overheating of platforms. This daemon monitors temperature and applies \
+compensation using available cooling methods."
+
+HOMEPAGE = "https://github.com/01org/thermal_daemon"
+
+DEPENDS = "dbus dbus-glib dbus-glib-native libxml2 glib-2.0 glib-2.0-native upower libevdev"
+DEPENDS += "autoconf-archive-native"
+
+LICENSE = "GPL-2.0-only"
+LIC_FILES_CHKSUM = "file://COPYING;md5=ea8831610e926e2e469075b52bf08848"
+
+SRC_URI = "git://github.com/intel/thermal_daemon/;branch=master;protocol=https \
+ file://0001-Makefile-Fix-build-Issue.patch \
+ "
+
+SRCREV = "ea8b773f76641a7a49d6584669e17371c22ad03e"
+S = "${WORKDIR}/git"
+
+inherit pkgconfig autotools systemd gtk-doc
+
+# gtkdocsize runs before autotools do_configure and it copies gtk-doc.m4 and fails
+# to copy becuase there is no m4 dir yet.
+do_configure:prepend () {
+ mkdir -p ${S}/m4
+}
+
+EXTRA_OECONF = " \
+ --with-systemdsystemunitdir=${systemd_system_unitdir} \
+ "
+
+FILES:${PN} += "${datadir}/dbus-1"
+
+SYSTEMD_SERVICE:${PN} = "thermald.service"
+
+COMPATIBLE_HOST = '(i.86|x86_64).*-linux'
+
+CONFFILES:${PN} = " \
+ ${sysconfdir}/thermald/thermal-conf.xml \
+ ${sysconfdir}/thermald/thermal-cpu-cdev-order.xml \
+ "
+
+UPSTREAM_CHECK_URI = "https://github.com/01org/thermal_daemon/releases"