aboutsummaryrefslogtreecommitdiffstats
path: root/dynamic-layers/meta-python
diff options
context:
space:
mode:
Diffstat (limited to 'dynamic-layers/meta-python')
-rw-r--r--dynamic-layers/meta-python/recipes-opencv/dldt/openvino-model-optimizer_2024.1.0.bb (renamed from dynamic-layers/meta-python/recipes-opencv/dldt/openvino-model-optimizer_2020.4.bb)24
1 files changed, 12 insertions, 12 deletions
diff --git a/dynamic-layers/meta-python/recipes-opencv/dldt/openvino-model-optimizer_2020.4.bb b/dynamic-layers/meta-python/recipes-opencv/dldt/openvino-model-optimizer_2024.1.0.bb
index 996633b3..de765d6c 100644
--- a/dynamic-layers/meta-python/recipes-opencv/dldt/openvino-model-optimizer_2020.4.bb
+++ b/dynamic-layers/meta-python/recipes-opencv/dldt/openvino-model-optimizer_2024.1.0.bb
@@ -5,29 +5,29 @@ environment, performs static model analysis, and adjusts deep \
learning models for optimal execution on end-point target devices."
HOMEPAGE = "https://01.org/openvinotoolkit"
-SRC_URI = "git://github.com/openvinotoolkit/openvino.git;protocol=https;branch=releases/2020/4;lfs=0 \
+SRC_URI = "git://github.com/openvinotoolkit/openvino.git;protocol=https;branch=releases/2024/1;lfs=0 \
"
-SRCREV = "023e7c2c3f8a8ac83564db09799d2049115d9cf6"
+SRCREV = "f4afc983258bcb2592d999ed6700043fdb58ad78"
LICENSE = "Apache-2.0"
LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327"
CVE_PRODUCT = "intel:openvino"
-
S = "${WORKDIR}/git"
-do_install() {
- mkdir -p ${D}${datadir}/openvino/model-optimizer
- cp -r model-optimizer ${D}${datadir}/openvino/
-}
+inherit setuptools3
-RDEPENDS_${PN} += " \
- python3-numpy \
- python3-protobuf \
+SETUPTOOLS_SETUP_PATH = "${WORKDIR}/git/tools/mo"
+
+RDEPENDS:${PN} += " \
python3-defusedxml \
+ python3-fastjsonschema \
python3-networkx \
- python3-test-generator \
+ python3-numpy \
+ python3-protobuf \
+ python3-requests \
+ python3-urllib3 \
bash \
"
-FILES_${PN} += "${datadir}/openvino"
+UPSTREAM_CHECK_GITTAGREGEX = "(?P<pver>(\d+\.\d+\.\d+))$"