aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-multimedia/alsa/alsa-lib/0006-add-conf-for-iMX-XCVR-sound-card.patch
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-multimedia/alsa/alsa-lib/0006-add-conf-for-iMX-XCVR-sound-card.patch')
-rw-r--r--recipes-multimedia/alsa/alsa-lib/0006-add-conf-for-iMX-XCVR-sound-card.patch76
1 files changed, 23 insertions, 53 deletions
diff --git a/recipes-multimedia/alsa/alsa-lib/0006-add-conf-for-iMX-XCVR-sound-card.patch b/recipes-multimedia/alsa/alsa-lib/0006-add-conf-for-iMX-XCVR-sound-card.patch
index bd1512e9..1f558185 100644
--- a/recipes-multimedia/alsa/alsa-lib/0006-add-conf-for-iMX-XCVR-sound-card.patch
+++ b/recipes-multimedia/alsa/alsa-lib/0006-add-conf-for-iMX-XCVR-sound-card.patch
@@ -1,25 +1,25 @@
-From cfbe756d55a303803805d3e8e3d3cf3b97866964 Mon Sep 17 00:00:00 2001
+From 36aae65dc913e1ebe72366d7ae361897d465e88d Mon Sep 17 00:00:00 2001
From: Viorel Suman <viorel.suman@nxp.com>
Date: Mon, 9 Mar 2020 14:25:46 +0200
Subject: [PATCH] add conf for iMX XCVR sound card
-Upstream Status: Pending
+Upstream-Status: Pending
Signed-off-by: Viorel Suman <viorel.suman@nxp.com>
---
- src/conf/cards/IMX-XCVR.conf | 69 ++++++++++++++++++++++++++++++++++++
- src/conf/cards/Makefile.am | 3 +-
+ src/conf/cards/IMX-XCVR.conf | 39 ++++++++++++++++++++++++++++++++++++
+ src/conf/cards/Makefile.am | 3 ++-
src/conf/cards/aliases.conf | 1 +
- 3 files changed, 72 insertions(+), 1 deletion(-)
+ 3 files changed, 42 insertions(+), 1 deletion(-)
create mode 100755 src/conf/cards/IMX-XCVR.conf
diff --git a/src/conf/cards/IMX-XCVR.conf b/src/conf/cards/IMX-XCVR.conf
new file mode 100755
-index 0000000..ee323c7
+index 0000000..009000c
--- /dev/null
+++ b/src/conf/cards/IMX-XCVR.conf
-@@ -0,0 +1,69 @@
+@@ -0,0 +1,39 @@
+#
+# Configuration for the IMX-XCVR sound card using software IEC958
+# subframe conversion
@@ -27,21 +27,10 @@ index 0000000..ee323c7
+IMX-XCVR.pcm.default {
+ @args [ CARD ]
+ @args.CARD { type string }
-+ type asym
-+ playback.pcm {
-+ type linear
-+ slave.pcm {
-+ @func concat
-+ strings [ "iec958:" $CARD ]
-+ }
-+ slave.format S24_LE
-+ }
-+ capture.pcm {
-+ type plug
-+ slave.pcm {
-+ @func concat
-+ strings [ "iec958:" $CARD ]
-+ }
++ type plug
++ slave.pcm {
++ @func concat
++ strings [ "iec958:" $CARD ]
+ }
+}
+
@@ -54,40 +43,21 @@ index 0000000..ee323c7
+ @args.AES1 { type integer }
+ @args.AES2 { type integer }
+ @args.AES3 { type integer }
-+ type asym
-+ playback.pcm {
-+ type hooks
-+ slave.pcm {
-+ type hw
-+ card $CARD
-+ }
-+ hooks.0 {
-+ type ctl_elems
-+ hook_args [
-+ {
-+ interface PCM
-+ name "IEC958 Playback Default"
-+ preserve true
-+ optional true
-+ value [ $AES0 $AES1 $AES2 $AES3 ]
-+ }
-+ ]
-+ }
-+ }
-+ capture.pcm {
-+ type iec958
-+ slave {
-+ format IEC958_SUBFRAME_LE
-+ pcm {
-+ type plug
-+ slave.pcm {
-+ type hw
-+ card $CARD
-+ }
++ type iec958
++ slave {
++ format IEC958_SUBFRAME_LE
++ pcm {
++ type plug
++ slave.pcm {
++ type hw
++ card $CARD
+ }
+ }
-+ status [ $AES0 $AES1 $AES2 $AES3 ]
+ }
++ status [ $AES0 $AES1 $AES2 $AES3 ]
++ preamble.z 0x0
++ preamble.x 0x1
++ preamble.y 0x3
+}
diff --git a/src/conf/cards/Makefile.am b/src/conf/cards/Makefile.am
index 34fa5a3..70b9bab 100644