aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-kernel/kernel-modules/kernel-module-isp-vvcam_4.2.2.24.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-kernel/kernel-modules/kernel-module-isp-vvcam_4.2.2.24.0.bb')
-rw-r--r--recipes-kernel/kernel-modules/kernel-module-isp-vvcam_4.2.2.24.0.bb20
1 files changed, 20 insertions, 0 deletions
diff --git a/recipes-kernel/kernel-modules/kernel-module-isp-vvcam_4.2.2.24.0.bb b/recipes-kernel/kernel-modules/kernel-module-isp-vvcam_4.2.2.24.0.bb
new file mode 100644
index 00000000..d5804634
--- /dev/null
+++ b/recipes-kernel/kernel-modules/kernel-module-isp-vvcam_4.2.2.24.0.bb
@@ -0,0 +1,20 @@
+# Copyright 2020-2023 NXP
+
+DESCRIPTION = "Kernel loadable module for ISP"
+LICENSE = "GPL-2.0-only"
+LIC_FILES_CHKSUM = "file://${S}/../LICENSE;md5=64381a6ea83b48c39fe524c85f65fb44"
+
+SRC_URI = "${ISP_KERNEL_SRC};branch=${SRCBRANCH}"
+ISP_KERNEL_SRC ?= "git://github.com/nxp-imx/isp-vvcam.git;protocol=https"
+SRCBRANCH = "lf-6.1.55_2.2.0"
+SRCREV = "2c762259b979d7ec5a2e17df6ad823de49d43a28"
+
+S = "${WORKDIR}/git/vvcam/v4l2"
+
+inherit module
+
+DEBUG_PREFIX_MAP:prepend = " \
+ -fmacro-prefix-map=${WORKDIR}/git/vvcam=/usr/src/debug/${PN}/${EXTENDPE}${PV}-${PR} \
+ -fdebug-prefix-map=${WORKDIR}/git/vvcam=/usr/src/debug/${PN}/${EXTENDPE}${PV}-${PR} "
+
+COMPATIBLE_MACHINE = "(mx8mp-nxp-bsp)"