aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-graphics/imx-gpu-apitrace/imx-gpu-apitrace_10.0.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-graphics/imx-gpu-apitrace/imx-gpu-apitrace_10.0.0.bb')
-rw-r--r--recipes-graphics/imx-gpu-apitrace/imx-gpu-apitrace_10.0.0.bb25
1 files changed, 17 insertions, 8 deletions
diff --git a/recipes-graphics/imx-gpu-apitrace/imx-gpu-apitrace_10.0.0.bb b/recipes-graphics/imx-gpu-apitrace/imx-gpu-apitrace_10.0.0.bb
index bd041582..7d97f475 100644
--- a/recipes-graphics/imx-gpu-apitrace/imx-gpu-apitrace_10.0.0.bb
+++ b/recipes-graphics/imx-gpu-apitrace/imx-gpu-apitrace_10.0.0.bb
@@ -2,12 +2,12 @@
SUMMARY = "Samples for OpenGL ES"
LICENSE = "MIT"
LIC_FILES_CHKSUM = "file://LICENSE;md5=aeb969185a143c3c25130bc2c3ef9a50"
-DEPENDS = "imx-gpu-viv zlib libpng procps"
+DEPENDS = "zlib libpng procps"
-SRC_URI = "git://source.codeaurora.org/external/imx/apitrace-imx.git;protocol=https;branch=imx_10.0 \
+SRC_URI = "git://github.com/nxp-imx/apitrace-imx.git;protocol=https;branch=imx_10.0 \
file://0001-dlsym-workaround-glibc-2.34-build-failure.patch \
"
-SRCREV = "90a59407f1cddd31b4dac67e5a2500100eb091bc"
+SRCREV = "522cb2981289b7ba20d6dd4b4bf75097e079815b"
S = "${WORKDIR}/git"
@@ -18,11 +18,13 @@ PACKAGECONFIG_BACKEND:mx6-nxp-bsp = " \
bb.utils.contains('DISTRO_FEATURES', 'x11', 'x11', \
'', d), d)} \
"
-PACKAGECONFIG_BACKEND:mx7-nxp-bsp = "${PACKAGECONFIG_BACKEND:mx6-nxp-bsp}"
-PACKAGECONFIG_BACKEND:mx8-nxp-bsp = "waffle"
+PACKAGECONFIG_BACKEND:mx7-nxp-bsp = "${PACKAGECONFIG_BACKEND:mx6-nxp-bsp}"
+PACKAGECONFIG_BACKEND:mx8-nxp-bsp = "waffle"
+PACKAGECONFIG_BACKEND:mx95-nxp-bsp = "waffle"
-PACKAGECONFIG_GPU2D = ""
-PACKAGECONFIG_GPU2D:imxgpu2d = "vivante"
+PACKAGECONFIG_GPU2D = ""
+PACKAGECONFIG_GPU2D:imxgpu2d = "vivante"
+PACKAGECONFIG_GPU2D:mx95-nxp-bsp = ""
PACKAGECONFIG ??= " \
egl \
@@ -43,6 +45,13 @@ FILES:${PN} += " \
${libdir}/apitrace/scripts/* \
${libdir}/apitrace/wrappers/* \
"
-
+EXTRA_OECMAKE += "\
+ -DENABLE_GUI=OFF \
+ -DENABLE_STATIC_LIBGCC=OFF \
+ -DENABLE_STATIC_LIBSTDCXX=OFF \
+ -DPython3_ROOT_DIR=/usr/bin/python3-native \
+"
PACKAGE_ARCH = "${MACHINE_SOCARCH}"
COMPATIBLE_MACHINE = "(imxgpu)"
+SECURITY_CFLAGS:toolchain-clang = ""
+