aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-graphics/drm
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-graphics/drm')
-rw-r--r--recipes-graphics/drm/libdrm/0001-meson-add-libdrm-vivante-to-the-meson-meta-data.patch140
-rw-r--r--recipes-graphics/drm/libdrm_2.4.116.imx.bb (renamed from recipes-graphics/drm/libdrm_2.4.102.imx.bb)50
2 files changed, 25 insertions, 165 deletions
diff --git a/recipes-graphics/drm/libdrm/0001-meson-add-libdrm-vivante-to-the-meson-meta-data.patch b/recipes-graphics/drm/libdrm/0001-meson-add-libdrm-vivante-to-the-meson-meta-data.patch
deleted file mode 100644
index ae6b0ab7..00000000
--- a/recipes-graphics/drm/libdrm/0001-meson-add-libdrm-vivante-to-the-meson-meta-data.patch
+++ /dev/null
@@ -1,140 +0,0 @@
-From 45f48f8a5de59c04b0510c23853772bc970f411e Mon Sep 17 00:00:00 2001
-From: Max Krummenacher <max.krummenacher@toradex.com>
-Date: Thu, 9 Jan 2020 01:01:35 +0000
-Subject: [PATCH] meson: add libdrm-vivante to the meson meta data
-
-Upstream libdrm added the option to use meason as the buildsystem.
-Integrate Vivante into the relevant meson build information.
-
-Upstream-Status: Pending
-
-Signed-off-by: Max Krummenacher <max.krummenacher@toradex.com>
----
- meson.build | 14 +++++++++++++
- meson_options.txt | 7 +++++++
- vivante/meson.build | 50 +++++++++++++++++++++++++++++++++++++++++++++
- 3 files changed, 71 insertions(+)
- create mode 100644 vivante/meson.build
-
-diff --git a/meson.build b/meson.build
-index e292554a..f4740634 100644
---- a/meson.build
-+++ b/meson.build
-@@ -157,6 +157,15 @@ if _vc4 != 'false'
- with_vc4 = _vc4 == 'true' or ['arm', 'aarch64'].contains(host_machine.cpu_family())
- endif
-
-+with_vivante = false
-+_vivante = get_option('vivante')
-+if _vivante == 'true'
-+ if not with_atomics
-+ error('libdrm_vivante requires atomics.')
-+ endif
-+ with_vivante = true
-+endif
-+
- # XXX: Apparently only freebsd and dragonfly bsd actually need this (and
- # gnu/kfreebsd), not openbsd and netbsd
- with_libkms = false
-@@ -312,6 +321,7 @@ install_headers(
- 'include/drm/savage_drm.h', 'include/drm/sis_drm.h',
- 'include/drm/tegra_drm.h', 'include/drm/vc4_drm.h',
- 'include/drm/via_drm.h', 'include/drm/virtgpu_drm.h',
-+ 'include/drm/vivante_drm.h',
- subdir : 'libdrm',
- )
- if with_vmwgfx
-@@ -362,6 +372,9 @@ endif
- if with_etnaviv
- subdir('etnaviv')
- endif
-+if with_vivante
-+ subdir('vivante')
-+endif
- if with_man_pages
- subdir('man')
- endif
-@@ -382,5 +395,6 @@ message(' EXYNOS API @0@'.format(with_exynos))
- message(' Freedreno API @0@ (kgsl: @1@)'.format(with_freedreno, with_freedreno_kgsl))
- message(' Tegra API @0@'.format(with_tegra))
- message(' VC4 API @0@'.format(with_vc4))
-+message(' Vivante API @0@'.format(with_etnaviv))
- message(' Etnaviv API @0@'.format(with_etnaviv))
- message('')
-diff --git a/meson_options.txt b/meson_options.txt
-index 8af33f1c..dc69563d 100644
---- a/meson_options.txt
-+++ b/meson_options.txt
-@@ -95,6 +95,13 @@ option(
- choices : ['true', 'false', 'auto'],
- description : '''Enable support for vc4's KMS API.''',
- )
-+option(
-+ 'vivante',
-+ type : 'combo',
-+ value : 'false',
-+ choices : ['true', 'false', 'auto'],
-+ description : '''Enable support for vivante's propriatary experimental KMS API.''',
-+)
- option(
- 'etnaviv',
- type : 'combo',
-diff --git a/vivante/meson.build b/vivante/meson.build
-new file mode 100644
-index 00000000..f6adb598
---- /dev/null
-+++ b/vivante/meson.build
-@@ -0,0 +1,50 @@
-+# Copyright © 2017-2018 Intel Corporation
-+
-+# Permission is hereby granted, free of charge, to any person obtaining a copy
-+# of this software and associated documentation files (the "Software"), to deal
-+# in the Software without restriction, including without limitation the rights
-+# to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
-+# copies of the Software, and to permit persons to whom the Software is
-+# furnished to do so, subject to the following conditions:
-+
-+# The above copyright notice and this permission notice shall be included in
-+# all copies or substantial portions of the Software.
-+
-+# THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
-+# IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
-+# FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
-+# AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
-+# LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
-+# OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE
-+# SOFTWARE.
-+
-+
-+libdrm_vivante = shared_library(
-+ 'drm_vivante',
-+ [
-+ files(
-+ 'vivante_bo.c',
-+ ),
-+ config_file
-+ ],
-+ include_directories : [inc_root, inc_drm],
-+ link_with : libdrm,
-+ c_args : libdrm_c_args,
-+ dependencies : [dep_pthread_stubs, dep_rt, dep_atomic_ops],
-+ version : '1.0.0',
-+ install : true,
-+)
-+
-+pkg.generate(
-+ name : 'libdrm_vivante',
-+ libraries : libdrm_vivante,
-+ subdirs : ['.', 'libdrm'],
-+ version : meson.project_version(),
-+ requires_private : 'libdrm',
-+ description : 'Userspace interface to Vivante kernel DRM services',
-+)
-+
-+ext_libdrm_vivante = declare_dependency(
-+ link_with : [libdrm, libdrm_vivante],
-+ include_directories : [inc_drm, include_directories('.')],
-+)
---
-2.20.1
-
diff --git a/recipes-graphics/drm/libdrm_2.4.102.imx.bb b/recipes-graphics/drm/libdrm_2.4.116.imx.bb
index bffef407..ff23f35f 100644
--- a/recipes-graphics/drm/libdrm_2.4.102.imx.bb
+++ b/recipes-graphics/drm/libdrm_2.4.116.imx.bb
@@ -6,45 +6,46 @@ accelerated OpenGL drivers."
HOMEPAGE = "http://dri.freedesktop.org"
SECTION = "x11/base"
LICENSE = "MIT"
-LIC_FILES_CHKSUM = "file://xf86drm.c;beginline=9;endline=32;md5=c8a3b961af7667c530816761e949dc71"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=9eb1f4831351ab42d762c40b3ebb7add \
+ file://xf86drm.c;beginline=9;endline=32;md5=c8a3b961af7667c530816761e949dc71"
PROVIDES = "drm"
DEPENDS = "libpthread-stubs"
-IMX_LIBDRM_SRC ?= "git://source.codeaurora.org/external/imx/libdrm-imx.git;protocol=https;nobranch=1"
-IMX_LIBDRM_BRANCH ?= "libdrm-imx-2.4.102"
-SRC_URI = "${IMX_LIBDRM_SRC};branch=${IMX_LIBDRM_BRANCH} \
- file://0001-meson-add-libdrm-vivante-to-the-meson-meta-data.patch "
-SRCREV = "40ea53973b99b7df07f472318918a8c2b310e4a7"
+SRC_URI = "${IMX_LIBDRM_SRC};branch=${SRCBRANCH}"
+IMX_LIBDRM_SRC ?= "git://github.com/nxp-imx/libdrm-imx.git;protocol=https"
+SRCBRANCH = "libdrm-imx-2.4.116"
+SRCREV = "2f1797674f94572ae8c365c8cbffb0263337ed57"
+
S = "${WORKDIR}/git"
DEFAULT_PREFERENCE = "-1"
-COMPATIBLE_MACHINE = "(mx6|mx7|mx8)"
+COMPATIBLE_MACHINE = "(imx-nxp-bsp)"
inherit meson pkgconfig manpages
-PACKAGECONFIG ??= "libkms intel radeon amdgpu nouveau vmwgfx omap freedreno vc4 etnaviv install-test-programs"
-PACKAGECONFIG[libkms] = "-Dlibkms=true,-Dlibkms=false"
-PACKAGECONFIG[intel] = "-Dintel=true,-Dintel=false,libpciaccess"
-PACKAGECONFIG[radeon] = "-Dradeon=true,-Dradeon=false"
-PACKAGECONFIG[amdgpu] = "-Damdgpu=true,-Damdgpu=false"
-PACKAGECONFIG[nouveau] = "-Dnouveau=true,-Dnouveau=false"
-PACKAGECONFIG[vmwgfx] = "-Dvmwgfx=true,-Dvmwgfx=false"
-PACKAGECONFIG[omap] = "-Domap=true,-Domap=false"
-PACKAGECONFIG[exynos] = "-Dexynos=true,-Dexynos=false"
-PACKAGECONFIG[freedreno] = "-Dfreedreno=true,-Dfreedreno=false"
-PACKAGECONFIG[tegra] = "-Dtegra=true,-Dtegra=false"
-PACKAGECONFIG[vc4] = "-Dvc4=true,-Dvc4=false"
-PACKAGECONFIG[etnaviv] = "-Detnaviv=true,-Detnaviv=false"
+PACKAGECONFIG ??= "intel radeon amdgpu nouveau vmwgfx omap freedreno vc4 etnaviv tests install-test-programs"
+PACKAGECONFIG[intel] = "-Dintel=enabled,-Dintel=disabled,libpciaccess"
+PACKAGECONFIG[radeon] = "-Dradeon=enabled,-Dradeon=disabled"
+PACKAGECONFIG[amdgpu] = "-Damdgpu=enabled,-Damdgpu=disabled"
+PACKAGECONFIG[nouveau] = "-Dnouveau=enabled,-Dnouveau=disabled"
+PACKAGECONFIG[vmwgfx] = "-Dvmwgfx=enabled,-Dvmwgfx=disabled"
+PACKAGECONFIG[omap] = "-Domap=enabled,-Domap=disabled"
+PACKAGECONFIG[exynos] = "-Dexynos=enabled,-Dexynos=disabled"
+PACKAGECONFIG[freedreno] = "-Dfreedreno=enabled,-Dfreedreno=disabled"
+PACKAGECONFIG[tegra] = "-Dtegra=enabled,-Dtegra=disabled"
+PACKAGECONFIG[vc4] = "-Dvc4=enabled,-Dvc4=disabled"
+PACKAGECONFIG[etnaviv] = "-Detnaviv=enabled,-Detnaviv=disabled"
PACKAGECONFIG[freedreno-kgsl] = "-Dfreedreno-kgsl=true,-Dfreedreno-kgsl=false"
-PACKAGECONFIG[valgrind] = "-Dvalgrind=true,-Dvalgrind=false,valgrind"
+PACKAGECONFIG[valgrind] = "-Dvalgrind=enabled,-Dvalgrind=disabled,valgrind"
PACKAGECONFIG[install-test-programs] = "-Dinstall-test-programs=true,-Dinstall-test-programs=false"
-PACKAGECONFIG[cairo-tests] = "-Dcairo-tests=true,-Dcairo-tests=false"
+PACKAGECONFIG[cairo-tests] = "-Dcairo-tests=enabled,-Dcairo-tests=disabled"
+PACKAGECONFIG[tests] = "-Dtests=true,-Dtests=false"
PACKAGECONFIG[udev] = "-Dudev=true,-Dudev=false,udev"
-PACKAGECONFIG[manpages] = "-Dman-pages=true,-Dman-pages=false,libxslt-native xmlto-native"
+PACKAGECONFIG[manpages] = "-Dman-pages=enabled,-Dman-pages=disabled,libxslt-native xmlto-native python3-docutils-native"
ALLOW_EMPTY:${PN}-drivers = "1"
PACKAGES =+ "${PN}-tests ${PN}-drivers ${PN}-radeon ${PN}-nouveau ${PN}-omap \
- ${PN}-intel ${PN}-exynos ${PN}-kms ${PN}-freedreno ${PN}-amdgpu \
+ ${PN}-intel ${PN}-exynos ${PN}-freedreno ${PN}-amdgpu \
${PN}-etnaviv"
RRECOMMENDS:${PN}-drivers = "${PN}-radeon ${PN}-nouveau ${PN}-omap ${PN}-intel \
@@ -57,7 +58,6 @@ FILES:${PN}-nouveau = "${libdir}/libdrm_nouveau.so.*"
FILES:${PN}-omap = "${libdir}/libdrm_omap.so.*"
FILES:${PN}-intel = "${libdir}/libdrm_intel.so.*"
FILES:${PN}-exynos = "${libdir}/libdrm_exynos.so.*"
-FILES:${PN}-kms = "${libdir}/libkms*.so.*"
FILES:${PN}-freedreno = "${libdir}/libdrm_freedreno.so.*"
FILES:${PN}-amdgpu = "${libdir}/libdrm_amdgpu.so.* ${datadir}/${PN}/amdgpu.ids"
FILES:${PN}-etnaviv = "${libdir}/libdrm_etnaviv.so.*"