aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-extended/skmm-ep/skmm-ep_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-extended/skmm-ep/skmm-ep_git.bb')
-rw-r--r--recipes-extended/skmm-ep/skmm-ep_git.bb31
1 files changed, 31 insertions, 0 deletions
diff --git a/recipes-extended/skmm-ep/skmm-ep_git.bb b/recipes-extended/skmm-ep/skmm-ep_git.bb
new file mode 100644
index 00000000..ca5d6734
--- /dev/null
+++ b/recipes-extended/skmm-ep/skmm-ep_git.bb
@@ -0,0 +1,31 @@
+DESCRIPTION = "SKMM application for PCIe endpoint"
+SECTION = "skmm-ep"
+LICENSE = "BSD & GPLv2"
+LIC_FILES_CHKSUM = "file://Makefile;endline=30;md5=39e58bedc879163c9338596e52df5b1f"
+
+DEPENDS = "libedit openssl virtual/kernel"
+
+PACKAGE_ARCH = "${MACHINE_ARCH}"
+
+SRC_URI = "git://git.freescale.com/ppc/sdk/skmm-ep.git;nobranch=1 \
+ file://add-two-missing-header-files.patch \
+"
+SRCREV = "27156a6621c8f6d7f98210b1ca5cd97bde926875"
+
+COMPATIBLE_MACHINE = "(p4080ds|t4240qds|c293pcie)"
+
+S = "${WORKDIR}/git"
+
+EXTRA_OEMAKE = 'MACHINE=${MACHINE}'
+
+export LIBEDIT_CFLAGS = "`pkg-config --cflags libedit`"
+export LIBEDIT_LDFLAGS = "`pkg-config --libs --static libedit`"
+
+do_compile () {
+ export ARCH=${TARGET_ARCH}
+ oe_runmake
+}
+
+do_install () {
+ oe_runmake ARCH=${TARGET_ARCH} install DESTDIR=${D}
+}