aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-dpaa2/management-complex
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-dpaa2/management-complex')
-rw-r--r--recipes-dpaa2/management-complex/management-complex_10.14.1.bb41
-rw-r--r--recipes-dpaa2/management-complex/management-complex_10.20.4.bb41
-rw-r--r--recipes-dpaa2/management-complex/management-complex_10.29.0.bb41
-rw-r--r--recipes-dpaa2/management-complex/management-complex_10.37.0.bb (renamed from recipes-dpaa2/management-complex/management-complex_10.24.0.bb)7
4 files changed, 3 insertions, 127 deletions
diff --git a/recipes-dpaa2/management-complex/management-complex_10.14.1.bb b/recipes-dpaa2/management-complex/management-complex_10.14.1.bb
deleted file mode 100644
index 4d4f1dcd..00000000
--- a/recipes-dpaa2/management-complex/management-complex_10.14.1.bb
+++ /dev/null
@@ -1,41 +0,0 @@
-SUMMARY = "DPAA2 Management Complex Firmware"
-LICENSE = "NXP-Binary-EULA"
-LIC_FILES_CHKSUM = "file://NXP-Binary-EULA.txt;md5=afcb1213054384820390d410ab62105f"
-
-inherit deploy
-
-INHIBIT_DEFAULT_DEPS = "1"
-
-SRC_URI = "git://github.com/nxp/qoriq-mc-binary;nobranch=1;protocol=https"
-SRCREV = "408110ee632f6291545b0b156cd74e7e3b4612cc"
-
-S = "${WORKDIR}/git"
-
-REGLEX:ls2088a = "ls2088a"
-REGLEX:ls2080a = "ls2080a"
-REGLEX:ls1088a = "ls1088a"
-REGLEX:lx2160a = "lx2160a"
-
-do_install () {
- install -d ${D}/boot
- install -m 755 ${S}/${REGLEX}/*.itb ${D}/boot
-}
-
-do_deploy () {
- install -d ${DEPLOYDIR}/mc_app
- install -m 755 ${S}/${REGLEX}/*.itb ${DEPLOYDIR}/mc_app
- # make a symlink to the latest binary
- for mc_binary in `find ${DEPLOYDIR}/mc_app -type f -printf "%f\n" |sort`;do
- ln -sfT ${mc_binary} ${DEPLOYDIR}/mc_app/mc.itb
- done
-}
-addtask deploy before do_build after do_install
-
-PACKAGES += "${PN}-image"
-FILES:${PN}-image += "/boot"
-
-INHIBIT_PACKAGE_STRIP = "1"
-
-COMPATIBLE_MACHINE = "(qoriq-arm64)"
-PACKAGE_ARCH = "${MACHINE_ARCH}"
-
diff --git a/recipes-dpaa2/management-complex/management-complex_10.20.4.bb b/recipes-dpaa2/management-complex/management-complex_10.20.4.bb
deleted file mode 100644
index 07f26b29..00000000
--- a/recipes-dpaa2/management-complex/management-complex_10.20.4.bb
+++ /dev/null
@@ -1,41 +0,0 @@
-SUMMARY = "DPAA2 Management Complex Firmware"
-LICENSE = "NXP-Binary-EULA"
-LIC_FILES_CHKSUM = "file://NXP-Binary-EULA.txt;md5=73d4b970c18882e229e4bf1ada5bb8d6"
-
-inherit deploy
-
-INHIBIT_DEFAULT_DEPS = "1"
-
-SRC_URI = "git://github.com/nxp/qoriq-mc-binary;nobranch=1;protocol=https"
-SRCREV = "f73683596a7b72124d67b62e64f3dc2bb36b9321"
-
-S = "${WORKDIR}/git"
-
-REGLEX:ls2088a = "ls2088a"
-REGLEX:ls2080a = "ls2080a"
-REGLEX:ls1088a = "ls1088a"
-REGLEX:lx2160a = "lx2160a"
-
-do_install () {
- install -d ${D}/boot
- install -m 755 ${S}/${REGLEX}/*.itb ${D}/boot
-}
-
-do_deploy () {
- install -d ${DEPLOYDIR}/mc_app
- install -m 755 ${S}/${REGLEX}/*.itb ${DEPLOYDIR}/mc_app
- # make a symlink to the latest binary
- for mc_binary in `find ${DEPLOYDIR}/mc_app -type f -printf "%f\n" |sort`;do
- ln -sfT ${mc_binary} ${DEPLOYDIR}/mc_app/mc.itb
- done
-}
-addtask deploy before do_build after do_install
-
-PACKAGES += "${PN}-image"
-FILES:${PN}-image += "/boot"
-
-INHIBIT_PACKAGE_STRIP = "1"
-
-COMPATIBLE_MACHINE = "(qoriq-arm64)"
-PACKAGE_ARCH = "${MACHINE_ARCH}"
-
diff --git a/recipes-dpaa2/management-complex/management-complex_10.29.0.bb b/recipes-dpaa2/management-complex/management-complex_10.29.0.bb
deleted file mode 100644
index 08991f09..00000000
--- a/recipes-dpaa2/management-complex/management-complex_10.29.0.bb
+++ /dev/null
@@ -1,41 +0,0 @@
-SUMMARY = "DPAA2 Management Complex Firmware"
-LICENSE = "NXP-Binary-EULA"
-LIC_FILES_CHKSUM = "file://NXP-Binary-EULA.txt;md5=2cb2fee5d3558ee2a81331ed121647ad"
-
-inherit deploy
-
-INHIBIT_DEFAULT_DEPS = "1"
-
-SRC_URI = "git://github.com/nxp/qoriq-mc-binary;nobranch=1;protocol=https"
-SRCREV = "d21bc22000a14b0b6eeafc017fb93bc70499f74a"
-
-S = "${WORKDIR}/git"
-
-REGLEX:ls2088a = "ls2088a"
-REGLEX:ls2080a = "ls2080a"
-REGLEX:ls1088a = "ls1088a"
-REGLEX:lx2160a = "lx216xa"
-REGLEX:lx2162a = "lx216xa"
-
-do_install () {
- install -d ${D}/boot
- install -m 755 ${S}/${REGLEX}/*.itb ${D}/boot
-}
-
-do_deploy () {
- install -d ${DEPLOYDIR}/mc_app
- install -m 755 ${S}/${REGLEX}/*.itb ${DEPLOYDIR}/mc_app
- # make a symlink to the latest binary
- for mc_binary in `find ${DEPLOYDIR}/mc_app -type f -printf "%f\n" |sort`;do
- ln -sfT ${mc_binary} ${DEPLOYDIR}/mc_app/mc.itb
- done
-}
-addtask deploy before do_build after do_install
-
-PACKAGES += "${PN}-image"
-FILES:${PN}-image += "/boot"
-
-INHIBIT_PACKAGE_STRIP = "1"
-
-COMPATIBLE_MACHINE = "(qoriq-arm64)"
-PACKAGE_ARCH = "${MACHINE_ARCH}"
diff --git a/recipes-dpaa2/management-complex/management-complex_10.24.0.bb b/recipes-dpaa2/management-complex/management-complex_10.37.0.bb
index 3408fba0..d1877159 100644
--- a/recipes-dpaa2/management-complex/management-complex_10.24.0.bb
+++ b/recipes-dpaa2/management-complex/management-complex_10.37.0.bb
@@ -1,18 +1,17 @@
SUMMARY = "DPAA2 Management Complex Firmware"
LICENSE = "NXP-Binary-EULA"
-LIC_FILES_CHKSUM = "file://NXP-Binary-EULA.txt;md5=481d6288552113961a835bbabceb0c33"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=481d6288552113961a835bbabceb0c33"
inherit deploy
INHIBIT_DEFAULT_DEPS = "1"
-SRC_URI = "git://github.com/nxp/qoriq-mc-binary;nobranch=1;protocol=https"
-SRCREV = "324817697a4c89a9a940fb7dba1b18909913ee20"
+SRC_URI = "git://github.com/nxp/qoriq-mc-binary;protocol=https;nobranch=1"
+SRCREV = "bb19f586b87b97878b4bd0d3e57da2ca40c5c69f"
S = "${WORKDIR}/git"
REGLEX:ls2088a = "ls2088a"
-REGLEX:ls2080a = "ls2080a"
REGLEX:ls1088a = "ls1088a"
REGLEX:lx2160a = "lx216xa"
REGLEX:lx2162a = "lx216xa"