aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-dpaa2/management-complex/management-complex_10.20.4.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-dpaa2/management-complex/management-complex_10.20.4.bb')
-rw-r--r--recipes-dpaa2/management-complex/management-complex_10.20.4.bb41
1 files changed, 0 insertions, 41 deletions
diff --git a/recipes-dpaa2/management-complex/management-complex_10.20.4.bb b/recipes-dpaa2/management-complex/management-complex_10.20.4.bb
deleted file mode 100644
index 07f26b29..00000000
--- a/recipes-dpaa2/management-complex/management-complex_10.20.4.bb
+++ /dev/null
@@ -1,41 +0,0 @@
-SUMMARY = "DPAA2 Management Complex Firmware"
-LICENSE = "NXP-Binary-EULA"
-LIC_FILES_CHKSUM = "file://NXP-Binary-EULA.txt;md5=73d4b970c18882e229e4bf1ada5bb8d6"
-
-inherit deploy
-
-INHIBIT_DEFAULT_DEPS = "1"
-
-SRC_URI = "git://github.com/nxp/qoriq-mc-binary;nobranch=1;protocol=https"
-SRCREV = "f73683596a7b72124d67b62e64f3dc2bb36b9321"
-
-S = "${WORKDIR}/git"
-
-REGLEX:ls2088a = "ls2088a"
-REGLEX:ls2080a = "ls2080a"
-REGLEX:ls1088a = "ls1088a"
-REGLEX:lx2160a = "lx2160a"
-
-do_install () {
- install -d ${D}/boot
- install -m 755 ${S}/${REGLEX}/*.itb ${D}/boot
-}
-
-do_deploy () {
- install -d ${DEPLOYDIR}/mc_app
- install -m 755 ${S}/${REGLEX}/*.itb ${DEPLOYDIR}/mc_app
- # make a symlink to the latest binary
- for mc_binary in `find ${DEPLOYDIR}/mc_app -type f -printf "%f\n" |sort`;do
- ln -sfT ${mc_binary} ${DEPLOYDIR}/mc_app/mc.itb
- done
-}
-addtask deploy before do_build after do_install
-
-PACKAGES += "${PN}-image"
-FILES:${PN}-image += "/boot"
-
-INHIBIT_PACKAGE_STRIP = "1"
-
-COMPATIBLE_MACHINE = "(qoriq-arm64)"
-PACKAGE_ARCH = "${MACHINE_ARCH}"
-