aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--classes/imx-boot-container.bbclass2
-rw-r--r--recipes-bsp/u-boot/u-boot-fslc-common_2022.01.inc (renamed from recipes-bsp/u-boot/u-boot-fslc-common_2021.07.inc)6
-rw-r--r--recipes-bsp/u-boot/u-boot-fslc-mfgtool_2022.01.bb (renamed from recipes-bsp/u-boot/u-boot-fslc-mfgtool_2021.07.bb)0
-rw-r--r--recipes-bsp/u-boot/u-boot-fslc-mxsboot_2022.01.bb (renamed from recipes-bsp/u-boot/u-boot-fslc-mxsboot_2021.07.bb)0
-rw-r--r--recipes-bsp/u-boot/u-boot-fslc_2022.01.bb (renamed from recipes-bsp/u-boot/u-boot-fslc_2021.07.bb)0
-rw-r--r--wic/imx-boot-container-bootpart.wks.in13
6 files changed, 9 insertions, 12 deletions
diff --git a/classes/imx-boot-container.bbclass b/classes/imx-boot-container.bbclass
index 3ffa7cbd..19b43312 100644
--- a/classes/imx-boot-container.bbclass
+++ b/classes/imx-boot-container.bbclass
@@ -85,7 +85,6 @@ do_deploy:append() {
j=$(expr $j + 1);
if [ $j -eq $i ]
then
- install -m 0644 ${B}/${config}/u-boot.itb ${DEPLOYDIR}/u-boot.itb-${MACHINE}-${type}
install -m 0644 ${B}/${config}/flash.bin ${DEPLOYDIR}/flash.bin-${MACHINE}-${type}
# When there's more than one word in UBOOT_CONFIG,
# this will overwrite the links created in
@@ -94,7 +93,6 @@ do_deploy:append() {
# word in UBOOT_CONFIG. This is also how all other
# artifacts handled by oe-core's u-boot.inc are
# treated.
- ln -sf u-boot.itb-${MACHINE}-${type} u-boot.itb
ln -sf flash.bin-${MACHINE}-${type} flash.bin
fi
done
diff --git a/recipes-bsp/u-boot/u-boot-fslc-common_2021.07.inc b/recipes-bsp/u-boot/u-boot-fslc-common_2022.01.inc
index 7d401692..341e2802 100644
--- a/recipes-bsp/u-boot/u-boot-fslc-common_2021.07.inc
+++ b/recipes-bsp/u-boot/u-boot-fslc-common_2022.01.inc
@@ -10,10 +10,10 @@ DEPENDS += "flex-native bison-native"
SRC_URI = "git://github.com/Freescale/u-boot-fslc.git;branch=${SRCBRANCH};protocol=https"
-SRCREV = "691e634bfd317ede487d2b864a126847ffeb4aa7"
-SRCBRANCH = "2021.07+fslc"
+SRCREV = "ed9503daa309c765a8654dc89c486326b4850f6d"
+SRCBRANCH = "2022.01+fslc"
-PV = "v2021.07+git${SRCPV}"
+PV = "v2022.01+git${SRCPV}"
S = "${WORKDIR}/git"
B = "${WORKDIR}/build"
diff --git a/recipes-bsp/u-boot/u-boot-fslc-mfgtool_2021.07.bb b/recipes-bsp/u-boot/u-boot-fslc-mfgtool_2022.01.bb
index 2e79166b..2e79166b 100644
--- a/recipes-bsp/u-boot/u-boot-fslc-mfgtool_2021.07.bb
+++ b/recipes-bsp/u-boot/u-boot-fslc-mfgtool_2022.01.bb
diff --git a/recipes-bsp/u-boot/u-boot-fslc-mxsboot_2021.07.bb b/recipes-bsp/u-boot/u-boot-fslc-mxsboot_2022.01.bb
index a3a732ef..a3a732ef 100644
--- a/recipes-bsp/u-boot/u-boot-fslc-mxsboot_2021.07.bb
+++ b/recipes-bsp/u-boot/u-boot-fslc-mxsboot_2022.01.bb
diff --git a/recipes-bsp/u-boot/u-boot-fslc_2021.07.bb b/recipes-bsp/u-boot/u-boot-fslc_2022.01.bb
index 21989ae5..21989ae5 100644
--- a/recipes-bsp/u-boot/u-boot-fslc_2021.07.bb
+++ b/recipes-bsp/u-boot/u-boot-fslc_2022.01.bb
diff --git a/wic/imx-boot-container-bootpart.wks.in b/wic/imx-boot-container-bootpart.wks.in
index 88679a68..321ee46b 100644
--- a/wic/imx-boot-container-bootpart.wks.in
+++ b/wic/imx-boot-container-bootpart.wks.in
@@ -11,16 +11,15 @@
# U-Boot DTB file, ATF, and optional OP-TEE components.
#
# The disk layout used is:
-# - ----------- -------------- ----------------------------
-# | | flash.bin | u-boot.itb | boot | rootfs |
-# - ----------- -------------- ----------------------------
-# ^ ^ ^ ^ ^ ^
-# | | | | | |
-# 0 | 384KiB 8MiB 72MiB 72MiB + rootfs + IMAGE_EXTRA_SPACE (default 10MiB)
+# - ----------- -------------- -------------
+# | | flash.bin | boot | rootfs |
+# - ----------- -------------- -------------
+# ^ ^ ^ ^ ^
+# | | | | |
+# 0 | 8MiB 72MiB 72MiB + rootfs + IMAGE_EXTRA_SPACE (default 10MiB)
# ${IMX_BOOT_SEEK} 32 or 33kiB, see reference manual
#
part u-boot --source rawcopy --sourceparams="file=flash.bin" --ondisk mmcblk --no-table --align ${IMX_BOOT_SEEK}
-part u-boot-itb --source rawcopy --sourceparams="file=u-boot.itb" --ondisk mmcblk --no-table --align 384
part /boot --source bootimg-partition --ondisk mmcblk --fstype=vfat --label boot --active --align 8192 --size 64
part / --source rootfs --ondisk mmcblk --fstype=ext4 --label root --align 8192