aboutsummaryrefslogtreecommitdiffstats
path: root/meta-openstack/recipes-devtools
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openstack/recipes-devtools')
-rw-r--r--meta-openstack/recipes-devtools/python/python-cinder_2013.1.3.bb4
-rw-r--r--meta-openstack/recipes-devtools/python/python-glance_2013.1.3.bb5
-rw-r--r--meta-openstack/recipes-devtools/python/python-keystone_2013.1.3.bb4
-rw-r--r--meta-openstack/recipes-devtools/python/python-nova_2013.1.3.bb13
-rw-r--r--meta-openstack/recipes-devtools/python/python-quantum_2013.1.3.bb5
5 files changed, 14 insertions, 17 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-cinder_2013.1.3.bb b/meta-openstack/recipes-devtools/python/python-cinder_2013.1.3.bb
index 1cdcd98f..a6a10e53 100644
--- a/meta-openstack/recipes-devtools/python/python-cinder_2013.1.3.bb
+++ b/meta-openstack/recipes-devtools/python/python-cinder_2013.1.3.bb
@@ -57,10 +57,8 @@ pkg_postinst_${SRCNAME} () {
# This is to make sure postgres is configured and running
if ! pidof postmaster > /dev/null; then
- sudo -u postgres initdb -D /etc/postgresql/
+ /etc/init.d/postgresql-init
/etc/init.d/postgresql start
- sleep 0.2
- sudo -u postgres psql -c "CREATE ROLE ${DB_USER} WITH SUPERUSER LOGIN PASSWORD '${DB_PASSWORD}'"
fi
sudo -u postgres createdb cinder
diff --git a/meta-openstack/recipes-devtools/python/python-glance_2013.1.3.bb b/meta-openstack/recipes-devtools/python/python-glance_2013.1.3.bb
index 9bfd2624..ff81a0c7 100644
--- a/meta-openstack/recipes-devtools/python/python-glance_2013.1.3.bb
+++ b/meta-openstack/recipes-devtools/python/python-glance_2013.1.3.bb
@@ -65,10 +65,9 @@ pkg_postinst_${SRCNAME} () {
# This is to make sure postgres is configured and running
if ! pidof postmaster > /dev/null; then
- sudo -u postgres initdb -D /etc/postgresql/
+ /etc/init.d/postgresql-init
/etc/init.d/postgresql start
- sleep 0.2
- sudo -u postgres psql -c "CREATE ROLE ${DB_USER} WITH SUPERUSER LOGIN PASSWORD '${DB_PASSWORD}'"
+ sleep 5
fi
mkdir /var/log/glance
diff --git a/meta-openstack/recipes-devtools/python/python-keystone_2013.1.3.bb b/meta-openstack/recipes-devtools/python/python-keystone_2013.1.3.bb
index e1245837..387fa68c 100644
--- a/meta-openstack/recipes-devtools/python/python-keystone_2013.1.3.bb
+++ b/meta-openstack/recipes-devtools/python/python-keystone_2013.1.3.bb
@@ -58,11 +58,9 @@ pkg_postinst_${SRCNAME} () {
# This is to make sure postgres is configured and running
if ! pidof postmaster > /dev/null; then
- sudo -u postgres initdb -D /etc/postgresql/
- sleep 10
+ /etc/init.d/postgresql-init
/etc/init.d/postgresql start
sleep 5
- sudo -u postgres psql -c "CREATE ROLE ${DB_USER} WITH SUPERUSER LOGIN PASSWORD '${DB_PASSWORD}'"
fi
sudo -u postgres createdb keystone
diff --git a/meta-openstack/recipes-devtools/python/python-nova_2013.1.3.bb b/meta-openstack/recipes-devtools/python/python-nova_2013.1.3.bb
index c2dd1f3f..35525923 100644
--- a/meta-openstack/recipes-devtools/python/python-nova_2013.1.3.bb
+++ b/meta-openstack/recipes-devtools/python/python-nova_2013.1.3.bb
@@ -16,6 +16,7 @@ SRC_URI = "https://launchpad.net/${SRCNAME}/grizzly/${PV}/+download/${SRCNAME}-$
"
SRC_URI += "file://nova-all \
+ file://nova-compute \
file://nova-consoleauth \
file://nova-novncproxy \
file://nova.conf \
@@ -93,6 +94,7 @@ do_install_append() {
if ${@base_contains('DISTRO_FEATURES', 'sysvinit', 'true', 'false', d)}; then
install -d ${D}${sysconfdir}/init.d
install -m 0755 ${WORKDIR}/nova-all ${D}${sysconfdir}/init.d/nova-all
+ install -m 0755 ${WORKDIR}/nova-compute ${D}${sysconfdir}/init.d/nova-compute
install -m 0755 ${WORKDIR}/nova-consoleauth ${D}${sysconfdir}/init.d/nova-consoleauth
install -m 0755 ${WORKDIR}/nova-novncproxy ${D}${sysconfdir}/init.d/nova-novncproxy
fi
@@ -197,14 +199,15 @@ RDEPENDS_${SRCNAME}-common = "${PN} openssl openssl-misc libxml2 libxslt \
iptables curl dnsmasq sudo procps"
RDEPENDS_${SRCNAME}-controller = "${PN} ${SRCNAME}-common \
- ${SRCNAME}-consoleauth \
- ${SRCNAME}-novncproxy \
- postgresql postgresql-client python-psycopg2"
+ ${SRCNAME}-consoleauth \
+ ${SRCNAME}-novncproxy \
+ postgresql postgresql-client python-psycopg2"
RDEPENDS_${SRCNAME}-compute = "${PN} ${SRCNAME}-common \
- qemu libvirt libvirt-libvirtd libvirt-python libvirt-virsh"
+ qemu libvirt libvirt-libvirtd libvirt-python libvirt-virsh"
-INITSCRIPT_PACKAGES = "${SRCNAME}-controller ${SRCNAME}-consoleauth ${SRCNAME}-novncproxy"
+INITSCRIPT_PACKAGES = "${SRCNAME}-compute ${SRCNAME}-controller ${SRCNAME}-consoleauth ${SRCNAME}-novncproxy"
INITSCRIPT_NAME_${SRCNAME}-controller = "nova-all"
+INITSCRIPT_NAME_${SRCNAME}-compute = "nova-compute"
INITSCRIPT_NAME_${SRCNAME}-consoleauth = "nova-consoleauth"
INITSCRIPT_NAME_${SRCNAME}-novncproxy = "nova-novncproxy"
diff --git a/meta-openstack/recipes-devtools/python/python-quantum_2013.1.3.bb b/meta-openstack/recipes-devtools/python/python-quantum_2013.1.3.bb
index 34da3c9a..8198e6a1 100644
--- a/meta-openstack/recipes-devtools/python/python-quantum_2013.1.3.bb
+++ b/meta-openstack/recipes-devtools/python/python-quantum_2013.1.3.bb
@@ -74,10 +74,9 @@ pkg_postinst_${SRCNAME} () {
# This is to make sure postgres is configured and running
if ! pidof postmaster > /dev/null; then
- sudo -u postgres initdb -D /etc/postgresql/
+ /etc/init.d/postgresql-init
/etc/init.d/postgresql start
- sleep 0.2
- sudo -u postgres psql -c "CREATE ROLE ${DB_USER} WITH SUPERUSER LOGIN PASSWORD '${DB_PASSWORD}'"
+ sleep 5
fi
sudo -u postgres createdb ovs_quantum