aboutsummaryrefslogtreecommitdiffstats
path: root/meta-openstack/recipes-devtools/ruby
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openstack/recipes-devtools/ruby')
-rw-r--r--meta-openstack/recipes-devtools/ruby/bundler_git.bb2
-rw-r--r--meta-openstack/recipes-devtools/ruby/chef-zero_git.bb2
-rw-r--r--meta-openstack/recipes-devtools/ruby/coderay_git.bb2
-rw-r--r--meta-openstack/recipes-devtools/ruby/diff-lcs_git.bb2
-rw-r--r--meta-openstack/recipes-devtools/ruby/erubis_git.bb2
-rw-r--r--meta-openstack/recipes-devtools/ruby/hashie_git.bb2
-rw-r--r--meta-openstack/recipes-devtools/ruby/highline_git.bb2
-rw-r--r--meta-openstack/recipes-devtools/ruby/ipaddress_git.bb2
-rw-r--r--meta-openstack/recipes-devtools/ruby/json_git.bb2
-rw-r--r--meta-openstack/recipes-devtools/ruby/method-source_git.bb2
-rw-r--r--meta-openstack/recipes-devtools/ruby/mime-types_git.bb2
-rw-r--r--meta-openstack/recipes-devtools/ruby/mixlib-authentication_git.bb2
-rw-r--r--meta-openstack/recipes-devtools/ruby/mixlib-cli_git.bb2
-rw-r--r--meta-openstack/recipes-devtools/ruby/mixlib-config_git.bb2
-rw-r--r--meta-openstack/recipes-devtools/ruby/mixlib-log_git.bb2
-rw-r--r--meta-openstack/recipes-devtools/ruby/mixlib-shellout_git.bb2
-rw-r--r--meta-openstack/recipes-devtools/ruby/net-ssh-gateway_git.bb2
-rw-r--r--meta-openstack/recipes-devtools/ruby/net-ssh-multi_git.bb2
-rw-r--r--meta-openstack/recipes-devtools/ruby/net-ssh_git.bb2
-rw-r--r--meta-openstack/recipes-devtools/ruby/ohai_git.bb2
-rw-r--r--meta-openstack/recipes-devtools/ruby/pry_git.bb2
-rw-r--r--meta-openstack/recipes-devtools/ruby/rack_git.bb2
-rw-r--r--meta-openstack/recipes-devtools/ruby/rest-client_git.bb2
-rw-r--r--meta-openstack/recipes-devtools/ruby/slop_git.bb2
-rw-r--r--meta-openstack/recipes-devtools/ruby/systemu_git.bb2
-rw-r--r--meta-openstack/recipes-devtools/ruby/yard_git.bb2
26 files changed, 26 insertions, 26 deletions
diff --git a/meta-openstack/recipes-devtools/ruby/bundler_git.bb b/meta-openstack/recipes-devtools/ruby/bundler_git.bb
index f7617a0c..a4300a27 100644
--- a/meta-openstack/recipes-devtools/ruby/bundler_git.bb
+++ b/meta-openstack/recipes-devtools/ruby/bundler_git.bb
@@ -25,7 +25,7 @@ SRCREV = "06e3647c117da210ffd15a174624497830addd7b"
S = "${WORKDIR}/git"
SRC_URI = " \
- git://github.com/bundler/bundler.git;branch=1-7-stable \
+ git://github.com/bundler/bundler.git;branch=1-7-stable;protocol=https \
"
inherit ruby
diff --git a/meta-openstack/recipes-devtools/ruby/chef-zero_git.bb b/meta-openstack/recipes-devtools/ruby/chef-zero_git.bb
index 993e2926..199fd41e 100644
--- a/meta-openstack/recipes-devtools/ruby/chef-zero_git.bb
+++ b/meta-openstack/recipes-devtools/ruby/chef-zero_git.bb
@@ -21,7 +21,7 @@ SRCREV = "28fe2928469885b0138de4d4270c6eccac8ab482"
S = "${WORKDIR}/git"
SRC_URI = " \
- git://github.com/opscode/chef-zero.git;branch=master \
+ git://github.com/opscode/chef-zero.git;branch=master;protocol=https \
"
inherit ruby
diff --git a/meta-openstack/recipes-devtools/ruby/coderay_git.bb b/meta-openstack/recipes-devtools/ruby/coderay_git.bb
index 72fb420e..a45942f6 100644
--- a/meta-openstack/recipes-devtools/ruby/coderay_git.bb
+++ b/meta-openstack/recipes-devtools/ruby/coderay_git.bb
@@ -16,7 +16,7 @@ SRCREV = "a48037b85a12228431b32103786456f36beb355f"
S = "${WORKDIR}/git"
SRC_URI = " \
- git://github.com/rubychan/coderay.git;branch=master \
+ git://github.com/rubychan/coderay.git;branch=master;protocol=https \
"
inherit ruby
diff --git a/meta-openstack/recipes-devtools/ruby/diff-lcs_git.bb b/meta-openstack/recipes-devtools/ruby/diff-lcs_git.bb
index 24c64359..6f6758c0 100644
--- a/meta-openstack/recipes-devtools/ruby/diff-lcs_git.bb
+++ b/meta-openstack/recipes-devtools/ruby/diff-lcs_git.bb
@@ -20,7 +20,7 @@ SRCREV = "704bc2c0000b5f9bf49d607dcd0d3989b63b2595"
S = "${WORKDIR}/git"
SRC_URI = " \
- git://github.com/halostatue/diff-lcs.git;branch=master \
+ git://github.com/halostatue/diff-lcs.git;branch=master;protocol=https \
"
inherit ruby
diff --git a/meta-openstack/recipes-devtools/ruby/erubis_git.bb b/meta-openstack/recipes-devtools/ruby/erubis_git.bb
index b9c2e072..16fd5429 100644
--- a/meta-openstack/recipes-devtools/ruby/erubis_git.bb
+++ b/meta-openstack/recipes-devtools/ruby/erubis_git.bb
@@ -16,7 +16,7 @@ SRCREV = "1f0b38d9e66885f8af0244d12d1a6702fc04a8de"
S = "${WORKDIR}/git"
SRC_URI = " \
- git://github.com/kwatch/erubis.git;branch=master \
+ git://github.com/kwatch/erubis.git;branch=master;protocol=https \
"
inherit ruby
diff --git a/meta-openstack/recipes-devtools/ruby/hashie_git.bb b/meta-openstack/recipes-devtools/ruby/hashie_git.bb
index f68547a1..65ccb119 100644
--- a/meta-openstack/recipes-devtools/ruby/hashie_git.bb
+++ b/meta-openstack/recipes-devtools/ruby/hashie_git.bb
@@ -16,7 +16,7 @@ SRCREV = "02df8918dd07ef2da1aceba5fd17e8757027345a"
S = "${WORKDIR}/git"
SRC_URI = " \
- git://github.com/intridea/hashie.git;branch=master \
+ git://github.com/intridea/hashie.git;branch=master;protocol=https \
"
inherit ruby
diff --git a/meta-openstack/recipes-devtools/ruby/highline_git.bb b/meta-openstack/recipes-devtools/ruby/highline_git.bb
index 10322553..56965345 100644
--- a/meta-openstack/recipes-devtools/ruby/highline_git.bb
+++ b/meta-openstack/recipes-devtools/ruby/highline_git.bb
@@ -22,7 +22,7 @@ SRCREV = "327051c1c217df2880c3a53f31484f7e815e847f"
S = "${WORKDIR}/git"
SRC_URI = " \
- git://github.com/JEG2/highline.git;branch=master \
+ git://github.com/JEG2/highline.git;branch=master;protocol=https \
"
inherit ruby
diff --git a/meta-openstack/recipes-devtools/ruby/ipaddress_git.bb b/meta-openstack/recipes-devtools/ruby/ipaddress_git.bb
index d7554265..29a89336 100644
--- a/meta-openstack/recipes-devtools/ruby/ipaddress_git.bb
+++ b/meta-openstack/recipes-devtools/ruby/ipaddress_git.bb
@@ -20,7 +20,7 @@ SRCREV = "96aaf68210d644157bd57a6ec3e38c49f38bfc34"
S = "${WORKDIR}/git"
SRC_URI = " \
- git://github.com/ipaddress-gem/ipaddress.git;branch=master \
+ git://github.com/ipaddress-gem/ipaddress.git;branch=master;protocol=https \
"
inherit ruby
diff --git a/meta-openstack/recipes-devtools/ruby/json_git.bb b/meta-openstack/recipes-devtools/ruby/json_git.bb
index f7b3dd79..407f812f 100644
--- a/meta-openstack/recipes-devtools/ruby/json_git.bb
+++ b/meta-openstack/recipes-devtools/ruby/json_git.bb
@@ -16,7 +16,7 @@ SRCREV = "4cf6c6270f52888997ec1b626b9f557db4f26f2e"
S = "${WORKDIR}/git"
SRC_URI = " \
- git://github.com/flori/json.git;branch=v1.8 \
+ git://github.com/flori/json.git;branch=v1.8;protocol=https \
"
inherit ruby
diff --git a/meta-openstack/recipes-devtools/ruby/method-source_git.bb b/meta-openstack/recipes-devtools/ruby/method-source_git.bb
index 8ac3e011..6756f998 100644
--- a/meta-openstack/recipes-devtools/ruby/method-source_git.bb
+++ b/meta-openstack/recipes-devtools/ruby/method-source_git.bb
@@ -16,7 +16,7 @@ SRCREV = "1b1f8323a7c25f29331fe32511f50697e5405dbd"
S = "${WORKDIR}/git"
SRC_URI = " \
- git://github.com/banister/method_source.git;branch=master \
+ git://github.com/banister/method_source.git;branch=master;protocol=https \
file://gemspec-bump-version.patch \
"
diff --git a/meta-openstack/recipes-devtools/ruby/mime-types_git.bb b/meta-openstack/recipes-devtools/ruby/mime-types_git.bb
index 42b417bd..989cb626 100644
--- a/meta-openstack/recipes-devtools/ruby/mime-types_git.bb
+++ b/meta-openstack/recipes-devtools/ruby/mime-types_git.bb
@@ -19,7 +19,7 @@ SRCREV = "bc15d62118b59aabbc9cb6e5734b65bf3bc273f0"
S = "${WORKDIR}/git"
SRC_URI = " \
- git://github.com/halostatue/mime-types.git;branch=master \
+ git://github.com/halostatue/mime-types.git;branch=master;protocol=https \
"
inherit ruby
diff --git a/meta-openstack/recipes-devtools/ruby/mixlib-authentication_git.bb b/meta-openstack/recipes-devtools/ruby/mixlib-authentication_git.bb
index 2e60ca37..d10835d9 100644
--- a/meta-openstack/recipes-devtools/ruby/mixlib-authentication_git.bb
+++ b/meta-openstack/recipes-devtools/ruby/mixlib-authentication_git.bb
@@ -17,7 +17,7 @@ SRCREV = "db24a56c6f5b99114998a50942220a7023060229"
S = "${WORKDIR}/git"
SRC_URI = " \
- git://github.com/opscode/mixlib-authentication.git;branch=master \
+ git://github.com/opscode/mixlib-authentication.git;branch=master;protocol=https \
"
inherit ruby
diff --git a/meta-openstack/recipes-devtools/ruby/mixlib-cli_git.bb b/meta-openstack/recipes-devtools/ruby/mixlib-cli_git.bb
index 1b7459b1..44309c46 100644
--- a/meta-openstack/recipes-devtools/ruby/mixlib-cli_git.bb
+++ b/meta-openstack/recipes-devtools/ruby/mixlib-cli_git.bb
@@ -17,7 +17,7 @@ SRCREV = "b3b3c12141b5380ec61945770690fc1ae31d92b0"
S = "${WORKDIR}/git"
SRC_URI = " \
- git://github.com/opscode/mixlib-cli.git;branch=master \
+ git://github.com/opscode/mixlib-cli.git;branch=master;protocol=https \
"
inherit ruby
diff --git a/meta-openstack/recipes-devtools/ruby/mixlib-config_git.bb b/meta-openstack/recipes-devtools/ruby/mixlib-config_git.bb
index 9fa6fe57..68eb393e 100644
--- a/meta-openstack/recipes-devtools/ruby/mixlib-config_git.bb
+++ b/meta-openstack/recipes-devtools/ruby/mixlib-config_git.bb
@@ -17,7 +17,7 @@ SRCREV = "d7bdd7c999e13a0bd67607011731a536323dd51c"
S = "${WORKDIR}/git"
SRC_URI = " \
- git://github.com/opscode/mixlib-config.git;branch=master \
+ git://github.com/opscode/mixlib-config.git;branch=master;protocol=https \
"
inherit ruby
diff --git a/meta-openstack/recipes-devtools/ruby/mixlib-log_git.bb b/meta-openstack/recipes-devtools/ruby/mixlib-log_git.bb
index 5aa63f7b..52a95d6e 100644
--- a/meta-openstack/recipes-devtools/ruby/mixlib-log_git.bb
+++ b/meta-openstack/recipes-devtools/ruby/mixlib-log_git.bb
@@ -17,7 +17,7 @@ SRCREV = "b750625a79cc46fffe6b886320f96e7874497fa0"
S = "${WORKDIR}/git"
SRC_URI = " \
- git://github.com/opscode/mixlib-log.git;branch=master \
+ git://github.com/opscode/mixlib-log.git;branch=master;protocol=https \
"
inherit ruby
diff --git a/meta-openstack/recipes-devtools/ruby/mixlib-shellout_git.bb b/meta-openstack/recipes-devtools/ruby/mixlib-shellout_git.bb
index 0f827317..70e316e5 100644
--- a/meta-openstack/recipes-devtools/ruby/mixlib-shellout_git.bb
+++ b/meta-openstack/recipes-devtools/ruby/mixlib-shellout_git.bb
@@ -20,7 +20,7 @@ SRCREV = "27ba1e882dcab280527aa1764d1b45aca3ef5961"
S = "${WORKDIR}/git"
SRC_URI = " \
- git://github.com/opscode/mixlib-shellout.git;branch=master \
+ git://github.com/opscode/mixlib-shellout.git;branch=master;protocol=https \
"
inherit ruby
diff --git a/meta-openstack/recipes-devtools/ruby/net-ssh-gateway_git.bb b/meta-openstack/recipes-devtools/ruby/net-ssh-gateway_git.bb
index f7481d31..160237c3 100644
--- a/meta-openstack/recipes-devtools/ruby/net-ssh-gateway_git.bb
+++ b/meta-openstack/recipes-devtools/ruby/net-ssh-gateway_git.bb
@@ -20,7 +20,7 @@ SRCREV = "1de7611a7f7cedbe7a4c6cf3798c88d00637582d"
S = "${WORKDIR}/git"
SRC_URI = " \
- git://github.com/net-ssh/net-ssh-gateway.git;branch=master \
+ git://github.com/net-ssh/net-ssh-gateway.git;branch=master;protocol=https \
file://gemspec-don-t-force-the-use-of-gem-private_key.pem.patch \
"
diff --git a/meta-openstack/recipes-devtools/ruby/net-ssh-multi_git.bb b/meta-openstack/recipes-devtools/ruby/net-ssh-multi_git.bb
index 127368ee..d95042e5 100644
--- a/meta-openstack/recipes-devtools/ruby/net-ssh-multi_git.bb
+++ b/meta-openstack/recipes-devtools/ruby/net-ssh-multi_git.bb
@@ -20,7 +20,7 @@ SRCREV = "5b668d5ef34102c9ac159a8f21c889fdc7f99f1b"
S = "${WORKDIR}/git"
SRC_URI = " \
- git://github.com/net-ssh/net-ssh-multi.git;branch=master \
+ git://github.com/net-ssh/net-ssh-multi.git;branch=master;protocol=https \
file://gemspec-don-t-force-the-use-of-gem-private_key.pem.patch \
"
diff --git a/meta-openstack/recipes-devtools/ruby/net-ssh_git.bb b/meta-openstack/recipes-devtools/ruby/net-ssh_git.bb
index ea8df88f..344b34bb 100644
--- a/meta-openstack/recipes-devtools/ruby/net-ssh_git.bb
+++ b/meta-openstack/recipes-devtools/ruby/net-ssh_git.bb
@@ -18,7 +18,7 @@ SRCREV = "9f8607984d8e904f211cc5edb39ab2a2ca94008e"
S = "${WORKDIR}/git"
SRC_URI = " \
- git://github.com/net-ssh/net-ssh.git;branch=master \
+ git://github.com/net-ssh/net-ssh.git;branch=master;protocol=https \
file://gemspec-don-t-force-the-use-of-gem-private_key.pem.patch \
"
diff --git a/meta-openstack/recipes-devtools/ruby/ohai_git.bb b/meta-openstack/recipes-devtools/ruby/ohai_git.bb
index d14b1292..f7bad071 100644
--- a/meta-openstack/recipes-devtools/ruby/ohai_git.bb
+++ b/meta-openstack/recipes-devtools/ruby/ohai_git.bb
@@ -20,7 +20,7 @@ SRCREV = "5c166cf3fa4b2af541ee54855aae73c809044b3d"
S = "${WORKDIR}/git"
SRC_URI = " \
- git://github.com/opscode/ohai.git;branch=master \
+ git://github.com/opscode/ohai.git;branch=master;protocol=https \
"
inherit ruby
diff --git a/meta-openstack/recipes-devtools/ruby/pry_git.bb b/meta-openstack/recipes-devtools/ruby/pry_git.bb
index bdb75f80..d2c33256 100644
--- a/meta-openstack/recipes-devtools/ruby/pry_git.bb
+++ b/meta-openstack/recipes-devtools/ruby/pry_git.bb
@@ -18,7 +18,7 @@ SRCREV = "191dc519813402acd6db0d7f73e652ed61f8111f"
S = "${WORKDIR}/git"
SRC_URI = " \
- git://github.com/pry/pry.git;branch=master \
+ git://github.com/pry/pry.git;branch=master;protocol=https \
file://rdoc-fixup-opt.banner-heredoc.patch \
"
diff --git a/meta-openstack/recipes-devtools/ruby/rack_git.bb b/meta-openstack/recipes-devtools/ruby/rack_git.bb
index 41f01c54..2c03cff3 100644
--- a/meta-openstack/recipes-devtools/ruby/rack_git.bb
+++ b/meta-openstack/recipes-devtools/ruby/rack_git.bb
@@ -20,7 +20,7 @@ SRCREV = "134d6218d0881d87ae6a522e88eafbddb6cd1bb7"
S = "${WORKDIR}/git"
SRC_URI = " \
- git://github.com/rack/rack.git;branch=1-6-stable \
+ git://github.com/rack/rack.git;branch=1-6-stable;protocol=https \
"
inherit ruby
diff --git a/meta-openstack/recipes-devtools/ruby/rest-client_git.bb b/meta-openstack/recipes-devtools/ruby/rest-client_git.bb
index 3f724c75..706af39c 100644
--- a/meta-openstack/recipes-devtools/ruby/rest-client_git.bb
+++ b/meta-openstack/recipes-devtools/ruby/rest-client_git.bb
@@ -18,7 +18,7 @@ SRCREV = "40eddc184a7b3fe79f9b68f291e06df4c1fbcb0b"
S = "${WORKDIR}/git"
SRC_URI = " \
- git://github.com/rest-client/rest-client.git;branch=master \
+ git://github.com/rest-client/rest-client.git;branch=master;protocol=https \
"
inherit ruby
diff --git a/meta-openstack/recipes-devtools/ruby/slop_git.bb b/meta-openstack/recipes-devtools/ruby/slop_git.bb
index eced5f0f..14debbf2 100644
--- a/meta-openstack/recipes-devtools/ruby/slop_git.bb
+++ b/meta-openstack/recipes-devtools/ruby/slop_git.bb
@@ -16,7 +16,7 @@ SRCREV = "50c4d5a6553c9d0b78dee35a092ea3a40c136fa1"
S = "${WORKDIR}/git"
SRC_URI = " \
- git://github.com/leejarvis/slop.git;branch=master \
+ git://github.com/leejarvis/slop.git;branch=master;protocol=https \
"
inherit ruby
diff --git a/meta-openstack/recipes-devtools/ruby/systemu_git.bb b/meta-openstack/recipes-devtools/ruby/systemu_git.bb
index fa0a53fb..fa407f1d 100644
--- a/meta-openstack/recipes-devtools/ruby/systemu_git.bb
+++ b/meta-openstack/recipes-devtools/ruby/systemu_git.bb
@@ -17,7 +17,7 @@ SRCREV = "cb253a8bf213beea69f27418202e936a22d7308f"
S = "${WORKDIR}/git"
SRC_URI = " \
- git://github.com/ahoward/systemu.git;branch=master \
+ git://github.com/ahoward/systemu.git;branch=master;protocol=https \
"
inherit ruby
diff --git a/meta-openstack/recipes-devtools/ruby/yard_git.bb b/meta-openstack/recipes-devtools/ruby/yard_git.bb
index e7a25b1f..2728802e 100644
--- a/meta-openstack/recipes-devtools/ruby/yard_git.bb
+++ b/meta-openstack/recipes-devtools/ruby/yard_git.bb
@@ -20,7 +20,7 @@ SRCREV = "d83194e1a09098ec5be28b616cde3b9a15380873"
S = "${WORKDIR}/git"
SRC_URI = " \
- git://github.com/lsegal/yard.git;branch=main \
+ git://github.com/lsegal/yard.git;branch=main;protocol=https \
"
inherit ruby