aboutsummaryrefslogtreecommitdiffstats
path: root/meta-openstack/recipes-devtools/python/python-httpretty_0.8.10.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openstack/recipes-devtools/python/python-httpretty_0.8.10.bb')
-rw-r--r--meta-openstack/recipes-devtools/python/python-httpretty_0.8.10.bb26
1 files changed, 26 insertions, 0 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-httpretty_0.8.10.bb b/meta-openstack/recipes-devtools/python/python-httpretty_0.8.10.bb
new file mode 100644
index 00000000..a6d622ec
--- /dev/null
+++ b/meta-openstack/recipes-devtools/python/python-httpretty_0.8.10.bb
@@ -0,0 +1,26 @@
+#
+# Copyright (C) 2014 Wind River Systems, Inc.
+#
+DESCRIPTION = "HTTP client mock for Python"
+HOMEPAGE = "https://pypi.python.org/pypi/httpretty"
+SECTION = "devel/python"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://COPYING;md5=fac859f0c7aee8d7f10b1aa5b130d1a7"
+
+PR = "r0"
+SRCNAME = "httpretty"
+
+SRC_URI = "https://pypi.python.org/packages/source/h/${SRCNAME}/${SRCNAME}-${PV}.tar.gz \
+ "
+
+SRC_URI[md5sum] = "9c130b16726cbf85159574ae5761bce7"
+SRC_URI[sha256sum] = "474a72722d66841f0e59cee285d837e1c6263be5be7bf2f8e824fc849a99adda"
+
+S = "${WORKDIR}/${SRCNAME}-${PV}"
+
+inherit setuptools
+
+DEPENDS += " \
+ python-pip \
+ "
+