aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-openstack/recipes-devtools/python/python-neutron/uuid_wscheck.patch35
-rw-r--r--meta-openstack/recipes-devtools/python/python-neutron_git.bb1
2 files changed, 36 insertions, 0 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-neutron/uuid_wscheck.patch b/meta-openstack/recipes-devtools/python/python-neutron/uuid_wscheck.patch
new file mode 100644
index 00000000..f3748d65
--- /dev/null
+++ b/meta-openstack/recipes-devtools/python/python-neutron/uuid_wscheck.patch
@@ -0,0 +1,35 @@
+Binary files git.orig/neutron/api/v2/.attributes.py.swp and git/neutron/api/v2/.attributes.py.swp differ
+Index: git/neutron/api/v2/attributes.py
+===================================================================
+--- git.orig/neutron/api/v2/attributes.py
++++ git/neutron/api/v2/attributes.py
+@@ -354,7 +354,10 @@
+
+ def _validate_uuid(data, valid_values=None):
+ if not uuidutils.is_uuid_like(data):
+- msg = _("'%s' is not a valid UUID") % data
++ if data != data.rstrip():
++ msg = _("'%s' is not a valid UUID: trailing whitespace?") % data
++ else:
++ msg = _("'%s' is not a valid UUID") % data
+ LOG.debug(msg)
+ return msg
+
+Index: git/neutron/plugins/cisco/n1kv/n1kv_neutron_plugin.py
+===================================================================
+--- git.orig/neutron/plugins/cisco/n1kv/n1kv_neutron_plugin.py
++++ git/neutron/plugins/cisco/n1kv/n1kv_neutron_plugin.py
+@@ -569,8 +569,11 @@
+ raise n_exc.InvalidInput(error_message=msg)
+ pair_list.append((segment, dot1qtag))
+ else:
+- LOG.debug(_('%s is not a valid uuid'), segment)
+- msg = _("'%s' is not a valid UUID") % segment
++ if segment != segment.rstrip():
++ msg = _("'%s' is not a valid UUID: trailing whitespace?") % segment
++ else:
++ msg = _("'%s' is not a valid UUID") % segment
++ LOG.debug(msg)
+ raise n_exc.InvalidInput(error_message=msg)
+ return pair_list
+
diff --git a/meta-openstack/recipes-devtools/python/python-neutron_git.bb b/meta-openstack/recipes-devtools/python/python-neutron_git.bb
index 5fbad176..1314548c 100644
--- a/meta-openstack/recipes-devtools/python/python-neutron_git.bb
+++ b/meta-openstack/recipes-devtools/python/python-neutron_git.bb
@@ -17,6 +17,7 @@ SRC_URI = "git://github.com/openstack/${SRCNAME}.git;branch=stable/icehouse \
file://metadata_agent.ini \
file://neutron-dhcp-agent-netns-cleanup.cron \
file://0001-neutron.conf-jumpstart-nova-state-reporting-configur.patch \
+ file://uuid_wscheck.patch \
"
SRCREV="e0deffc71e5031059530b9b6c2ef3b0765de3d10"
PV="2014.1+git${SRCPV}"