aboutsummaryrefslogtreecommitdiffstats
path: root/meta-v1000/recipes-graphics/lunarg-sdk/vulkan-tools
diff options
context:
space:
mode:
Diffstat (limited to 'meta-v1000/recipes-graphics/lunarg-sdk/vulkan-tools')
-rw-r--r--meta-v1000/recipes-graphics/lunarg-sdk/vulkan-tools/0001-CMakeLists-add-include-paths-so-Xlib-and-XCB-are-fou.patch133
-rw-r--r--meta-v1000/recipes-graphics/lunarg-sdk/vulkan-tools/0002-layersvt-drop-device_sim-as-we-don-t-have-jsoncpp-fo.patch41
-rw-r--r--meta-v1000/recipes-graphics/lunarg-sdk/vulkan-tools/0003-CMakeLists.txt-use-a-fixed-header-for-spirv_commit.patch71
-rw-r--r--meta-v1000/recipes-graphics/lunarg-sdk/vulkan-tools/0004-CMakeLists-add-include-path-so-Xlib.h-is-found-as-ne.patch108
-rw-r--r--meta-v1000/recipes-graphics/lunarg-sdk/vulkan-tools/0009-CMakeLists-add-include-paths-for-xcb-and-Xlib.patch35
-rw-r--r--meta-v1000/recipes-graphics/lunarg-sdk/vulkan-tools/0010-layersvt-drop-device_sim-as-we-don-t-have-jsoncpp-fo.patch41
6 files changed, 245 insertions, 184 deletions
diff --git a/meta-v1000/recipes-graphics/lunarg-sdk/vulkan-tools/0001-CMakeLists-add-include-paths-so-Xlib-and-XCB-are-fou.patch b/meta-v1000/recipes-graphics/lunarg-sdk/vulkan-tools/0001-CMakeLists-add-include-paths-so-Xlib-and-XCB-are-fou.patch
new file mode 100644
index 00000000..ecac1262
--- /dev/null
+++ b/meta-v1000/recipes-graphics/lunarg-sdk/vulkan-tools/0001-CMakeLists-add-include-paths-so-Xlib-and-XCB-are-fou.patch
@@ -0,0 +1,133 @@
+From a6dc74817a8670155d06e6aec722e4219e789414 Mon Sep 17 00:00:00 2001
+From: Awais Belal <awais_belal@mentor.com>
+Date: Tue, 4 Sep 2018 16:54:17 +0500
+Subject: [PATCH 1/2] CMakeLists: add include paths so Xlib and XCB are found
+ as needed
+
+All the targets including vk_platform.h or directly including
+X11/Xlib.h or xcb.h require to know the directory for the
+installed header. Add the directory to these so the requirements
+are filled in properly.
+
+Signed-off-by: Awais Belal <awais_belal@mentor.com>
+---
+ CMakeLists.txt | 1 +
+ layer_factory/CMakeLists.txt | 1 +
+ layersvt/CMakeLists.txt | 1 +
+ vktrace/vktrace_common/CMakeLists.txt | 1 +
+ vktrace/vktrace_layer/CMakeLists.txt | 1 +
+ vktrace/vktrace_replay/CMakeLists.txt | 1 +
+ vktrace/vktrace_trace/CMakeLists.txt | 1 +
+ vktrace/vktrace_viewer/CMakeLists.txt | 5 +++++
+ 8 files changed, 12 insertions(+)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index e19817efa..5298766c9 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -57,6 +57,7 @@ if(CMAKE_SYSTEM_NAME STREQUAL "Linux")
+
+ if (BUILD_WSI_XLIB_SUPPORT)
+ find_package(X11 REQUIRED)
++ find_path(X11_XLIB_INCLUDE_DIR X11/Xlib.h DOC "Path to X11/Xlib.h")
+ endif()
+
+ if (BUILD_WSI_WAYLAND_SUPPORT)
+diff --git a/layer_factory/CMakeLists.txt b/layer_factory/CMakeLists.txt
+index e4355d8b2..88f2d8369 100644
+--- a/layer_factory/CMakeLists.txt
++++ b/layer_factory/CMakeLists.txt
+@@ -11,6 +11,7 @@ elseif(CMAKE_SYSTEM_NAME STREQUAL "Linux")
+
+ if (BUILD_WSI_XLIB_SUPPORT)
+ add_definitions(-DVK_USE_PLATFORM_XLIB_KHR -DVK_USE_PLATFORM_XLIB_KHX -DVK_USE_PLATFORM_XLIB_XRANDR_EXT)
++ include_directories(${X11_XLIB_INCLUDE_DIR})
+ endif()
+
+ if (BUILD_WSI_WAYLAND_SUPPORT)
+diff --git a/layersvt/CMakeLists.txt b/layersvt/CMakeLists.txt
+index d47f3c65a..9b780ce4d 100644
+--- a/layersvt/CMakeLists.txt
++++ b/layersvt/CMakeLists.txt
+@@ -136,6 +136,7 @@ include_directories(
+ ${CMAKE_BINARY_DIR}/${V_LVL_RELATIVE_LOCATION}
+ ${PROJECT_SOURCE_DIR}/../glslang/SPIRV
+ ${JSONCPP_INCLUDE_DIR}
++ ${X11_XLIB_INCLUDE_DIR}
+ )
+
+ if (WIN32)
+diff --git a/vktrace/vktrace_common/CMakeLists.txt b/vktrace/vktrace_common/CMakeLists.txt
+index c9ad2ad8e..4c639c6d7 100644
+--- a/vktrace/vktrace_common/CMakeLists.txt
++++ b/vktrace/vktrace_common/CMakeLists.txt
+@@ -9,6 +9,7 @@ include_directories(
+ ${SRC_DIR}/vktrace_common
+ ${SRC_DIR}/thirdparty
+ ${CMAKE_BINARY_DIR}/${V_LVL_RELATIVE_LOCATION}
++ ${X11_XLIB_INCLUDE_DIR}
+ )
+
+ if (${CMAKE_SYSTEM_NAME} MATCHES "Linux")
+diff --git a/vktrace/vktrace_layer/CMakeLists.txt b/vktrace/vktrace_layer/CMakeLists.txt
+index 5cf48b34c..ea419a7ee 100644
+--- a/vktrace/vktrace_layer/CMakeLists.txt
++++ b/vktrace/vktrace_layer/CMakeLists.txt
+@@ -78,6 +78,7 @@ include_directories(
+ ${CMAKE_BINARY_DIR}/${V_LVL_RELATIVE_LOCATION}
+ ${V_LVL_ROOT_DIR}/include
+ ${V_LVL_ROOT_DIR}/include/vulkan
++ ${X11_XLIB_INCLUDE_DIR}
+ )
+
+ # copy/link layer json file into build/layersvt directory
+diff --git a/vktrace/vktrace_replay/CMakeLists.txt b/vktrace/vktrace_replay/CMakeLists.txt
+index 191af81a8..0912c7f1f 100644
+--- a/vktrace/vktrace_replay/CMakeLists.txt
++++ b/vktrace/vktrace_replay/CMakeLists.txt
+@@ -70,6 +70,7 @@ include_directories(
+ ${VKTRACE_VULKAN_INCLUDE_DIR}
+ ${CMAKE_BINARY_DIR}
+ ${CMAKE_BINARY_DIR}/${V_LVL_RELATIVE_LOCATION}
++ ${X11_XLIB_INCLUDE_DIR}
+ )
+
+
+diff --git a/vktrace/vktrace_trace/CMakeLists.txt b/vktrace/vktrace_trace/CMakeLists.txt
+index b1390d3fe..0dc0f5f8b 100644
+--- a/vktrace/vktrace_trace/CMakeLists.txt
++++ b/vktrace/vktrace_trace/CMakeLists.txt
+@@ -24,6 +24,7 @@ include_directories(
+ ${CMAKE_BINARY_DIR}
+ ${CMAKE_BINARY_DIR}/${V_LVL_RELATIVE_LOCATION}
+ ${GENERATED_FILES_DIR}
++ ${X11_XLIB_INCLUDE_DIR}
+ )
+
+ if (NOT WIN32)
+diff --git a/vktrace/vktrace_viewer/CMakeLists.txt b/vktrace/vktrace_viewer/CMakeLists.txt
+index 316e9bdba..171be773e 100644
+--- a/vktrace/vktrace_viewer/CMakeLists.txt
++++ b/vktrace/vktrace_viewer/CMakeLists.txt
+@@ -50,6 +50,9 @@ else()
+ find_package(Threads REQUIRED)
+ find_package(X11 REQUIRED)
+
++find_path(XCB_INCLUDE_DIR xcb/xcb.h DOC "Path to xcb/xcb.h")
++find_path(X11_XLIB_INCLUDE_DIR X11/Xlib.h DOC "Path to X11/Xlib.h")
++
+ require_pthreads()
+
+ include_directories(
+@@ -61,6 +64,8 @@ include_directories(
+ ${CMAKE_BINARY_DIR}/${V_LVL_RELATIVE_LOCATION}
+ ${CMAKE_BINARY_DIR}
+ ${Qt5Widgets_INCLUDE_DIRS}
++ ${X11_XLIB_INCLUDE_DIR}
++ ${XCB_INCLUDE_DIR}
+ )
+
+ set(SRC_LIST
+--
+2.11.1
+
diff --git a/meta-v1000/recipes-graphics/lunarg-sdk/vulkan-tools/0002-layersvt-drop-device_sim-as-we-don-t-have-jsoncpp-fo.patch b/meta-v1000/recipes-graphics/lunarg-sdk/vulkan-tools/0002-layersvt-drop-device_sim-as-we-don-t-have-jsoncpp-fo.patch
new file mode 100644
index 00000000..8a5efc12
--- /dev/null
+++ b/meta-v1000/recipes-graphics/lunarg-sdk/vulkan-tools/0002-layersvt-drop-device_sim-as-we-don-t-have-jsoncpp-fo.patch
@@ -0,0 +1,41 @@
+From 87edcb996897825ef5dbbf6a614e1f07cc5edb5c Mon Sep 17 00:00:00 2001
+From: Awais Belal <awais_belal@mentor.com>
+Date: Tue, 4 Sep 2018 17:10:08 +0500
+Subject: [PATCH 2/2] layersvt: drop device_sim as we don't have jsoncpp for
+ now
+
+Signed-off-by: Awais Belal <awais_belal@mentor.com>
+---
+ layersvt/CMakeLists.txt | 3 ---
+ 1 file changed, 3 deletions(-)
+
+diff --git a/layersvt/CMakeLists.txt b/layersvt/CMakeLists.txt
+index 9b780ce4d..42fd3c471 100644
+--- a/layersvt/CMakeLists.txt
++++ b/layersvt/CMakeLists.txt
+@@ -46,7 +46,6 @@ set(LAYER_JSON_FILES
+ VkLayer_api_dump
+ VkLayer_monitor
+ VkLayer_screenshot
+- VkLayer_device_simulation
+ )
+
+ set(VK_LAYER_RPATH /usr/lib/x86_64-linux-gnu/vulkan/layer:/usr/lib/i386-linux-gnu/vulkan/layer)
+@@ -135,7 +134,6 @@ include_directories(
+ ${CMAKE_BINARY_DIR}
+ ${CMAKE_BINARY_DIR}/${V_LVL_RELATIVE_LOCATION}
+ ${PROJECT_SOURCE_DIR}/../glslang/SPIRV
+- ${JSONCPP_INCLUDE_DIR}
+ ${X11_XLIB_INCLUDE_DIR}
+ )
+
+@@ -168,6 +166,5 @@ run_vk_xml_generate(api_dump_generator.py api_dump_html.h)
+
+ add_vk_layer(monitor monitor.cpp ${V_LVL_ROOT_DIR}/layers/vk_layer_table.cpp)
+ add_vk_layer(screenshot screenshot.cpp screenshot_parsing.h screenshot_parsing.cpp ${V_LVL_ROOT_DIR}/layers/vk_layer_table.cpp)
+-add_vk_layer(device_simulation device_simulation.cpp ${V_LVL_ROOT_DIR}/layers/vk_layer_table.cpp ${JSONCPP_SOURCE_DIR}/jsoncpp.cpp)
+ add_vk_layer(api_dump api_dump.cpp ${V_LVL_ROOT_DIR}/layers/vk_layer_table.cpp)
+
+--
+2.11.1
+
diff --git a/meta-v1000/recipes-graphics/lunarg-sdk/vulkan-tools/0003-CMakeLists.txt-use-a-fixed-header-for-spirv_commit.patch b/meta-v1000/recipes-graphics/lunarg-sdk/vulkan-tools/0003-CMakeLists.txt-use-a-fixed-header-for-spirv_commit.patch
new file mode 100644
index 00000000..48a08bf4
--- /dev/null
+++ b/meta-v1000/recipes-graphics/lunarg-sdk/vulkan-tools/0003-CMakeLists.txt-use-a-fixed-header-for-spirv_commit.patch
@@ -0,0 +1,71 @@
+From af1706e021e900f2cfb15e7bc0f9f68cdd1bd04c Mon Sep 17 00:00:00 2001
+From: Awais Belal <awais_belal@mentor.com>
+Date: Tue, 4 Sep 2018 14:58:18 +0500
+Subject: [PATCH 3/4] CMakeLists.txt: use a fixed header for spirv_commit
+
+Signed-off-by: Awais Belal <awais_belal@mentor.com>
+---
+ CMakeLists.txt | 3 ---
+ spirv_tools_commit_id.h | 29 +++++++++++++++++++++++++++++
+ 2 files changed, 29 insertions(+), 3 deletions(-)
+ create mode 100644 spirv_tools_commit_id.h
+
+diff --git a/submodules/Vulkan-LoaderAndValidationLayers/CMakeLists.txt b/submodules/Vulkan-LoaderAndValidationLayers/CMakeLists.txt
+index 5cf85d487..b0ec3cbaf 100644
+--- a/submodules/Vulkan-LoaderAndValidationLayers/CMakeLists.txt
++++ b/submodules/Vulkan-LoaderAndValidationLayers/CMakeLists.txt
+@@ -343,7 +343,6 @@ add_custom_target(generate_helper_files DEPENDS
+ vk_dispatch_table_helper.h
+ vk_extension_helper.h
+ vk_typemap_helper.h
+- spirv_tools_commit_id.h
+ )
+ set_target_properties(generate_helper_files PROPERTIES FOLDER ${LVL_TARGET_FOLDER})
+
+@@ -358,8 +357,6 @@ run_vk_xml_generate(helper_file_generator.py vk_enum_string_helper.h)
+ run_vk_xml_generate(helper_file_generator.py vk_object_types.h)
+ run_vk_xml_generate(helper_file_generator.py vk_extension_helper.h)
+ run_vk_xml_generate(helper_file_generator.py vk_typemap_helper.h)
+-run_external_revision_generate(${EXTERNAL_SOURCE_ROOT}/glslang/External/spirv-tools SPIRV_TOOLS_COMMIT_ID spirv_tools_commit_id.h)
+-
+
+
+ if(NOT WIN32)
+diff --git a/submodules/Vulkan-LoaderAndValidationLayers/include/vulkan/spirv_tools_commit_id.h b/submodules/Vulkan-LoaderAndValidationLayers/include/vulkan/spirv_tools_commit_id.h
+new file mode 100644
+index 000000000..ae588b33f
+--- /dev/null
++++ b/submodules/Vulkan-LoaderAndValidationLayers/include/vulkan/spirv_tools_commit_id.h
+@@ -0,0 +1,29 @@
++// *** THIS FILE IS GENERATED - DO NOT EDIT ***
++// See external_revision_generator.py for modifications
++
++/***************************************************************************
++ *
++ * Copyright (c) 2015-2017 The Khronos Group Inc.
++ * Copyright (c) 2015-2017 Valve Corporation
++ * Copyright (c) 2015-2017 LunarG, Inc.
++ * Copyright (c) 2015-2017 Google Inc.
++ *
++ * Licensed under the Apache License, Version 2.0 (the "License");
++ * you may not use this file except in compliance with the License.
++ * You may obtain a copy of the License at
++ *
++ * http://www.apache.org/licenses/LICENSE-2.0
++ *
++ * Unless required by applicable law or agreed to in writing, software
++ * distributed under the License is distributed on an "AS IS" BASIS,
++ * WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
++ * See the License for the specific language governing permissions and
++ * limitations under the License.
++ *
++ * Author: Chris Forbes <chrisforbes@google.com>
++ * Author: Cort Stratton <cort@google.com>
++ *
++ ****************************************************************************/
++#pragma once
++
++#define SPIRV_TOOLS_COMMIT_ID "2651ccaec8170b3257642b3c438f50dc4f181fdd"
+--
+2.11.1
+
diff --git a/meta-v1000/recipes-graphics/lunarg-sdk/vulkan-tools/0004-CMakeLists-add-include-path-so-Xlib.h-is-found-as-ne.patch b/meta-v1000/recipes-graphics/lunarg-sdk/vulkan-tools/0004-CMakeLists-add-include-path-so-Xlib.h-is-found-as-ne.patch
deleted file mode 100644
index 7f68c793..00000000
--- a/meta-v1000/recipes-graphics/lunarg-sdk/vulkan-tools/0004-CMakeLists-add-include-path-so-Xlib.h-is-found-as-ne.patch
+++ /dev/null
@@ -1,108 +0,0 @@
-From 00241b5774d0b730958b03c588e4ff56ba38774f Mon Sep 17 00:00:00 2001
-From: Awais Belal <awais_belal@mentor.com>
-Date: Thu, 7 Dec 2017 16:54:56 +0500
-Subject: [PATCH] CMakeLists: add include path so Xlib.h is found as needed
-
-All the targets including vk_platform.h or directly including
-X11/Xlib.h require to know the directory for the installed
-header. Add the directory to these so the requirements are
-filled in properly.
-
-Signed-off-by: Awais Belal <awais_belal@mentor.com>
----
- CMakeLists.txt | 1 +
- layers/CMakeLists.txt | 1 +
- layersvt/CMakeLists.txt | 1 +
- vktrace/vktrace_common/CMakeLists.txt | 1 +
- vktrace/vktrace_layer/CMakeLists.txt | 1 +
- vktrace/vktrace_replay/CMakeLists.txt | 1 +
- vktrace/vktrace_trace/CMakeLists.txt | 1 +
- 7 files changed, 7 insertions(+)
-
-diff --git a/CMakeLists.txt b/CMakeLists.txt
-index 1b3e8770a..ddb8aac18 100644
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -42,6 +42,7 @@ if(CMAKE_SYSTEM_NAME STREQUAL "Linux")
-
- if (BUILD_WSI_XLIB_SUPPORT)
- find_package(X11 REQUIRED)
-+ find_path(X11_XLIB_INCLUDE_DIR X11/Xlib.h DOC "Path to X11/Xlib.h")
- endif()
-
- if (BUILD_WSI_WAYLAND_SUPPORT)
-diff --git a/layers/CMakeLists.txt b/layers/CMakeLists.txt
-index 9567d7146..998482052 100644
---- a/layers/CMakeLists.txt
-+++ b/layers/CMakeLists.txt
-@@ -142,6 +142,7 @@ include_directories(
- ${CMAKE_CURRENT_BINARY_DIR}
- ${CMAKE_PROJECT_BINARY_DIR}
- ${CMAKE_BINARY_DIR}
-+ ${X11_XLIB_INCLUDE_DIR}
- )
-
- if (WIN32)
-diff --git a/layersvt/CMakeLists.txt b/layersvt/CMakeLists.txt
-index 3c6055050..437057e8d 100644
---- a/layersvt/CMakeLists.txt
-+++ b/layersvt/CMakeLists.txt
-@@ -132,6 +132,7 @@ include_directories(
- ${CMAKE_BINARY_DIR}
- ${PROJECT_SOURCE_DIR}/../glslang/SPIRV
- ${JSONCPP_INCLUDE_DIR}
-+ ${X11_XLIB_INCLUDE_DIR}
- )
-
- if (WIN32)
-diff --git a/vktrace/vktrace_common/CMakeLists.txt b/vktrace/vktrace_common/CMakeLists.txt
-index b7d6e33eb..c223912a9 100644
---- a/vktrace/vktrace_common/CMakeLists.txt
-+++ b/vktrace/vktrace_common/CMakeLists.txt
-@@ -7,6 +7,7 @@ set(CMAKE_RUNTIME_OUTPUT_DIRECTORY ${PROJECT_BINARY_DIR}/../)
- include_directories(
- ${SRC_DIR}/vktrace_common
- ${SRC_DIR}/thirdparty
-+ ${X11_XLIB_INCLUDE_DIR}
- )
-
- if (${CMAKE_SYSTEM_NAME} MATCHES "Linux")
-diff --git a/vktrace/vktrace_layer/CMakeLists.txt b/vktrace/vktrace_layer/CMakeLists.txt
-index 4a25eec87..182a406b7 100644
---- a/vktrace/vktrace_layer/CMakeLists.txt
-+++ b/vktrace/vktrace_layer/CMakeLists.txt
-@@ -75,6 +75,7 @@ include_directories(
- ${VKTRACE_VULKAN_INCLUDE_DIR}
- ${CMAKE_BINARY_DIR}
- ${GENERATED_FILES_DIR}
-+ ${X11_XLIB_INCLUDE_DIR}
- )
-
- # copy/link layer json file into build/layersvt directory
-diff --git a/vktrace/vktrace_replay/CMakeLists.txt b/vktrace/vktrace_replay/CMakeLists.txt
-index 946d49691..adbf10844 100644
---- a/vktrace/vktrace_replay/CMakeLists.txt
-+++ b/vktrace/vktrace_replay/CMakeLists.txt
-@@ -69,6 +69,7 @@ include_directories(
- ${GENERATED_FILES_DIR}
- ${VKTRACE_VULKAN_INCLUDE_DIR}
- ${CMAKE_BINARY_DIR}
-+ ${X11_XLIB_INCLUDE_DIR}
- )
-
-
-diff --git a/vktrace/vktrace_trace/CMakeLists.txt b/vktrace/vktrace_trace/CMakeLists.txt
-index 5bffb4d9f..d2707ecd4 100644
---- a/vktrace/vktrace_trace/CMakeLists.txt
-+++ b/vktrace/vktrace_trace/CMakeLists.txt
-@@ -23,6 +23,7 @@ include_directories(
- ${VULKAN_TOOLS_SOURCE_DIR}/layersvt
- ${CMAKE_BINARY_DIR}
- ${GENERATED_FILES_DIR}
-+ ${X11_XLIB_INCLUDE_DIR}
- )
-
- if (NOT WIN32)
---
-2.11.1
-
diff --git a/meta-v1000/recipes-graphics/lunarg-sdk/vulkan-tools/0009-CMakeLists-add-include-paths-for-xcb-and-Xlib.patch b/meta-v1000/recipes-graphics/lunarg-sdk/vulkan-tools/0009-CMakeLists-add-include-paths-for-xcb-and-Xlib.patch
deleted file mode 100644
index b1b86573..00000000
--- a/meta-v1000/recipes-graphics/lunarg-sdk/vulkan-tools/0009-CMakeLists-add-include-paths-for-xcb-and-Xlib.patch
+++ /dev/null
@@ -1,35 +0,0 @@
-From 801aa0aad1f62fb41d8f28d3f2e0bf836d9aeec7 Mon Sep 17 00:00:00 2001
-From: Ahsan Hussain <ahsan_hussain@mentor.com>
-Date: Mon, 18 Sep 2017 14:16:13 +0500
-Subject: [PATCH 1/1] CMakeLists: add include paths for xcb and Xlib
-
----
- vktrace/vktrace_viewer/CMakeLists.txt | 5 +++++
- 1 file changed, 5 insertions(+)
-
-diff --git a/vktrace/vktrace_viewer/CMakeLists.txt b/vktrace/vktrace_viewer/CMakeLists.txt
-index 7127c7f..3a203ad 100644
---- a/vktrace/vktrace_viewer/CMakeLists.txt
-+++ b/vktrace/vktrace_viewer/CMakeLists.txt
-@@ -41,6 +41,9 @@ endif()
-
- find_package(Qt5 COMPONENTS Widgets Gui Core Svg QUIET)
-
-+find_path(XCB_INCLUDE_DIR xcb/xcb.h DOC "Path to xcb/xcb.h")
-+find_path(X11_XLIB_INCLUDE_DIR X11/Xlib.h DOC "Path to X11/Xlib.h")
-+
- if(NOT Qt5_FOUND)
- # After Qt5.6 is installed, you may need to add the following to the cmake command line:
- # -DCMAKE_PREFIX_PATH=C:\\Qt\\5.6\\msvc2015_64\\
-@@ -60,6 +63,8 @@ include_directories(
- ${CMAKE_CURRENT_BINARY_DIR}
- ${CMAKE_BINARY_DIR}
- ${Qt5Widgets_INCLUDE_DIRS}
-+ ${X11_XLIB_INCLUDE_DIR}
-+ ${XCB_INCLUDE_DIR}
- )
-
- set(SRC_LIST
---
-2.11.1
-
diff --git a/meta-v1000/recipes-graphics/lunarg-sdk/vulkan-tools/0010-layersvt-drop-device_sim-as-we-don-t-have-jsoncpp-fo.patch b/meta-v1000/recipes-graphics/lunarg-sdk/vulkan-tools/0010-layersvt-drop-device_sim-as-we-don-t-have-jsoncpp-fo.patch
deleted file mode 100644
index c1b90d1f..00000000
--- a/meta-v1000/recipes-graphics/lunarg-sdk/vulkan-tools/0010-layersvt-drop-device_sim-as-we-don-t-have-jsoncpp-fo.patch
+++ /dev/null
@@ -1,41 +0,0 @@
-From 6d89b0953f8ffe2b81ecdf2e512afe59a86ab609 Mon Sep 17 00:00:00 2001
-From: Awais Belal <awais_belal@mentor.com>
-Date: Wed, 6 Dec 2017 19:17:58 +0500
-Subject: [PATCH] layersvt: drop device_sim as we don't have jsoncpp for now
-
-Signed-off-by: Awais Belal <awais_belal@mentor.com>
----
- layersvt/CMakeLists.txt | 3 ---
- 1 file changed, 3 deletions(-)
-
-diff --git a/layersvt/CMakeLists.txt b/layersvt/CMakeLists.txt
-index 437057e8d..8ac4d4d13 100644
---- a/layersvt/CMakeLists.txt
-+++ b/layersvt/CMakeLists.txt
-@@ -45,7 +45,6 @@ set(LAYER_JSON_FILES
- VkLayer_api_dump
- VkLayer_monitor
- VkLayer_screenshot
-- VkLayer_device_simulation
- )
-
- set(VK_LAYER_RPATH /usr/lib/x86_64-linux-gnu/vulkan/layer:/usr/lib/i386-linux-gnu/vulkan/layer)
-@@ -131,7 +130,6 @@ include_directories(
- ${CMAKE_CURRENT_BINARY_DIR}
- ${CMAKE_BINARY_DIR}
- ${PROJECT_SOURCE_DIR}/../glslang/SPIRV
-- ${JSONCPP_INCLUDE_DIR}
- ${X11_XLIB_INCLUDE_DIR}
- )
-
-@@ -176,7 +174,6 @@ add_dependencies(VkLayer_utilsvt generate_helper_files)
- # VulkanTools layers
- add_vk_layer(monitor monitor.cpp ../layers/vk_layer_table.cpp)
- add_vk_layer(screenshot screenshot.cpp screenshot_parsing.h screenshot_parsing.cpp ../layers/vk_layer_table.cpp)
--add_vk_layer(device_simulation device_simulation.cpp ../layers/vk_layer_table.cpp ${JSONCPP_SOURCE_DIR}/jsoncpp.cpp)
- # generated
- add_vk_layer(api_dump api_dump.cpp ../layers/vk_layer_table.cpp)
-
---
-2.11.1
-