aboutsummaryrefslogtreecommitdiffstats
path: root/meta-snowyowl/recipes-kernel
diff options
context:
space:
mode:
Diffstat (limited to 'meta-snowyowl/recipes-kernel')
-rw-r--r--meta-snowyowl/recipes-kernel/linux/linux-yocto_4.9.bbappend10
1 files changed, 7 insertions, 3 deletions
diff --git a/meta-snowyowl/recipes-kernel/linux/linux-yocto_4.9.bbappend b/meta-snowyowl/recipes-kernel/linux/linux-yocto_4.9.bbappend
index 77d4c6fe..05a934ca 100644
--- a/meta-snowyowl/recipes-kernel/linux/linux-yocto_4.9.bbappend
+++ b/meta-snowyowl/recipes-kernel/linux/linux-yocto_4.9.bbappend
@@ -1,14 +1,18 @@
require linux-yocto-snowyowl_4.9.inc
-MACHINE_FEATURES_remove = "alsa"
-MACHINE_EXTRA_RRECOMMENDS_remove = "alsa-utils"
-
SRC_URI_append_snowyowl += "file://snowyowl-standard-only.cfg"
SRC_URI_append_snowyowl += "file://disable-graphics.cfg"
KBRANCH_snowyowl ?= "standard/base"
SRCREV_machine_snowyowl ?= "81055b89bd32414ecaf95156ce9a5fa6643e530a"
+# openssl-dev is required for features such as module signing
+DEPENDS_append = " openssl-native"
+
+# backported from OE-core so things such as openssl-native listed
+# above can be picked up from the native sysroot
+EXTRA_OEMAKE = " HOSTCC="${BUILD_CC} ${BUILD_CFLAGS} ${BUILD_LDFLAGS}" HOSTCPP="${BUILD_CPP}""
+
do_validate_branches_append() {
# Droping configs related to sound generating spurious warnings
sed -i '/kconf hardware snd_hda_intel.cfg/d' ${WORKDIR}/${KMETA}/features/sound/snd_hda_intel.scc