aboutsummaryrefslogtreecommitdiffstats
path: root/meta-amd-bsp/recipes-kernel/linux/linux-yocto-4.19.8/2124-Revert-drm-amd-display-move-vmid-determination-logic.patch
diff options
context:
space:
mode:
Diffstat (limited to 'meta-amd-bsp/recipes-kernel/linux/linux-yocto-4.19.8/2124-Revert-drm-amd-display-move-vmid-determination-logic.patch')
-rw-r--r--meta-amd-bsp/recipes-kernel/linux/linux-yocto-4.19.8/2124-Revert-drm-amd-display-move-vmid-determination-logic.patch286
1 files changed, 286 insertions, 0 deletions
diff --git a/meta-amd-bsp/recipes-kernel/linux/linux-yocto-4.19.8/2124-Revert-drm-amd-display-move-vmid-determination-logic.patch b/meta-amd-bsp/recipes-kernel/linux/linux-yocto-4.19.8/2124-Revert-drm-amd-display-move-vmid-determination-logic.patch
new file mode 100644
index 00000000..6589441a
--- /dev/null
+++ b/meta-amd-bsp/recipes-kernel/linux/linux-yocto-4.19.8/2124-Revert-drm-amd-display-move-vmid-determination-logic.patch
@@ -0,0 +1,286 @@
+From c6fdbf2b346e697fcf9bad7cefce5cb45620ea2f Mon Sep 17 00:00:00 2001
+From: Alex Deucher <alexander.deucher@amd.com>
+Date: Mon, 17 Jun 2019 13:06:37 -0500
+Subject: [PATCH 2124/2940] Revert "drm/amd/display: move vmid determination
+ logic out of dc"
+
+This reverts commit 78b2cecea96274b2af6b280625a98c2ff7f8078a.
+
+Signed-off-by: Alex Deucher <alexander.deucher@amd.com>
+---
+ drivers/gpu/drm/amd/display/dc/Makefile | 4 +-
+ .../drm/amd/display/dc/core/dc_vm_helper.c | 123 ++++++++++++++++++
+ drivers/gpu/drm/amd/display/dc/dc.h | 1 -
+ drivers/gpu/drm/amd/display/dc/dc_hw_types.h | 2 -
+ .../gpu/drm/amd/display/dc/dcn10/dcn10_hubp.c | 3 +-
+ .../amd/display/dc/dcn10/dcn10_hw_sequencer.c | 3 +-
+ drivers/gpu/drm/amd/display/dc/inc/hw/hubp.h | 3 +-
+ drivers/gpu/drm/amd/display/dc/inc/hw/vmid.h | 1 -
+ .../gpu/drm/amd/display/dc/inc/vm_helper.h | 16 ++-
+ 9 files changed, 143 insertions(+), 13 deletions(-)
+ create mode 100644 drivers/gpu/drm/amd/display/dc/core/dc_vm_helper.c
+
+diff --git a/drivers/gpu/drm/amd/display/dc/Makefile b/drivers/gpu/drm/amd/display/dc/Makefile
+index f581d5394caa..6da4e4f844b2 100644
+--- a/drivers/gpu/drm/amd/display/dc/Makefile
++++ b/drivers/gpu/drm/amd/display/dc/Makefile
+@@ -41,8 +41,8 @@ AMD_DC = $(addsuffix /Makefile, $(addprefix $(FULL_AMD_DISPLAY_PATH)/dc/,$(DC_LI
+ include $(AMD_DC)
+
+ DISPLAY_CORE = dc.o dc_link.o dc_resource.o dc_hw_sequencer.o dc_sink.o \
+-dc_surface.o dc_link_hwss.o dc_link_dp.o dc_link_ddc.o dc_debug.o dc_stream.o
+-
++dc_surface.o dc_link_hwss.o dc_link_dp.o dc_link_ddc.o dc_debug.o dc_stream.o \
++dc_vm_helper.o
+
+ AMD_DISPLAY_CORE = $(addprefix $(AMDDALPATH)/dc/core/,$(DISPLAY_CORE))
+
+diff --git a/drivers/gpu/drm/amd/display/dc/core/dc_vm_helper.c b/drivers/gpu/drm/amd/display/dc/core/dc_vm_helper.c
+new file mode 100644
+index 000000000000..6ce87b682a32
+--- /dev/null
++++ b/drivers/gpu/drm/amd/display/dc/core/dc_vm_helper.c
+@@ -0,0 +1,123 @@
++/*
++ * Copyright 2018 Advanced Micro Devices, Inc.
++ *
++ * Permission is hereby granted, free of charge, to any person obtaining a
++ * copy of this software and associated documentation files (the "Software"),
++ * to deal in the Software without restriction, including without limitation
++ * the rights to use, copy, modify, merge, publish, distribute, sublicense,
++ * and/or sell copies of the Software, and to permit persons to whom the
++ * Software is furnished to do so, subject to the following conditions:
++ *
++ * The above copyright notice and this permission notice shall be included in
++ * all copies or substantial portions of the Software.
++ *
++ * THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
++ * IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
++ * FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL
++ * THE COPYRIGHT HOLDER(S) OR AUTHOR(S) BE LIABLE FOR ANY CLAIM, DAMAGES OR
++ * OTHER LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE,
++ * ARISING FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR
++ * OTHER DEALINGS IN THE SOFTWARE.
++ *
++ * Authors: AMD
++ *
++ */
++
++#include "vm_helper.h"
++
++static void mark_vmid_used(struct vm_helper *vm_helper, unsigned int pos, uint8_t hubp_idx)
++{
++ struct vmid_usage vmids = vm_helper->hubp_vmid_usage[hubp_idx];
++
++ vmids.vmid_usage[0] = vmids.vmid_usage[1];
++ vmids.vmid_usage[1] = 1 << pos;
++}
++
++static void add_ptb_to_table(struct vm_helper *vm_helper, unsigned int vmid, uint64_t ptb)
++{
++ vm_helper->ptb_assigned_to_vmid[vmid] = ptb;
++ vm_helper->num_vmids_available--;
++}
++
++static void clear_entry_from_vmid_table(struct vm_helper *vm_helper, unsigned int vmid)
++{
++ vm_helper->ptb_assigned_to_vmid[vmid] = 0;
++ vm_helper->num_vmids_available++;
++}
++
++static void evict_vmids(struct vm_helper *vm_helper)
++{
++ int i;
++ uint16_t ord = 0;
++
++ for (i = 0; i < vm_helper->num_vmid; i++)
++ ord |= vm_helper->hubp_vmid_usage[i].vmid_usage[0] | vm_helper->hubp_vmid_usage[i].vmid_usage[1];
++
++ // At this point any positions with value 0 are unused vmids, evict them
++ for (i = 1; i < vm_helper->num_vmid; i++) {
++ if (ord & (1u << i))
++ clear_entry_from_vmid_table(vm_helper, i);
++ }
++}
++
++// Return value of -1 indicates vmid table unitialized or ptb dne in the table
++static int get_existing_vmid_for_ptb(struct vm_helper *vm_helper, uint64_t ptb)
++{
++ int i;
++
++ for (i = 0; i < vm_helper->num_vmid; i++) {
++ if (vm_helper->ptb_assigned_to_vmid[i] == ptb)
++ return i;
++ }
++
++ return -1;
++}
++
++// Expected to be called only when there's an available vmid
++static int get_next_available_vmid(struct vm_helper *vm_helper)
++{
++ int i;
++
++ for (i = 1; i < vm_helper->num_vmid; i++) {
++ if (vm_helper->ptb_assigned_to_vmid[i] == 0)
++ return i;
++ }
++
++ return -1;
++}
++
++uint8_t get_vmid_for_ptb(struct vm_helper *vm_helper, int64_t ptb, uint8_t hubp_idx)
++{
++ unsigned int vmid = 0;
++ int vmid_exists = -1;
++
++ // Physical address gets vmid 0
++ if (ptb == 0)
++ return 0;
++
++ vmid_exists = get_existing_vmid_for_ptb(vm_helper, ptb);
++
++ if (vmid_exists != -1) {
++ mark_vmid_used(vm_helper, vmid_exists, hubp_idx);
++ vmid = vmid_exists;
++ } else {
++ if (vm_helper->num_vmids_available == 0)
++ evict_vmids(vm_helper);
++
++ vmid = get_next_available_vmid(vm_helper);
++ mark_vmid_used(vm_helper, vmid, hubp_idx);
++ add_ptb_to_table(vm_helper, vmid, ptb);
++ }
++
++ return vmid;
++}
++
++void init_vm_helper(struct vm_helper *vm_helper, unsigned int num_vmid, unsigned int num_hubp)
++{
++ vm_helper->num_vmid = num_vmid;
++ vm_helper->num_hubp = num_hubp;
++ vm_helper->num_vmids_available = num_vmid - 1;
++
++ memset(vm_helper->hubp_vmid_usage, 0, sizeof(vm_helper->hubp_vmid_usage[0]) * MAX_HUBP);
++ memset(vm_helper->ptb_assigned_to_vmid, 0, sizeof(vm_helper->ptb_assigned_to_vmid[0]) * MAX_VMID);
++}
+diff --git a/drivers/gpu/drm/amd/display/dc/dc.h b/drivers/gpu/drm/amd/display/dc/dc.h
+index 780d304adb58..2751b7541d5e 100644
+--- a/drivers/gpu/drm/amd/display/dc/dc.h
++++ b/drivers/gpu/drm/amd/display/dc/dc.h
+@@ -472,7 +472,6 @@ struct dc_callback_init {
+ };
+
+ struct dc *dc_create(const struct dc_init_data *init_params);
+-int dc_get_vmid_use_vector(struct dc *dc);
+ void dc_init_callbacks(struct dc *dc,
+ const struct dc_callback_init *init_params);
+ void dc_destroy(struct dc **dc);
+diff --git a/drivers/gpu/drm/amd/display/dc/dc_hw_types.h b/drivers/gpu/drm/amd/display/dc/dc_hw_types.h
+index 821d4f260764..d9999ff915df 100644
+--- a/drivers/gpu/drm/amd/display/dc/dc_hw_types.h
++++ b/drivers/gpu/drm/amd/display/dc/dc_hw_types.h
+@@ -99,8 +99,6 @@ struct dc_plane_address {
+ };
+
+ union large_integer page_table_base;
+-
+- uint8_t vmid;
+ };
+
+ struct dc_size {
+diff --git a/drivers/gpu/drm/amd/display/dc/dcn10/dcn10_hubp.c b/drivers/gpu/drm/amd/display/dc/dcn10/dcn10_hubp.c
+index 4cb7fe8b3903..aea2b63db137 100644
+--- a/drivers/gpu/drm/amd/display/dc/dcn10/dcn10_hubp.c
++++ b/drivers/gpu/drm/amd/display/dc/dcn10/dcn10_hubp.c
+@@ -317,7 +317,8 @@ void hubp1_program_pixel_format(
+ bool hubp1_program_surface_flip_and_addr(
+ struct hubp *hubp,
+ const struct dc_plane_address *address,
+- bool flip_immediate)
++ bool flip_immediate,
++ uint8_t vmid)
+ {
+ struct dcn10_hubp *hubp1 = TO_DCN10_HUBP(hubp);
+
+diff --git a/drivers/gpu/drm/amd/display/dc/dcn10/dcn10_hw_sequencer.c b/drivers/gpu/drm/amd/display/dc/dcn10/dcn10_hw_sequencer.c
+index dfa2b1784c71..3667fd2742b6 100644
+--- a/drivers/gpu/drm/amd/display/dc/dcn10/dcn10_hw_sequencer.c
++++ b/drivers/gpu/drm/amd/display/dc/dcn10/dcn10_hw_sequencer.c
+@@ -1236,7 +1236,8 @@ static void dcn10_update_plane_addr(const struct dc *dc, struct pipe_ctx *pipe_c
+ pipe_ctx->plane_res.hubp->funcs->hubp_program_surface_flip_and_addr(
+ pipe_ctx->plane_res.hubp,
+ &plane_state->address,
+- plane_state->flip_immediate);
++ plane_state->flip_immediate,
++ 0);
+
+ plane_state->status.requested_address = plane_state->address;
+
+diff --git a/drivers/gpu/drm/amd/display/dc/inc/hw/hubp.h b/drivers/gpu/drm/amd/display/dc/inc/hw/hubp.h
+index e4909d21b9f2..5420ad2da96f 100644
+--- a/drivers/gpu/drm/amd/display/dc/inc/hw/hubp.h
++++ b/drivers/gpu/drm/amd/display/dc/inc/hw/hubp.h
+@@ -80,7 +80,8 @@ struct hubp_funcs {
+ bool (*hubp_program_surface_flip_and_addr)(
+ struct hubp *hubp,
+ const struct dc_plane_address *address,
+- bool flip_immediate);
++ bool flip_immediate,
++ uint8_t vmid);
+
+ void (*hubp_program_pte_vm)(
+ struct hubp *hubp,
+diff --git a/drivers/gpu/drm/amd/display/dc/inc/hw/vmid.h b/drivers/gpu/drm/amd/display/dc/inc/hw/vmid.h
+index 76de0e4284e0..037beb0a2a27 100644
+--- a/drivers/gpu/drm/amd/display/dc/inc/hw/vmid.h
++++ b/drivers/gpu/drm/amd/display/dc/inc/hw/vmid.h
+@@ -44,7 +44,6 @@ struct dcn_vmid_page_table_config {
+ uint64_t page_table_end_addr;
+ enum dcn_hubbub_page_table_depth depth;
+ enum dcn_hubbub_page_table_block_size block_size;
+- uint64_t page_table_base_addr;
+ };
+
+ #endif /* DAL_DC_INC_HW_VMID_H_ */
+diff --git a/drivers/gpu/drm/amd/display/dc/inc/vm_helper.h b/drivers/gpu/drm/amd/display/dc/inc/vm_helper.h
+index 8bfcef0a3675..193407f76a80 100644
+--- a/drivers/gpu/drm/amd/display/dc/inc/vm_helper.h
++++ b/drivers/gpu/drm/amd/display/dc/inc/vm_helper.h
+@@ -28,21 +28,29 @@
+
+ #include "dc_types.h"
+
++#define MAX_VMID 16
+ #define MAX_HUBP 6
+
+ struct vmid_usage {
+- int vmid_usage[2];
++ uint16_t vmid_usage[2];
+ };
+
+ struct vm_helper {
+ unsigned int num_vmid;
++ unsigned int num_hubp;
++ unsigned int num_vmids_available;
++ uint64_t ptb_assigned_to_vmid[MAX_VMID];
+ struct vmid_usage hubp_vmid_usage[MAX_HUBP];
+ };
+
+-void vm_helper_mark_vmid_used(struct vm_helper *vm_helper, unsigned int pos, uint8_t hubp_idx);
++uint8_t get_vmid_for_ptb(
++ struct vm_helper *vm_helper,
++ int64_t ptb,
++ uint8_t pipe_idx);
+
+-void vm_helper_init(
++void init_vm_helper(
+ struct vm_helper *vm_helper,
+- unsigned int num_vmid);
++ unsigned int num_vmid,
++ unsigned int num_hubp);
+
+ #endif /* DC_INC_VM_HELPER_H_ */
+--
+2.17.1
+