aboutsummaryrefslogtreecommitdiffstats
path: root/meta-amd-bsp/recipes-kernel/linux/linux-yocto-4.14.71/3852-drm-amd-Resolving-compilation-issues.patch
diff options
context:
space:
mode:
Diffstat (limited to 'meta-amd-bsp/recipes-kernel/linux/linux-yocto-4.14.71/3852-drm-amd-Resolving-compilation-issues.patch')
-rw-r--r--meta-amd-bsp/recipes-kernel/linux/linux-yocto-4.14.71/3852-drm-amd-Resolving-compilation-issues.patch105
1 files changed, 105 insertions, 0 deletions
diff --git a/meta-amd-bsp/recipes-kernel/linux/linux-yocto-4.14.71/3852-drm-amd-Resolving-compilation-issues.patch b/meta-amd-bsp/recipes-kernel/linux/linux-yocto-4.14.71/3852-drm-amd-Resolving-compilation-issues.patch
new file mode 100644
index 00000000..9d5c291a
--- /dev/null
+++ b/meta-amd-bsp/recipes-kernel/linux/linux-yocto-4.14.71/3852-drm-amd-Resolving-compilation-issues.patch
@@ -0,0 +1,105 @@
+From ef8936090f6ea6a0c80495f9ae6d94af31ba2e76 Mon Sep 17 00:00:00 2001
+From: Kalyan Alle <kalyan.alle@amd.com>
+Date: Sun, 22 Jul 2018 12:34:17 +0530
+Subject: [PATCH 3852/4131] drm/amd: Resolving compilation issues
+
+Signed-off-by: Kalyan Alle <kalyan.alle@amd.com>
+---
+ drivers/gpu/drm/amd/amdgpu/Makefile | 2 +-
+ drivers/gpu/drm/amd/amdkfd/kfd_device_queue_manager.c | 5 ++---
+ drivers/gpu/drm/amd/display/Kconfig | 8 ++++----
+ drivers/gpu/drm/amd/display/dc/gpio/gpio_base.c | 2 +-
+ drivers/gpu/drm/amd/powerplay/amd_powerplay.c | 2 +-
+ 5 files changed, 9 insertions(+), 10 deletions(-)
+
+diff --git a/drivers/gpu/drm/amd/amdgpu/Makefile b/drivers/gpu/drm/amd/amdgpu/Makefile
+index e2e9f7a..c27005e 100644
+--- a/drivers/gpu/drm/amd/amdgpu/Makefile
++++ b/drivers/gpu/drm/amd/amdgpu/Makefile
+@@ -7,7 +7,7 @@ FULL_AMD_PATH=$(src)/..
+ DISPLAY_FOLDER_NAME=display
+ FULL_AMD_DISPLAY_PATH = $(FULL_AMD_PATH)/$(DISPLAY_FOLDER_NAME)
+
+-ccflags-y := -I$(FULL_AMD_PATH)/include/asic_reg \
++ccflags-y := -Iinclude/drm -I$(FULL_AMD_PATH)/include/asic_reg \
+ -I$(FULL_AMD_PATH)/include \
+ -I$(FULL_AMD_PATH)/amdgpu \
+ -I$(FULL_AMD_PATH)/powerplay/inc \
+diff --git a/drivers/gpu/drm/amd/amdkfd/kfd_device_queue_manager.c b/drivers/gpu/drm/amd/amdkfd/kfd_device_queue_manager.c
+index a62a329..8c04f7a2 100644
+--- a/drivers/gpu/drm/amd/amdkfd/kfd_device_queue_manager.c
++++ b/drivers/gpu/drm/amd/amdkfd/kfd_device_queue_manager.c
+@@ -1356,13 +1356,12 @@ static int destroy_queue_cpsch(struct device_queue_manager *dqm,
+
+ list_del(&q->list);
+ qpd->queue_count--;
+- if (q->properties.is_active) {
++ if (q->properties.is_active)
+ dqm->queue_count--;
+ retval = execute_queues_cpsch(dqm,
+ KFD_UNMAP_QUEUES_FILTER_DYNAMIC_QUEUES, 0);
+ if (retval == -ETIME)
+ qpd->reset_wavefronts = true;
+- }
+
+ mqd->uninit_mqd(mqd, q->mqd, q->mqd_mem_obj);
+
+@@ -1376,7 +1375,7 @@ static int destroy_queue_cpsch(struct device_queue_manager *dqm,
+
+ mutex_unlock(&dqm->lock);
+
+- return retval;
++ return 0;
+
+ failed:
+ failed_try_destroy_debugged_queue:
+diff --git a/drivers/gpu/drm/amd/display/Kconfig b/drivers/gpu/drm/amd/display/Kconfig
+index a855307..5f0a690 100644
+--- a/drivers/gpu/drm/amd/display/Kconfig
++++ b/drivers/gpu/drm/amd/display/Kconfig
+@@ -2,12 +2,12 @@ menu "Display Engine Configuration"
+ depends on DRM && DRM_AMDGPU
+
+ config DRM_AMD_DC
+- bool "AMD DC - Enable new display engine (will be deprecated when the development is done)"
++ bool "AMD DC - Enable new display engine"
++ default y
+ help
+ Choose this option if you want to use the new display engine
+- support for AMDGPU.
+-
+- Will be deprecated when the DC component is upstream.
++ support for AMDGPU.This adds required support for Vega and
++ Raven ASICs.
+
+ config DRM_AMD_DC_PRE_VEGA
+ bool "DC support for Polaris and older ASICs"
+diff --git a/drivers/gpu/drm/amd/display/dc/gpio/gpio_base.c b/drivers/gpu/drm/amd/display/dc/gpio/gpio_base.c
+index 85205e5..1d1efd7 100644
+--- a/drivers/gpu/drm/amd/display/dc/gpio/gpio_base.c
++++ b/drivers/gpu/drm/amd/display/dc/gpio/gpio_base.c
+@@ -61,7 +61,7 @@ enum gpio_result dal_gpio_open_ex(
+ enum gpio_mode mode)
+ {
+ if (gpio->pin) {
+- printk(KERN_ERR "Already opened GPIO");
++ ASSERT_CRITICAL(false);
+ return GPIO_RESULT_ALREADY_OPENED;
+ }
+
+diff --git a/drivers/gpu/drm/amd/powerplay/amd_powerplay.c b/drivers/gpu/drm/amd/powerplay/amd_powerplay.c
+index 86338ea..7553ac7 100644
+--- a/drivers/gpu/drm/amd/powerplay/amd_powerplay.c
++++ b/drivers/gpu/drm/amd/powerplay/amd_powerplay.c
+@@ -206,7 +206,7 @@ static int pp_late_init(void *handle)
+ static void pp_late_fini(void *handle)
+ {
+ struct amdgpu_device *adev = handle;
+-
++
+ amd_powerplay_destroy(adev);
+ }
+
+--
+2.7.4
+