aboutsummaryrefslogtreecommitdiffstats
path: root/meta-amd-bsp/recipes-kernel/linux/linux-yocto-4.14.71/3536-amdgpu-dc-calcs-Support-clang-option-for-stack-align.patch
diff options
context:
space:
mode:
Diffstat (limited to 'meta-amd-bsp/recipes-kernel/linux/linux-yocto-4.14.71/3536-amdgpu-dc-calcs-Support-clang-option-for-stack-align.patch')
-rw-r--r--meta-amd-bsp/recipes-kernel/linux/linux-yocto-4.14.71/3536-amdgpu-dc-calcs-Support-clang-option-for-stack-align.patch43
1 files changed, 43 insertions, 0 deletions
diff --git a/meta-amd-bsp/recipes-kernel/linux/linux-yocto-4.14.71/3536-amdgpu-dc-calcs-Support-clang-option-for-stack-align.patch b/meta-amd-bsp/recipes-kernel/linux/linux-yocto-4.14.71/3536-amdgpu-dc-calcs-Support-clang-option-for-stack-align.patch
new file mode 100644
index 00000000..2e9e3466
--- /dev/null
+++ b/meta-amd-bsp/recipes-kernel/linux/linux-yocto-4.14.71/3536-amdgpu-dc-calcs-Support-clang-option-for-stack-align.patch
@@ -0,0 +1,43 @@
+From 71308542906c21bb56cf208c2425f76dd937fed6 Mon Sep 17 00:00:00 2001
+From: Matthias Kaehlcke <mka@chromium.org>
+Date: Thu, 8 Feb 2018 12:53:16 -0800
+Subject: [PATCH 3536/4131] amdgpu/dc/calcs: Support clang option for stack
+ alignment
+
+calcs uses the compiler option -mpreferred-stack-boundary=4 to configure
+a stack alignment of 16 bytes. Clang uses the option -mstack-alignment
+instead, which expects as parameter the alignment in bytes, and not a
+power of two like -mpreferred-stack-boundary.
+
+Probe for both compiler options and use the correct one, similar to
+what is done in arch/x86/Makefile.
+
+Signed-off-by: Matthias Kaehlcke <mka@chromium.org>
+Reviewed-by: Harry Wentland <harry.wentland@amd.com>
+Signed-off-by: Alex Deucher <alexander.deucher@amd.com>
+---
+ drivers/gpu/drm/amd/display/dc/calcs/Makefile | 8 +++++++-
+ 1 file changed, 7 insertions(+), 1 deletion(-)
+
+diff --git a/drivers/gpu/drm/amd/display/dc/calcs/Makefile b/drivers/gpu/drm/amd/display/dc/calcs/Makefile
+index ac4b936..1cb3a1d 100644
+--- a/drivers/gpu/drm/amd/display/dc/calcs/Makefile
++++ b/drivers/gpu/drm/amd/display/dc/calcs/Makefile
+@@ -3,7 +3,13 @@
+ # It calculates Bandwidth and Watermarks values for HW programming
+ #
+
+-calcs_ccflags := -mhard-float -msse -mpreferred-stack-boundary=4
++ifneq ($(call cc-option, -mpreferred-stack-boundary=4),)
++ cc_stack_align := -mpreferred-stack-boundary=4
++else ifneq ($(call cc-option, -mstack-alignment=16),)
++ cc_stack_align := -mstack-alignment=16
++endif
++
++calcs_ccflags := -mhard-float -msse $(cc_stack_align)
+
+ CFLAGS_dcn_calcs.o := $(calcs_ccflags)
+ CFLAGS_dcn_calc_auto.o := $(calcs_ccflags)
+--
+2.7.4
+