aboutsummaryrefslogtreecommitdiffstats
path: root/meta-amd-bsp/recipes-kernel/linux/linux-yocto-4.14.71/3534-amdgpu-dc-calcs-Consolidate-redundant-CFLAGS.patch
diff options
context:
space:
mode:
Diffstat (limited to 'meta-amd-bsp/recipes-kernel/linux/linux-yocto-4.14.71/3534-amdgpu-dc-calcs-Consolidate-redundant-CFLAGS.patch')
-rw-r--r--meta-amd-bsp/recipes-kernel/linux/linux-yocto-4.14.71/3534-amdgpu-dc-calcs-Consolidate-redundant-CFLAGS.patch37
1 files changed, 37 insertions, 0 deletions
diff --git a/meta-amd-bsp/recipes-kernel/linux/linux-yocto-4.14.71/3534-amdgpu-dc-calcs-Consolidate-redundant-CFLAGS.patch b/meta-amd-bsp/recipes-kernel/linux/linux-yocto-4.14.71/3534-amdgpu-dc-calcs-Consolidate-redundant-CFLAGS.patch
new file mode 100644
index 00000000..acb8bd74
--- /dev/null
+++ b/meta-amd-bsp/recipes-kernel/linux/linux-yocto-4.14.71/3534-amdgpu-dc-calcs-Consolidate-redundant-CFLAGS.patch
@@ -0,0 +1,37 @@
+From 43a7e36b72d4d14c6bef80aa80ae3749f6f80e58 Mon Sep 17 00:00:00 2001
+From: Matthias Kaehlcke <mka@chromium.org>
+Date: Thu, 8 Feb 2018 12:53:14 -0800
+Subject: [PATCH 3534/4131] amdgpu/dc/calcs: Consolidate redundant CFLAGS
+
+Use a variable for common CFLAGS instead of specifying the same flags
+for every source file.
+
+Signed-off-by: Matthias Kaehlcke <mka@chromium.org>
+Reviewed-by: Harry Wentland <harry.wentland@amd.com>
+Signed-off-by: Alex Deucher <alexander.deucher@amd.com>
+---
+ drivers/gpu/drm/amd/display/dc/calcs/Makefile | 8 +++++---
+ 1 file changed, 5 insertions(+), 3 deletions(-)
+
+diff --git a/drivers/gpu/drm/amd/display/dc/calcs/Makefile b/drivers/gpu/drm/amd/display/dc/calcs/Makefile
+index 41ef359..ac4b936 100644
+--- a/drivers/gpu/drm/amd/display/dc/calcs/Makefile
++++ b/drivers/gpu/drm/amd/display/dc/calcs/Makefile
+@@ -3,9 +3,11 @@
+ # It calculates Bandwidth and Watermarks values for HW programming
+ #
+
+-CFLAGS_dcn_calcs.o := -mhard-float -msse -mpreferred-stack-boundary=4
+-CFLAGS_dcn_calc_auto.o := -mhard-float -msse -mpreferred-stack-boundary=4
+-CFLAGS_dcn_calc_math.o := -mhard-float -msse -mpreferred-stack-boundary=4 -Wno-tautological-compare
++calcs_ccflags := -mhard-float -msse -mpreferred-stack-boundary=4
++
++CFLAGS_dcn_calcs.o := $(calcs_ccflags)
++CFLAGS_dcn_calc_auto.o := $(calcs_ccflags)
++CFLAGS_dcn_calc_math.o := $(calcs_ccflags) -Wno-tautological-compare
+
+ BW_CALCS = dce_calcs.o bw_fixed.o custom_float.o
+
+--
+2.7.4
+