aboutsummaryrefslogtreecommitdiffstats
path: root/meta-amd-bsp/recipes-kernel/linux/linux-yocto-4.14.71/3533-amdgpu-dc-dml-Consolidate-redundant-CFLAGS.patch
diff options
context:
space:
mode:
Diffstat (limited to 'meta-amd-bsp/recipes-kernel/linux/linux-yocto-4.14.71/3533-amdgpu-dc-dml-Consolidate-redundant-CFLAGS.patch')
-rw-r--r--meta-amd-bsp/recipes-kernel/linux/linux-yocto-4.14.71/3533-amdgpu-dc-dml-Consolidate-redundant-CFLAGS.patch46
1 files changed, 46 insertions, 0 deletions
diff --git a/meta-amd-bsp/recipes-kernel/linux/linux-yocto-4.14.71/3533-amdgpu-dc-dml-Consolidate-redundant-CFLAGS.patch b/meta-amd-bsp/recipes-kernel/linux/linux-yocto-4.14.71/3533-amdgpu-dc-dml-Consolidate-redundant-CFLAGS.patch
new file mode 100644
index 00000000..82382c4e
--- /dev/null
+++ b/meta-amd-bsp/recipes-kernel/linux/linux-yocto-4.14.71/3533-amdgpu-dc-dml-Consolidate-redundant-CFLAGS.patch
@@ -0,0 +1,46 @@
+From 03075bb85273ac9edc4999c4dc8bed38af2de931 Mon Sep 17 00:00:00 2001
+From: Matthias Kaehlcke <mka@chromium.org>
+Date: Thu, 8 Feb 2018 12:53:13 -0800
+Subject: [PATCH 3533/4131] amdgpu/dc/dml: Consolidate redundant CFLAGS
+
+Use a variable for common CFLAGS instead of specifying the same flags
+for every source file.
+
+Signed-off-by: Matthias Kaehlcke <mka@chromium.org>
+Reviewed-by: Harry Wentland <harry.wentland@amd.com>
+Signed-off-by: Alex Deucher <alexander.deucher@amd.com>
+Signed-off-by: Kalyan Alle <kalyan.alle@amd.com>
+---
+ drivers/gpu/drm/amd/display/dc/dml/Makefile | 16 +++++++++-------
+ 1 file changed, 9 insertions(+), 7 deletions(-)
+
+diff --git a/drivers/gpu/drm/amd/display/dc/dml/Makefile b/drivers/gpu/drm/amd/display/dc/dml/Makefile
+index cea34ff..f99b321 100644
+--- a/drivers/gpu/drm/amd/display/dc/dml/Makefile
++++ b/drivers/gpu/drm/amd/display/dc/dml/Makefile
+@@ -3,13 +3,15 @@
+ # It provides the general basic services required by other DAL
+ # subcomponents.
+
+-CFLAGS_display_mode_vba.o := -mhard-float -msse -mpreferred-stack-boundary=4
+-CFLAGS_display_mode_lib.o := -mhard-float -msse -mpreferred-stack-boundary=4
+-CFLAGS_display_pipe_clocks.o := -mhard-float -msse -mpreferred-stack-boundary=4
+-CFLAGS_dml1_display_rq_dlg_calc.o := -mhard-float -msse -mpreferred-stack-boundary=4
+-CFLAGS_display_rq_dlg_helpers.o := -mhard-float -msse -mpreferred-stack-boundary=4
+-CFLAGS_soc_bounding_box.o := -mhard-float -msse -mpreferred-stack-boundary=4
+-CFLAGS_dml_common_defs.o := -mhard-float -msse -mpreferred-stack-boundary=4
++dml_ccflags := -mhard-float -msse -mpreferred-stack-boundary=4
++
++CFLAGS_display_mode_vba.o := $(dml_ccflags)
++CFLAGS_display_mode_lib.o := $(dml_ccflags)
++CFLAGS_display_pipe_clocks.o := $(dml_ccflags)
++CFLAGS_dml1_display_rq_dlg_calc.o := $(dml_ccflags)
++CFLAGS_display_rq_dlg_helpers.o := $(dml_ccflags)
++CFLAGS_soc_bounding_box.o := $(dml_ccflags)
++CFLAGS_dml_common_defs.o := $(dml_ccflags)
+
+ DML = display_mode_lib.o display_rq_dlg_helpers.o dml1_display_rq_dlg_calc.o \
+ soc_bounding_box.o dml_common_defs.o
+--
+2.7.4
+