aboutsummaryrefslogtreecommitdiffstats
path: root/meta-amd-bsp/recipes-kernel/linux/linux-yocto-4.14.71/2543-drm-amd-display-Ignore-wrong-tautological-warning.patch
diff options
context:
space:
mode:
Diffstat (limited to 'meta-amd-bsp/recipes-kernel/linux/linux-yocto-4.14.71/2543-drm-amd-display-Ignore-wrong-tautological-warning.patch')
-rw-r--r--meta-amd-bsp/recipes-kernel/linux/linux-yocto-4.14.71/2543-drm-amd-display-Ignore-wrong-tautological-warning.patch33
1 files changed, 33 insertions, 0 deletions
diff --git a/meta-amd-bsp/recipes-kernel/linux/linux-yocto-4.14.71/2543-drm-amd-display-Ignore-wrong-tautological-warning.patch b/meta-amd-bsp/recipes-kernel/linux/linux-yocto-4.14.71/2543-drm-amd-display-Ignore-wrong-tautological-warning.patch
new file mode 100644
index 00000000..5184d9bf
--- /dev/null
+++ b/meta-amd-bsp/recipes-kernel/linux/linux-yocto-4.14.71/2543-drm-amd-display-Ignore-wrong-tautological-warning.patch
@@ -0,0 +1,33 @@
+From d73c5624eb62a1b88f18296d53ee6b9b2bf0e773 Mon Sep 17 00:00:00 2001
+From: Harry Wentland <harry.wentland@amd.com>
+Date: Mon, 2 Oct 2017 15:27:26 -0400
+Subject: [PATCH 2543/4131] drm/amd/display: Ignore wrong tautological warning
+
+Some of our HW calcs functions compares a var against
+itself to check for NaN. Gcc isn't fond of it and wrongfully
+warns about a tautological comparison. Disable this check
+for dcn_calcs_math.c.
+
+Signed-off-by: Harry Wentland <harry.wentland@amd.com>
+Reviewed-by: Dmytro Laktyushkin <Dmytro.Laktyushkin@amd.com>
+Acked-by: Harry Wentland <Harry.Wentland@amd.com>
+---
+ drivers/gpu/drm/amd/display/dc/calcs/Makefile | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/drivers/gpu/drm/amd/display/dc/calcs/Makefile b/drivers/gpu/drm/amd/display/dc/calcs/Makefile
+index a095472..41ef359 100644
+--- a/drivers/gpu/drm/amd/display/dc/calcs/Makefile
++++ b/drivers/gpu/drm/amd/display/dc/calcs/Makefile
+@@ -5,7 +5,7 @@
+
+ CFLAGS_dcn_calcs.o := -mhard-float -msse -mpreferred-stack-boundary=4
+ CFLAGS_dcn_calc_auto.o := -mhard-float -msse -mpreferred-stack-boundary=4
+-CFLAGS_dcn_calc_math.o := -mhard-float -msse -mpreferred-stack-boundary=4
++CFLAGS_dcn_calc_math.o := -mhard-float -msse -mpreferred-stack-boundary=4 -Wno-tautological-compare
+
+ BW_CALCS = dce_calcs.o bw_fixed.o custom_float.o
+
+--
+2.7.4
+