aboutsummaryrefslogtreecommitdiffstats
path: root/meta-amd-bsp/recipes-kernel/linux/linux-yocto-4.14.71/2444-amdgpu-dc-inline-all-the-signal_types-code.patch
diff options
context:
space:
mode:
Diffstat (limited to 'meta-amd-bsp/recipes-kernel/linux/linux-yocto-4.14.71/2444-amdgpu-dc-inline-all-the-signal_types-code.patch')
-rw-r--r--meta-amd-bsp/recipes-kernel/linux/linux-yocto-4.14.71/2444-amdgpu-dc-inline-all-the-signal_types-code.patch187
1 files changed, 187 insertions, 0 deletions
diff --git a/meta-amd-bsp/recipes-kernel/linux/linux-yocto-4.14.71/2444-amdgpu-dc-inline-all-the-signal_types-code.patch b/meta-amd-bsp/recipes-kernel/linux/linux-yocto-4.14.71/2444-amdgpu-dc-inline-all-the-signal_types-code.patch
new file mode 100644
index 00000000..6e3c90ef
--- /dev/null
+++ b/meta-amd-bsp/recipes-kernel/linux/linux-yocto-4.14.71/2444-amdgpu-dc-inline-all-the-signal_types-code.patch
@@ -0,0 +1,187 @@
+From bfbd3614bd1c6be1c97990045900689a4752f79f Mon Sep 17 00:00:00 2001
+From: Dave Airlie <airlied@redhat.com>
+Date: Fri, 29 Sep 2017 17:13:28 +1000
+Subject: [PATCH 2444/4131] amdgpu/dc: inline all the signal_types code.
+
+This is worth 300 bytes, and one less source file.
+
+Signed-off-by: Dave Airlie <airlied@redhat.com>
+Reviewed-by: Harry Wentland <harry.wentland@amd.com>
+---
+ drivers/gpu/drm/amd/display/dc/basics/Makefile | 2 +-
+ .../gpu/drm/amd/display/dc/basics/signal_types.c | 80 ----------------------
+ drivers/gpu/drm/amd/display/include/signal_types.h | 59 +++++++++++++---
+ 3 files changed, 52 insertions(+), 89 deletions(-)
+ delete mode 100644 drivers/gpu/drm/amd/display/dc/basics/signal_types.c
+
+diff --git a/drivers/gpu/drm/amd/display/dc/basics/Makefile b/drivers/gpu/drm/amd/display/dc/basics/Makefile
+index 0658162..43c5ccd 100644
+--- a/drivers/gpu/drm/amd/display/dc/basics/Makefile
++++ b/drivers/gpu/drm/amd/display/dc/basics/Makefile
+@@ -4,7 +4,7 @@
+ # subcomponents.
+
+ BASICS = conversion.o fixpt31_32.o fixpt32_32.o grph_object_id.o \
+- logger.o log_helpers.o signal_types.o vector.o
++ logger.o log_helpers.o vector.o
+
+ AMD_DAL_BASICS = $(addprefix $(AMDDALPATH)/dc/basics/,$(BASICS))
+
+diff --git a/drivers/gpu/drm/amd/display/dc/basics/signal_types.c b/drivers/gpu/drm/amd/display/dc/basics/signal_types.c
+deleted file mode 100644
+index 534c803..0000000
+--- a/drivers/gpu/drm/amd/display/dc/basics/signal_types.c
++++ /dev/null
+@@ -1,80 +0,0 @@
+-/*
+- * Copyright 2012-15 Advanced Micro Devices, Inc.
+- *
+- * Permission is hereby granted, free of charge, to any person obtaining a
+- * copy of this software and associated documentation files (the "Software"),
+- * to deal in the Software without restriction, including without limitation
+- * the rights to use, copy, modify, merge, publish, distribute, sublicense,
+- * and/or sell copies of the Software, and to permit persons to whom the
+- * Software is furnished to do so, subject to the following conditions:
+- *
+- * The above copyright notice and this permission notice shall be included in
+- * all copies or substantial portions of the Software.
+- *
+- * THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
+- * IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
+- * FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL
+- * THE COPYRIGHT HOLDER(S) OR AUTHOR(S) BE LIABLE FOR ANY CLAIM, DAMAGES OR
+- * OTHER LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE,
+- * ARISING FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR
+- * OTHER DEALINGS IN THE SOFTWARE.
+- *
+- * Authors: AMD
+- *
+- */
+-
+-#include "dm_services.h"
+-#include "include/signal_types.h"
+-
+-bool dc_is_hdmi_signal(enum signal_type signal)
+-{
+- return (signal == SIGNAL_TYPE_HDMI_TYPE_A);
+-}
+-
+-bool dc_is_dp_sst_signal(enum signal_type signal)
+-{
+- return (signal == SIGNAL_TYPE_DISPLAY_PORT ||
+- signal == SIGNAL_TYPE_EDP);
+-}
+-
+-bool dc_is_dp_signal(enum signal_type signal)
+-{
+- return (signal == SIGNAL_TYPE_DISPLAY_PORT ||
+- signal == SIGNAL_TYPE_EDP ||
+- signal == SIGNAL_TYPE_DISPLAY_PORT_MST);
+-}
+-
+-bool dc_is_embedded_signal(enum signal_type signal)
+-{
+- return (signal == SIGNAL_TYPE_EDP || signal == SIGNAL_TYPE_LVDS);
+-}
+-
+-bool dc_is_dvi_signal(enum signal_type signal)
+-{
+- switch (signal) {
+- case SIGNAL_TYPE_DVI_SINGLE_LINK:
+- case SIGNAL_TYPE_DVI_DUAL_LINK:
+- return true;
+- break;
+- default:
+- return false;
+- }
+-}
+-
+-bool dc_is_dvi_single_link_signal(enum signal_type signal)
+-{
+- return (signal == SIGNAL_TYPE_DVI_SINGLE_LINK);
+-}
+-
+-bool dc_is_dual_link_signal(enum signal_type signal)
+-{
+- return (signal == SIGNAL_TYPE_DVI_DUAL_LINK);
+-}
+-
+-bool dc_is_audio_capable_signal(enum signal_type signal)
+-{
+- return (signal == SIGNAL_TYPE_DISPLAY_PORT ||
+- signal == SIGNAL_TYPE_DISPLAY_PORT_MST ||
+- dc_is_hdmi_signal(signal));
+-}
+-
+diff --git a/drivers/gpu/drm/amd/display/include/signal_types.h b/drivers/gpu/drm/amd/display/include/signal_types.h
+index 1a2ca53..b5ebde6 100644
+--- a/drivers/gpu/drm/amd/display/include/signal_types.h
++++ b/drivers/gpu/drm/amd/display/include/signal_types.h
+@@ -40,13 +40,56 @@ enum signal_type {
+ };
+
+ /* help functions for signal types manipulation */
+-bool dc_is_hdmi_signal(enum signal_type signal);
+-bool dc_is_dp_sst_signal(enum signal_type signal);
+-bool dc_is_dp_signal(enum signal_type signal);
+-bool dc_is_embedded_signal(enum signal_type signal);
+-bool dc_is_dvi_signal(enum signal_type signal);
+-bool dc_is_dvi_single_link_signal(enum signal_type signal);
+-bool dc_is_dual_link_signal(enum signal_type signal);
+-bool dc_is_audio_capable_signal(enum signal_type signal);
++static inline bool dc_is_hdmi_signal(enum signal_type signal)
++{
++ return (signal == SIGNAL_TYPE_HDMI_TYPE_A);
++}
++
++static inline bool dc_is_dp_sst_signal(enum signal_type signal)
++{
++ return (signal == SIGNAL_TYPE_DISPLAY_PORT ||
++ signal == SIGNAL_TYPE_EDP);
++}
++
++static inline bool dc_is_dp_signal(enum signal_type signal)
++{
++ return (signal == SIGNAL_TYPE_DISPLAY_PORT ||
++ signal == SIGNAL_TYPE_EDP ||
++ signal == SIGNAL_TYPE_DISPLAY_PORT_MST);
++}
++
++static inline bool dc_is_embedded_signal(enum signal_type signal)
++{
++ return (signal == SIGNAL_TYPE_EDP || signal == SIGNAL_TYPE_LVDS);
++}
++
++static inline bool dc_is_dvi_signal(enum signal_type signal)
++{
++ switch (signal) {
++ case SIGNAL_TYPE_DVI_SINGLE_LINK:
++ case SIGNAL_TYPE_DVI_DUAL_LINK:
++ return true;
++ break;
++ default:
++ return false;
++ }
++}
++
++static inline bool dc_is_dvi_single_link_signal(enum signal_type signal)
++{
++ return (signal == SIGNAL_TYPE_DVI_SINGLE_LINK);
++}
++
++static inline bool dc_is_dual_link_signal(enum signal_type signal)
++{
++ return (signal == SIGNAL_TYPE_DVI_DUAL_LINK);
++}
++
++static inline bool dc_is_audio_capable_signal(enum signal_type signal)
++{
++ return (signal == SIGNAL_TYPE_DISPLAY_PORT ||
++ signal == SIGNAL_TYPE_DISPLAY_PORT_MST ||
++ dc_is_hdmi_signal(signal));
++}
+
+ #endif
+--
+2.7.4
+