aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-devtools
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-devtools')
-rw-r--r--recipes-devtools/doxygen/doxygen/patch-flex_2_6_0.diff66
-rw-r--r--recipes-devtools/doxygen/doxygen_1.8.9.1.bb36
-rw-r--r--recipes-devtools/gdbc6x/gdbc6x.inc9
-rw-r--r--recipes-devtools/gdbc6x/gdbc6x/0001-libbfd.h-suppress-GCC9-Wstringop-truncation.patch28
-rw-r--r--recipes-devtools/gdbc6x/gdbc6x/init48
-rw-r--r--recipes-devtools/gdbc6x/gdbc6x_git.bb49
-rw-r--r--recipes-devtools/gdbc6x/gdbserver-c6x_git.bb50
-rw-r--r--recipes-devtools/gdbc6x/gdbserverproxy-module-drv_git.bb32
-rw-r--r--recipes-devtools/ion/libion/0001-cmake-Use-GNUInstallDirs-module-to-detect-install-pa.patch48
-rw-r--r--recipes-devtools/ion/libion_git.bb16
-rw-r--r--recipes-devtools/k3conf/k3conf_git.bb24
11 files changed, 0 insertions, 406 deletions
diff --git a/recipes-devtools/doxygen/doxygen/patch-flex_2_6_0.diff b/recipes-devtools/doxygen/doxygen/patch-flex_2_6_0.diff
deleted file mode 100644
index 36d73798..00000000
--- a/recipes-devtools/doxygen/doxygen/patch-flex_2_6_0.diff
+++ /dev/null
@@ -1,66 +0,0 @@
---- src/code.l.orig
-+++ src/code.l
-@@ -3695,7 +3695,7 @@ void codeFreeScanner()
- extern "C" { // some bogus code to keep the compiler happy
- void codeYYdummy() { yy_flex_realloc(0,0); }
- }
--#elif YY_FLEX_SUBMINOR_VERSION<33
-+#elif YY_FLEX_MAJOR_VERSION<=2 && YY_FLEX_MINOR_VERSION<=5 && YY_FLEX_SUBMINOR_VERSION<33
- #error "You seem to be using a version of flex newer than 2.5.4 but older than 2.5.33. These versions do NOT work with doxygen! Please use version <=2.5.4 or >=2.5.33 or expect things to be parsed wrongly!"
- #endif
-
---- src/commentscan.l.orig
-+++ src/commentscan.l
-@@ -1098,7 +1098,7 @@ RCSTAG "$"{ID}":"[^\n$]+"$"
- // but we need to know the position in the input buffer where this
- // rule matched.
- // for flex 2.5.33+ we should use YY_CURRENT_BUFFER_LVALUE
--#if YY_FLEX_MINOR_VERSION>=5 && YY_FLEX_SUBMINOR_VERSION>=33
-+#if YY_FLEX_MAJOR_VERSION>=2 && (YY_FLEX_MINOR_VERSION>5 || (YY_FLEX_MINOR_VERSION==5 && YY_FLEX_SUBMINOR_VERSION>=33))
- inputPosition=prevPosition + (int)(yy_bp - YY_CURRENT_BUFFER_LVALUE->yy_ch_buf);
- #else
- inputPosition=prevPosition + (int)(yy_bp - yy_current_buffer->yy_ch_buf);
-@@ -1160,7 +1160,7 @@ RCSTAG "$"{ID}":"[^\n$]+"$"
- g_memberGroupHeader.resize(0);
- parseMore=TRUE;
- needNewEntry = TRUE;
--#if YY_FLEX_MINOR_VERSION>=5 && YY_FLEX_SUBMINOR_VERSION>=33
-+#if YY_FLEX_MAJOR_VERSION>=2 && (YY_FLEX_MINOR_VERSION>5 || (YY_FLEX_MINOR_VERSION==5 && YY_FLEX_SUBMINOR_VERSION>=33))
- inputPosition=prevPosition + (int)(yy_bp - YY_CURRENT_BUFFER_LVALUE->yy_ch_buf) + strlen(yytext);
- #else
- inputPosition=prevPosition + (int)(yy_bp - yy_current_buffer->yy_ch_buf) + strlen(yytext);
-
---- src/fortrancode.l.orig
-+++ src/fortrancode.l
-@@ -1289,7 +1289,7 @@ void parseFortranCode(CodeOutputInterfac
- extern "C" { // some bogus code to keep the compiler happy
- void fortrancodeYYdummy() { yy_flex_realloc(0,0); }
- }
--#elif YY_FLEX_SUBMINOR_VERSION<33
-+#elif YY_FLEX_MAJOR_VERSION<=2 && YY_FLEX_MINOR_VERSION<=5 && YY_FLEX_SUBMINOR_VERSION<33
- #error "You seem to be using a version of flex newer than 2.5.4 but older than 2.5.33. These versions do NOT work with doxygen! Please use version <=2.5.4 or >=2.5.33 or expect things to be parsed wrongly!"
- #else
- extern "C" { // some bogus code to keep the compiler happy
-
---- src/pycode.l.orig
-+++ src/pycode.l
-@@ -1503,7 +1503,7 @@ void parsePythonCode(CodeOutputInterface
- extern "C" { // some bogus code to keep the compiler happy
- void pycodeYYdummy() { yy_flex_realloc(0,0); }
- }
--#elif YY_FLEX_SUBMINOR_VERSION<33
-+#elif YY_FLEX_MAJOR_VERSION<=2 && YY_FLEX_MINOR_VERSION<=5 && YY_FLEX_SUBMINOR_VERSION<33
- #error "You seem to be using a version of flex newer than 2.5.4. These are currently incompatible with 2.5.4, and do NOT work with doxygen! Please use version 2.5.4 or expect things to be parsed wrongly! A bug report has been submitted (#732132)."
- #endif
-
---- src/vhdlcode.l
-+++ src.a/vhdlcode.l
-@@ -1613,7 +1613,7 @@ void codeFreeVhdlScanner()
- extern "C" { // some bogus code to keep the compiler happy
- void vhdlcodeYYdummy() { yy_flex_realloc(0,0); }
- }
--#elif YY_FLEX_SUBMINOR_VERSION<33
-+#elif YY_FLEX_MAJOR_VERSION<=2 && YY_FLEX_MINOR_VERSION<=5 && YY_FLEX_SUBMINOR_VERSION<33
- #error "You seem to be using a version of flex newer than 2.5.4 but older than 2.5.33. These versions do NOT work with doxygen! Please use version <=2.5.4 or >=2.5.33 or expect things to be parsed wrongly!"
- #endif
-
diff --git a/recipes-devtools/doxygen/doxygen_1.8.9.1.bb b/recipes-devtools/doxygen/doxygen_1.8.9.1.bb
deleted file mode 100644
index eb43e741..00000000
--- a/recipes-devtools/doxygen/doxygen_1.8.9.1.bb
+++ /dev/null
@@ -1,36 +0,0 @@
-SUMMARY = "Utilities for generating documentation from source code"
-HOMEPAGE = "http://www.doxygen.org/"
-SECTION = "console/utils"
-LICENSE = "GPLv2"
-LIC_FILES_CHKSUM = "file://LICENSE;md5=b380c86cea229fa42b9e543fc491f5eb"
-
-DEPENDS = "flex-native bison-native"
-
-SRC_URI = "http://ftp.stack.nl/pub/users/dimitri/${BP}.src.tar.gz \
- file://patch-flex_2_6_0.diff;striplevel=0"
-
-SRC_URI[md5sum] = "3d1a5c26bef358c10a3894f356a69fbc"
-SRC_URI[sha256sum] = "d4ab6e28d4d45d8956cad17470aade3fbe2356e8f64b92167e738c1887feccec"
-
-EXTRA_OECONF = "--prefix ${prefix}"
-
-DISABLE_STATIC = ""
-
-do_configure () {
- ./configure ${EXTRA_OECONF}
-
- # TODO on rebuilds will repeatedly append. Change logic to include a
- # separate file and overwrite that file?
- echo "TMAKE_CC=${CC}" >> tmake/lib/linux-g++/tmake.conf
- echo "TMAKE_CXX=${CXX}" >> tmake/lib/linux-g++/tmake.conf
- echo "TMAKE_CFLAGS=${CFLAGS}" >> tmake/lib/linux-g++/tmake.conf
- echo "TMAKE_CXXFLAGS=${CXXFLAGS}" >> tmake/lib/linux-g++/tmake.conf
- echo "TMAKE_LINK=${CXX}" >> tmake/lib/linux-g++/tmake.conf
- echo "TMAKE_LFLAGS=${LDFLAGS}" >> tmake/lib/linux-g++/tmake.conf
-}
-
-do_install() {
- oe_runmake install DESTDIR=${D} MAN1DIR=share/man/man1
-}
-
-BBCLASSEXTEND = "native nativesdk"
diff --git a/recipes-devtools/gdbc6x/gdbc6x.inc b/recipes-devtools/gdbc6x/gdbc6x.inc
deleted file mode 100644
index eeb18fb1..00000000
--- a/recipes-devtools/gdbc6x/gdbc6x.inc
+++ /dev/null
@@ -1,9 +0,0 @@
-# This corresponds to version 1.1.0
-SRCREV = "dd0c82fb5763a6b32dc6d68e561efb66ab8283d7"
-
-PV = "1.1.0"
-INC_PR = "r7"
-
-SRC_URI = "git://git.ti.com/sdo-emu/gdbc6x.git;protocol=git;branch=${BRANCH}"
-
-BRANCH = "master"
diff --git a/recipes-devtools/gdbc6x/gdbc6x/0001-libbfd.h-suppress-GCC9-Wstringop-truncation.patch b/recipes-devtools/gdbc6x/gdbc6x/0001-libbfd.h-suppress-GCC9-Wstringop-truncation.patch
deleted file mode 100644
index 1cc23b32..00000000
--- a/recipes-devtools/gdbc6x/gdbc6x/0001-libbfd.h-suppress-GCC9-Wstringop-truncation.patch
+++ /dev/null
@@ -1,28 +0,0 @@
-From 0aa294e2bbd37a42266e59cb67687e57bfba4a88 Mon Sep 17 00:00:00 2001
-From: Denys Dmytriyenko <denys@ti.com>
-Date: Sat, 15 Feb 2020 15:59:37 -0500
-Subject: [PATCH] libbfd.h: suppress GCC9 -Wstringop-truncation
-
-Signed-off-by: Denys Dmytriyenko <denys@ti.com>
----
- gdbc6x/bfd/libbfd.h | 4 ++++
- 1 file changed, 4 insertions(+)
-
-diff --git a/gdbc6x/bfd/libbfd.h b/gdbc6x/bfd/libbfd.h
-index 72d3c50..3465f89 100644
---- a/gdbc6x/bfd/libbfd.h
-+++ b/gdbc6x/bfd/libbfd.h
-@@ -34,6 +34,10 @@
- #pragma GCC diagnostic ignored "-Wcast-function-type"
- #endif
-
-+#if __GNUC__ >= 9
-+#pragma GCC diagnostic ignored "-Wstringop-truncation"
-+#endif
-+
- #include "hashtab.h"
-
- /* Align an address upward to a boundary, expressed as a number of bytes.
---
-2.7.4
-
diff --git a/recipes-devtools/gdbc6x/gdbc6x/init b/recipes-devtools/gdbc6x/gdbc6x/init
deleted file mode 100644
index 90210b82..00000000
--- a/recipes-devtools/gdbc6x/gdbc6x/init
+++ /dev/null
@@ -1,48 +0,0 @@
-#!/bin/bash
-
-GDB_DEVICE_NAME='/dev/gdbtty$i'
-DSP_FIRMWARE_NAME='/lib/firmware/dra7-dsp$[$i+1]-fw.xe66'
-
-DSP_L2_GLOBAL_OFFSET="40000000"
-DSP_L2_GLOBAL_SHIFT="00800000"
-
-case "$1" in
- start)
-
- dsp_core_l2_offset=$DSP_L2_GLOBAL_OFFSET
-
- i=0
- while [ -c "`eval echo $GDB_DEVICE_NAME`" ]
- do
- dsp_firmware=`eval echo $DSP_FIRMWARE_NAME`
-
- if [ -f "`eval echo $DSP_FIRMWARE_NAME`" ]
- then
- eval echo "Initializing $GDB_DEVICE_NAME based on $DSP_FIRMWARE_NAME ..."
-
- gdb_data_local=`eval readelf -s "$DSP_FIRMWARE_NAME" | \
- grep 'gdb_globalData' | \
- awk '{print $2}'`
-
- echo "gdb_globalData (local) = $gdb_data_local"
- printf "gdb_globalData (global) = %X\n" \
- $[0x$gdb_data_local + 0x$dsp_core_l2_offset]
-
-
- printf "%X\n" $[0x$gdb_data_local + 0x$dsp_core_l2_offset] \
- >> `eval echo $GDB_DEVICE_NAME`
- fi
- i=$[$i + 1]
- dsp_core_l2_offset=`printf "%X" $[0x$dsp_core_l2_offset + 0x$DSP_L2_GLOBAL_SHIFT]`
- done
- ;;
- stop)
- # Nothing to be done.
- ;;
- *)
- echo "Usage: $0 {start|stop}"
- exit 1
- ;;
-esac
-
-
diff --git a/recipes-devtools/gdbc6x/gdbc6x_git.bb b/recipes-devtools/gdbc6x/gdbc6x_git.bb
deleted file mode 100644
index aa519a91..00000000
--- a/recipes-devtools/gdbc6x/gdbc6x_git.bb
+++ /dev/null
@@ -1,49 +0,0 @@
-DESCRIPTION = "GNU debugger for TI C6X DSP."
-SECTION = "devel"
-LICENSE = "GPLv3+"
-LIC_FILES_CHKSUM = "file://debian/copyright;md5=bf0fe2872eb3dfeebb2cbe38206fe81f"
-
-DEPENDS = "ncurses bison-native texinfo flex-native gettext"
-
-COMPATIBLE_MACHINE = "dra7xx|keystone"
-
-PR = "${INC_PR}.1"
-
-SRC_URI_append = " \
- file://init \
- file://0001-libbfd.h-suppress-GCC9-Wstringop-truncation.patch;striplevel=2 \
-"
-
-S = "${WORKDIR}/git/gdbc6x"
-
-inherit update-rc.d
-inherit gettext
-
-CFLAGS += "-fcommon"
-
-do_configure () {
- cd ${S}
- ./configure --program-suffix=c6x --target=tic6x-elf-tirtos --host=${HOST_SYS} --prefix=${S}/install_gdb
-}
-
-do_install () {
- make install
-
- # Custom install to prevent conflict with standard GDB.
- install -d ${D}${bindir}
- install -d ${D}${includedir}
- install -m 755 ${S}/install_gdb/bin/gdbc6x ${D}${bindir}
- cp -rf ${S}/install_gdb/include/* ${D}${includedir}
-
- install -d ${D}${sysconfdir}/init.d
- install -m 0755 ${WORKDIR}/init ${D}${sysconfdir}/init.d/gdbserverproxy
-}
-
-RDEPENDS_${PN} = "gdbserverproxy-module-drv bash"
-
-include gdbc6x.inc
-
-INITSCRIPT_NAME = "gdbserverproxy"
-INITSCRIPT_PARAMS = "defaults 95"
-
-PARALLEL_MAKE = ""
diff --git a/recipes-devtools/gdbc6x/gdbserver-c6x_git.bb b/recipes-devtools/gdbc6x/gdbserver-c6x_git.bb
deleted file mode 100644
index 79b584be..00000000
--- a/recipes-devtools/gdbc6x/gdbserver-c6x_git.bb
+++ /dev/null
@@ -1,50 +0,0 @@
-DESCRIPTION = "TI gdb-server to be used with c6xgdb."
-LICENSE = "BSD"
-LIC_FILES_CHKSUM = "file://../debian/copyright;md5=82c616b6c8f9c11c46feaaf8f9a11495"
-
-DEPENDS = "ti-xdais ti-framework-components ti-cgt6x-native ti-sysbios ti-xdctools-native"
-
-PR = "${INC_PR}.0"
-
-S = "${WORKDIR}/git/gdbserver-c6x/src"
-
-PLATFORM = ""
-PLATFORM_dra7xx = "DRA7xx_PLATFORM"
-PLATFORM_keystone = "KEYSTONE_PLATFORM"
-
-EXTRA_OEMAKE = "PLATFORM=${PLATFORM}"
-
-export XDAIS_DIR = "${XDAIS_INSTALL_DIR}"
-export FC_DIR = "${FC_INSTALL_DIR}"
-export TI_CGT_INSTALL = "${STAGING_DIR_NATIVE}/usr/share/ti/cgt-c6x"
-export BIOS_DIR = "${SYSBIOS_INSTALL_DIR}"
-export XDC_DIR = "${XDC_INSTALL_DIR}"
-
-# The following is to prevent an unused configure.ac from erroneously
-# triggering the QA check for gettext.
-EXTRA_OECONF = "--disable-nls"
-do_configure() {
- :
-}
-
-do_install() {
- install -d ${D}${datadir}/ti/gdbc6x/include
- install -d ${D}${datadir}/ti/gdbc6x/lib
- cp -f ../include/* ${D}${datadir}/ti/gdbc6x/include
- cp -f ../lib/* ${D}${datadir}/ti/gdbc6x/lib
-}
-
-COMPATIBLE_MACHINE = "dra7xx|keystone"
-PACKAGE_ARCH = "${MACHINE_ARCH}"
-
-FILES_${PN}-dev += "\
- ${datadir}/ti/gdbc6x \
-"
-
-include gdbc6x.inc
-
-require recipes-ti/includes/ti-paths.inc
-
-ALLOW_EMPTY_${PN} = "1"
-
-PARALLEL_MAKE = ""
diff --git a/recipes-devtools/gdbc6x/gdbserverproxy-module-drv_git.bb b/recipes-devtools/gdbc6x/gdbserverproxy-module-drv_git.bb
deleted file mode 100644
index 77a29ec8..00000000
--- a/recipes-devtools/gdbc6x/gdbserverproxy-module-drv_git.bb
+++ /dev/null
@@ -1,32 +0,0 @@
-DESCRIPTION = "Interface for GDB to commincate witha TI C66X DSP"
-LICENSE = "GPLv2"
-LIC_FILES_CHKSUM = "file://COPYING.txt;md5=75859989545e37968a99b631ef42722e"
-
-# This package builds a kernel module, use kernel PR as base and append a local
-MACHINE_KERNEL_PR_append = "b"
-PR = "${MACHINE_KERNEL_PR}"
-PV_append = "+git${SRCPV}"
-
-S = "${WORKDIR}/git/kernel_module/gdbproxy-mod"
-
-inherit module
-
-PLATFORM = ""
-PLATFORM_dra7xx = "DRA7xx_PLATFORM"
-PLATFORM_keystone = "KEYSTONE_PLATFORM"
-
-EXTRA_OEMAKE = "PLATFORM=${PLATFORM} KVERSION=${KERNEL_VERSION} KERNEL_SRC=${STAGING_KERNEL_DIR}"
-
-# The following is to prevent an unused configure.ac from erroneously
-# triggering the QA check for gettext.
-EXTRA_OECONF = "--disable-nls"
-do_configure() {
- :
-}
-
-COMPATIBLE_MACHINE = "dra7xx|keystone"
-PACKAGE_ARCH = "${MACHINE_ARCH}"
-
-include gdbc6x.inc
-
-KERNEL_MODULE_AUTOLOAD += "gdbserverproxy"
diff --git a/recipes-devtools/ion/libion/0001-cmake-Use-GNUInstallDirs-module-to-detect-install-pa.patch b/recipes-devtools/ion/libion/0001-cmake-Use-GNUInstallDirs-module-to-detect-install-pa.patch
deleted file mode 100644
index bf63ed32..00000000
--- a/recipes-devtools/ion/libion/0001-cmake-Use-GNUInstallDirs-module-to-detect-install-pa.patch
+++ /dev/null
@@ -1,48 +0,0 @@
-From 51eece2c291e121f9ae67c9b812617b885e76a64 Mon Sep 17 00:00:00 2001
-From: Khem Raj <raj.khem@gmail.com>
-Date: Wed, 18 Dec 2019 20:31:52 -0800
-Subject: [PATCH] cmake: Use GNUInstallDirs module to detect install paths
-
-This helps it to calculate directories as per platform instead of
-hardcoding them, helps compile it for arches which use /lib64 and
-/usr/lib64 for libpaths
-
-Upstream-Status: Submitted [https://github.com/glneo/libion/pull/2]
-Signed-off-by: Khem Raj <raj.khem@gmail.com>
----
- CMakeLists.txt | 10 ++++++----
- 1 file changed, 6 insertions(+), 4 deletions(-)
-
-diff --git a/CMakeLists.txt b/CMakeLists.txt
-index 6e5928c..5b7c0de 100644
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -3,6 +3,8 @@ PROJECT(ion)
- set(PROJECT_DESCRIPTION "ION Userspace Memory Allocator Library")
- set(PROJECT_VERSION 1.0.0)
-
-+INCLUDE(GNUInstallDirs)
-+
- add_library(ion
- SHARED
- src/libion.c
-@@ -23,12 +25,12 @@ target_include_directories(ion
- configure_file(libion.pc.in libion.pc @ONLY)
-
- install(TARGETS ion
-- LIBRARY DESTINATION lib
-- PUBLIC_HEADER DESTINATION include/ion)
-+ LIBRARY DESTINATION ${CMAKE_INSTALL_LIBDIR}
-+ PUBLIC_HEADER DESTINATION ${CMAKE_INSTALL_INCLUDEDIR}/ion)
-
- install(DIRECTORY include/kernel-headers/4.19/
-- DESTINATION include
-+ DESTINATION ${CMAKE_INSTALL_INCLUDEDIR}
- FILES_MATCHING PATTERN "*.h")
-
- install(FILES ${CMAKE_BINARY_DIR}/libion.pc
-- DESTINATION lib/pkgconfig)
-+ DESTINATION ${CMAKE_INSTALL_LIBDIR}/pkgconfig)
---
-2.24.1
-
diff --git a/recipes-devtools/ion/libion_git.bb b/recipes-devtools/ion/libion_git.bb
deleted file mode 100644
index 4cf03afa..00000000
--- a/recipes-devtools/ion/libion_git.bb
+++ /dev/null
@@ -1,16 +0,0 @@
-SUMMARY = "ION Userspace Memory Allocator Library"
-HOMEPAGE = "https://github.com/glneo/libion"
-LICENSE = "Apache-2.0"
-LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327"
-
-PV = "1.0.0"
-
-BRANCH = "master"
-SRC_URI = "git://github.com/glneo/libion.git;protocol=git;branch=${BRANCH} \
- file://0001-cmake-Use-GNUInstallDirs-module-to-detect-install-pa.patch \
- "
-SRCREV = "813bd63e2f2118e17cb1c5d38505a1e572a2381c"
-
-S = "${WORKDIR}/git"
-
-inherit cmake pkgconfig
diff --git a/recipes-devtools/k3conf/k3conf_git.bb b/recipes-devtools/k3conf/k3conf_git.bb
deleted file mode 100644
index 0f2705b8..00000000
--- a/recipes-devtools/k3conf/k3conf_git.bb
+++ /dev/null
@@ -1,24 +0,0 @@
-SUMMARY = "Diagnostic tool for TI K3 processors"
-
-LICENSE = "BSD-3-Clause"
-LIC_FILES_CHKSUM = "file://common/k3conf.c;beginline=1;endline=34;md5=7154c0ffcd418064ffa528e34e70ca9d"
-
-PV = "0.2+git${SRCPV}"
-
-COMPATIBLE_MACHINE = "k3"
-
-BRANCH ?= "master"
-SRCREV = "79f007cd462384ce22e750e9002b714878f56892"
-
-SRC_URI = "git://git.ti.com/k3conf/k3conf.git;protocol=git;branch=${BRANCH}"
-
-S = "${WORKDIR}/git"
-
-do_compile () {
- oe_runmake CC="${CC}" CROSS_COMPILE=${TARGET_PREFIX} all
-}
-
-do_install () {
- install -d ${D}${bindir}
- install ${S}/k3conf ${D}${bindir}
-}