aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-devtools/python
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-devtools/python')
-rw-r--r--recipes-devtools/python/python-google-auth.inc21
-rw-r--r--recipes-devtools/python/python3-astunparse_1.6.3.bb12
-rw-r--r--recipes-devtools/python/python3-gast_0.4.0.bb12
-rw-r--r--recipes-devtools/python/python3-google-auth-oauthlib_0.4.5.bb20
-rw-r--r--recipes-devtools/python/python3-google-auth_2.0.0.bb2
-rw-r--r--recipes-devtools/python/python3-google-pasta_0.2.0.bb12
-rw-r--r--recipes-devtools/python/python3-mldtypes_0.2.0.bb28
-rw-r--r--recipes-devtools/python/python3-opt-einsum/0001-Use-ConfigParser-instead-of-SafeConfigParser.patch36
-rw-r--r--recipes-devtools/python/python3-opt-einsum_3.3.0.bb19
9 files changed, 162 insertions, 0 deletions
diff --git a/recipes-devtools/python/python-google-auth.inc b/recipes-devtools/python/python-google-auth.inc
new file mode 100644
index 0000000..91dbb21
--- /dev/null
+++ b/recipes-devtools/python/python-google-auth.inc
@@ -0,0 +1,21 @@
+SUMMARY = "Google Authentication Library"
+HOMEPAGE = "https://github.com/googleapis/google-auth-library-python"
+DESCRIPTION = "This library simplifies using Google’s various \
+server-to-server authentication mechanisms to access Google APIs."
+SECTION = "devel/python"
+
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327"
+
+inherit pypi
+
+SRC_URI[md5sum] = "2d7fb4328377b94603823e3f029a3e1d"
+SRC_URI[sha256sum] = "9e00c76e1bc7b1a7fe80472f1347f3802e4caa1fa53ba1f11b7af3772b484a82"
+
+RDEPENDS:${PN} += " \
+ python3-cachetools \
+ python3-rsa \
+ python3-pyasn1-modules \
+"
+
+BBCLASSEXTEND = "native"
diff --git a/recipes-devtools/python/python3-astunparse_1.6.3.bb b/recipes-devtools/python/python3-astunparse_1.6.3.bb
new file mode 100644
index 0000000..0cb5c5e
--- /dev/null
+++ b/recipes-devtools/python/python3-astunparse_1.6.3.bb
@@ -0,0 +1,12 @@
+SUMMARY = "An AST unparser for Python"
+HOMEPAGE = "https://github.com/simonpercivall/astunparse"
+SECTION = "devel/python"
+LICENSE = "PSF-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=7a7c771110c28a37480b73d07ad6d2a1"
+
+SRC_URI[md5sum] = "2cea4d8e49beba7684bac890e73d6a40"
+SRC_URI[sha256sum] = "5ad93a8456f0d084c3456d059fd9a92cce667963232cbf763eac3bc5b7940872"
+
+inherit pypi setuptools3
+
+BBCLASSEXTEND = "native"
diff --git a/recipes-devtools/python/python3-gast_0.4.0.bb b/recipes-devtools/python/python3-gast_0.4.0.bb
new file mode 100644
index 0000000..29a6c54
--- /dev/null
+++ b/recipes-devtools/python/python3-gast_0.4.0.bb
@@ -0,0 +1,12 @@
+SUMMARY = "A generic AST to represent Python3's Abstract Syntax Tree(AST)."
+HOMEPAGE = "https://github.com/serge-sans-paille/gast"
+SECTION = "devel/python"
+LICENSE = "BSD-3-Clause"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=a3ad9b6802e713fc5e307e1230f1ea90"
+
+SRC_URI[md5sum] = "d1f258eb70bb916f8fe5535351d5ff05"
+SRC_URI[sha256sum] = "40feb7b8b8434785585ab224d1568b857edb18297e5a3047f1ba012bc83b42c1"
+
+inherit pypi setuptools3
+
+BBCLASSEXTEND = "native"
diff --git a/recipes-devtools/python/python3-google-auth-oauthlib_0.4.5.bb b/recipes-devtools/python/python3-google-auth-oauthlib_0.4.5.bb
new file mode 100644
index 0000000..ecc2867
--- /dev/null
+++ b/recipes-devtools/python/python3-google-auth-oauthlib_0.4.5.bb
@@ -0,0 +1,20 @@
+SUMMARY = "The oauthlib integration for Google Auth"
+HOMEPAGE = "https://github.com/googleapis/google-auth-library-python-oauthlib"
+DESCRIPTION = "This library provides oauthlib integration with google-auth."
+SECTION = "devel/python"
+
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57"
+
+inherit pypi
+
+SRC_URI[md5sum] = "0ef7695adb47224714926a7e8331e61d"
+SRC_URI[sha256sum] = "4ab58e6c3dc6ccf112f921fcced40e5426fba266768986ea502228488276eaba"
+
+BBCLASSEXTEND = "native"
+
+RDEPENDS:${PN} += " \
+ python3-requests-oauthlib \
+ python3-oauthlib \
+"
+inherit setuptools3
diff --git a/recipes-devtools/python/python3-google-auth_2.0.0.bb b/recipes-devtools/python/python3-google-auth_2.0.0.bb
new file mode 100644
index 0000000..0d86a65
--- /dev/null
+++ b/recipes-devtools/python/python3-google-auth_2.0.0.bb
@@ -0,0 +1,2 @@
+inherit setuptools3
+require python-google-auth.inc
diff --git a/recipes-devtools/python/python3-google-pasta_0.2.0.bb b/recipes-devtools/python/python3-google-pasta_0.2.0.bb
new file mode 100644
index 0000000..50a363c
--- /dev/null
+++ b/recipes-devtools/python/python3-google-pasta_0.2.0.bb
@@ -0,0 +1,12 @@
+SUMMARY = "The AST-based Python refactoring library"
+HOMEPAGE = "https://github.com/google/pasta"
+SECTION = "devel/python"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://PKG-INFO;md5=a10102394a800f3fa4a3df0934d57bb1"
+
+SRC_URI[md5sum] = "7c218a4a0d84303b9319352040fbfce6"
+SRC_URI[sha256sum] = "c9f2c8dfc8f96d0d5808299920721be30c9eec37f2389f28904f454565c8a16e"
+
+inherit pypi setuptools3
+
+BBCLASSEXTEND = "native"
diff --git a/recipes-devtools/python/python3-mldtypes_0.2.0.bb b/recipes-devtools/python/python3-mldtypes_0.2.0.bb
new file mode 100644
index 0000000..a369b25
--- /dev/null
+++ b/recipes-devtools/python/python3-mldtypes_0.2.0.bb
@@ -0,0 +1,28 @@
+SUMMARY = "The ml_dtypes is a stand-alone implementation of several NumPy dtype extensions used in machine learning libraries"
+HOMEPAGE = "https://github.com/jax-ml/ml_dtypes"
+SECTION = "devel/python"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57"
+
+SRC_URI[md5sum] = "ed4f6491b168ff2050c4ad373e9d76df"
+SRC_URI[sha256sum] = "6488eb642acaaf08d8020f6de0a38acee7ac324c1e6e92ee0c0fea42422cb797"
+
+inherit pypi setuptools3
+
+SRCNAME ?= "ml_dtypes"
+PYPI_SRC_URI = "https://files.pythonhosted.org/packages/fa/47/09ca9556bf99cfe7ddf129a3423642bd482a27a717bf115090493fa42429/${SRCNAME}-${PV}.tar.gz"
+
+S = "${WORKDIR}/${SRCNAME}-${PV}"
+
+DEPENDS = " \
+ python3-pybind11-native \
+ python3-numpy-native \
+"
+
+RDEPENDS:${PN} = " \
+ python3-pybind11 \
+ python3-numpy \
+"
+
+BBCLASSEXTEND = "native"
+
diff --git a/recipes-devtools/python/python3-opt-einsum/0001-Use-ConfigParser-instead-of-SafeConfigParser.patch b/recipes-devtools/python/python3-opt-einsum/0001-Use-ConfigParser-instead-of-SafeConfigParser.patch
new file mode 100644
index 0000000..93e3bd8
--- /dev/null
+++ b/recipes-devtools/python/python3-opt-einsum/0001-Use-ConfigParser-instead-of-SafeConfigParser.patch
@@ -0,0 +1,36 @@
+From 0beacf96923bbb2dd1939a9c59398a38ce7a11b1 Mon Sep 17 00:00:00 2001
+From: Hongxu Jia <hongxu.jia@windriver.com>
+Date: Thu, 17 Nov 2022 17:04:54 -0800
+Subject: [PATCH] Use ConfigParser instead of SafeConfigParser
+
+The SafeConfigParser class will be renamed to ConfigParser in Python
+3.12 [1]. This alias will be removed in future versions.So we can use
+ConfigParser directly instead.
+
+[1] https://github.com/python/cpython/issues/89336
+
+Upstream-Status: Submitted [https://github.com/dgasmith/opt_einsum/pull/208]
+Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com>
+---
+ versioneer.py | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/versioneer.py b/versioneer.py
+index d3db643..6d732af 100644
+--- a/versioneer.py
++++ b/versioneer.py
+@@ -339,9 +339,9 @@ def get_config_from_root(root):
+ # configparser.NoOptionError (if it lacks "VCS="). See the docstring at
+ # the top of versioneer.py for instructions on writing your setup.cfg .
+ setup_cfg = os.path.join(root, "setup.cfg")
+- parser = configparser.SafeConfigParser()
++ parser = configparser.ConfigParser()
+ with open(setup_cfg, "r") as f:
+- parser.readfp(f)
++ parser.read_file(f)
+ VCS = parser.get("versioneer", "VCS") # mandatory
+
+ def get(parser, name):
+--
+2.37.1
+
diff --git a/recipes-devtools/python/python3-opt-einsum_3.3.0.bb b/recipes-devtools/python/python3-opt-einsum_3.3.0.bb
new file mode 100644
index 0000000..ce9d220
--- /dev/null
+++ b/recipes-devtools/python/python3-opt-einsum_3.3.0.bb
@@ -0,0 +1,19 @@
+SUMMARY = "A tensor contraction order optimizer"
+HOMEPAGE = "https://github.com/dgasmith/opt_einsum"
+SECTION = "devel/python"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=5ab423c88cf3e69553decf93419f53ac"
+
+SRC_URI[md5sum] = "acf0a3997aab84b4e9a854296cc34971"
+SRC_URI[sha256sum] = "59f6475f77bbc37dcf7cd748519c0ec60722e91e63ca114e68821c0c54a46549"
+
+inherit pypi setuptools3
+
+SRCNAME = "opt_einsum"
+PYPI_SRC_URI = "https://files.pythonhosted.org/packages/source/o/${PYPI_PACKAGE}/${SRCNAME}-${PV}.tar.gz"
+SRC_URI += " \
+ file://0001-Use-ConfigParser-instead-of-SafeConfigParser.patch \
+"
+S = "${WORKDIR}/${SRCNAME}-${PV}"
+
+BBCLASSEXTEND = "native"