aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-devtools/python/python3-google-auth-oauthlib_0.4.5.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-devtools/python/python3-google-auth-oauthlib_0.4.5.bb')
-rw-r--r--recipes-devtools/python/python3-google-auth-oauthlib_0.4.5.bb20
1 files changed, 20 insertions, 0 deletions
diff --git a/recipes-devtools/python/python3-google-auth-oauthlib_0.4.5.bb b/recipes-devtools/python/python3-google-auth-oauthlib_0.4.5.bb
new file mode 100644
index 0000000..ecc2867
--- /dev/null
+++ b/recipes-devtools/python/python3-google-auth-oauthlib_0.4.5.bb
@@ -0,0 +1,20 @@
+SUMMARY = "The oauthlib integration for Google Auth"
+HOMEPAGE = "https://github.com/googleapis/google-auth-library-python-oauthlib"
+DESCRIPTION = "This library provides oauthlib integration with google-auth."
+SECTION = "devel/python"
+
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57"
+
+inherit pypi
+
+SRC_URI[md5sum] = "0ef7695adb47224714926a7e8331e61d"
+SRC_URI[sha256sum] = "4ab58e6c3dc6ccf112f921fcced40e5426fba266768986ea502228488276eaba"
+
+BBCLASSEXTEND = "native"
+
+RDEPENDS:${PN} += " \
+ python3-requests-oauthlib \
+ python3-oauthlib \
+"
+inherit setuptools3