aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-connectivity/connman
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-connectivity/connman')
-rw-r--r--recipes-connectivity/connman/connman-gnome_0.5.bb33
-rw-r--r--recipes-connectivity/connman/connman/add_xuser_dbus_permission.patch23
-rw-r--r--recipes-connectivity/connman/connman/connman62
-rw-r--r--recipes-connectivity/connman/connman/ethernet_default.patch22
-rw-r--r--recipes-connectivity/connman/connman_0.78.bb12
5 files changed, 152 insertions, 0 deletions
diff --git a/recipes-connectivity/connman/connman-gnome_0.5.bb b/recipes-connectivity/connman/connman-gnome_0.5.bb
new file mode 100644
index 0000000..026ca45
--- /dev/null
+++ b/recipes-connectivity/connman/connman-gnome_0.5.bb
@@ -0,0 +1,33 @@
+DESCRIPTION = "gtk frontend for connman"
+HOMEPAGE = "http://connman.net/"
+SECTION = "libs/network"
+LICENSE = "GPLv2 & LGPLv2.1"
+LIC_FILES_CHKSUM = "file://COPYING;md5=eb723b61539feef013de476e68b5c50a \
+ file://properties/main.c;beginline=1;endline=20;md5=50c77c81871308b033ab7a1504626afb \
+ file://common/connman-dbus.c;beginline=1;endline=20;md5=de6b485c0e717a0236402d220187717a"
+
+DEPENDS = "gtk+ dbus"
+
+PR = "r8"
+
+SRCREV = "78d3c39db6f3f7977b466305110faa8ca5f74ec8"
+SRC_URI = "git://github.com/connectivity/connman-gnome.git;protocol=git \
+ file://3g.patch \
+ file://security-type.patch"
+
+S = "${WORKDIR}/git"
+
+inherit autotools gtk-icon-cache
+
+RRECOMMENDS_${PN} = "python \
+ python-dbus \
+ connman \
+ connman-plugin-ethernet \
+ connman-plugin-loopback \
+ connman-plugin-udhcp \
+ connman-plugin-wifi \
+ connman-plugin-fake \
+ connman-plugin-bluetooth \
+ connman-plugin-dnsproxy \
+ connman-plugin-ofono \
+ "
diff --git a/recipes-connectivity/connman/connman/add_xuser_dbus_permission.patch b/recipes-connectivity/connman/connman/add_xuser_dbus_permission.patch
new file mode 100644
index 0000000..36e7456
--- /dev/null
+++ b/recipes-connectivity/connman/connman/add_xuser_dbus_permission.patch
@@ -0,0 +1,23 @@
+Some platform (like atom-pc) enables rootless X,
+thus we need to add the xuser in the list.
+
+Upstream-Status: Inappropriate [configuration]
+
+Signed-off-by: Dongxiao Xu <dongxiao.xu@intel.com>
+
+diff -ruN connman-0.65-orig/src/connman-dbus.conf connman-0.65/src/connman-dbus.conf
+--- connman-0.65-orig/src/connman-dbus.conf 2011-03-04 09:34:49.000000000 +0800
++++ connman-0.65/src/connman-dbus.conf 2011-03-04 09:35:21.000000000 +0800
+@@ -7,6 +7,12 @@
+ <allow send_interface="net.connman.Agent"/>
+ <allow send_interface="net.connman.Counter"/>
+ </policy>
++ <policy user="xuser">
++ <allow own="net.connman"/>
++ <allow send_destination="net.connman"/>
++ <allow send_interface="net.connman.Agent"/>
++ <allow send_interface="net.connman.Counter"/>
++ </policy>
+ <policy at_console="true">
+ <allow send_destination="net.connman"/>
+ </policy>
diff --git a/recipes-connectivity/connman/connman/connman b/recipes-connectivity/connman/connman/connman
new file mode 100644
index 0000000..b8cf2c9
--- /dev/null
+++ b/recipes-connectivity/connman/connman/connman
@@ -0,0 +1,62 @@
+#!/bin/sh
+
+DAEMON=/usr/sbin/connmand
+PIDFILE=/var/run/connmand.pid
+DESC="Connection Manager"
+
+if [ -f /etc/default/connman ] ; then
+ . /etc/default/connman
+fi
+
+set -e
+
+nfsroot=0
+
+exec 9<&0 < /proc/mounts
+while read dev mtpt fstype rest; do
+ if test $mtpt = "/" ; then
+ case $fstype in
+ nfs | nfs4)
+ nfsroot=1
+ break
+ ;;
+ *)
+ ;;
+ esac
+ fi
+done
+
+do_start() {
+ EXTRA_PARAM=""
+ if test $nfsroot -eq 1 ; then
+ EXTRA_PARAM="-P ethernet"
+ fi
+ $DAEMON $EXTRA_PARAM
+}
+
+do_stop() {
+ start-stop-daemon --stop --name connmand --quiet
+}
+
+case "$1" in
+ start)
+ echo "Starting $DESC"
+ do_start
+ ;;
+ stop)
+ echo "Stopping $DESC"
+ do_stop
+ ;;
+ restart|force-reload)
+ echo "Restarting $DESC"
+ do_stop
+ sleep 1
+ do_start
+ ;;
+ *)
+ echo "Usage: $0 {start|stop|restart|force-reload}" >&2
+ exit 1
+ ;;
+esac
+
+exit 0
diff --git a/recipes-connectivity/connman/connman/ethernet_default.patch b/recipes-connectivity/connman/connman/ethernet_default.patch
new file mode 100644
index 0000000..e948e56
--- /dev/null
+++ b/recipes-connectivity/connman/connman/ethernet_default.patch
@@ -0,0 +1,22 @@
+Default to enabling the ethernet interface. If we don't do this, connman
+will shut down all the networking when it starts without any configuration
+which is usualy not what the users expects. This is particularly
+problematic with our qemu images and runtime testing using qemu.
+
+Upstream-Status: Inappropriate [Configuration]
+
+RP 2011/12/12
+
+Index: git/src/storage.c
+===================================================================
+--- git.orig/src/storage.c 2011-12-12 16:14:10.892316565 +0000
++++ git/src/storage.c 2011-12-12 16:14:13.788316431 +0000
+@@ -367,7 +367,7 @@
+ "Enable", FALSE);
+
+ g_key_file_set_boolean(keyfile, "Wired",
+- "Enable", FALSE);
++ "Enable", TRUE);
+
+ g_key_file_set_boolean(keyfile, "3G",
+ "Enable", FALSE);
diff --git a/recipes-connectivity/connman/connman_0.78.bb b/recipes-connectivity/connman/connman_0.78.bb
new file mode 100644
index 0000000..963232e
--- /dev/null
+++ b/recipes-connectivity/connman/connman_0.78.bb
@@ -0,0 +1,12 @@
+require connman.inc
+
+PR = "r6"
+
+# 0.78 tag
+SRCREV = "02f5d5fe2d7c71514a6387ba2b772b42d8e8d297"
+SRC_URI = "git://git.kernel.org/pub/scm/network/connman/connman.git \
+ file://add_xuser_dbus_permission.patch \
+ file://ethernet_default.patch \
+ file://disable_alg-test.patch \
+ file://connman"
+S = "${WORKDIR}/git"