aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-connectivity
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-connectivity')
-rw-r--r--recipes-connectivity/connman/connman-gnome_0.5.bb33
-rw-r--r--recipes-connectivity/connman/connman/add_xuser_dbus_permission.patch23
-rw-r--r--recipes-connectivity/connman/connman/connman62
-rw-r--r--recipes-connectivity/connman/connman/ethernet_default.patch22
-rw-r--r--recipes-connectivity/connman/connman_0.78.bb12
-rw-r--r--recipes-connectivity/nfs-utils/files/fix-ac-prereq.patch15
-rw-r--r--recipes-connectivity/nfs-utils/libnfsidmap_0.24.bb19
-rw-r--r--recipes-connectivity/nfs-utils/nfs-utils/nfs-utils-1.0.6-uclibc.patch22
-rw-r--r--recipes-connectivity/nfs-utils/nfs-utils/nfs-utils-1.2.3-uclibc-libio.h.patch26
-rw-r--r--recipes-connectivity/openssh/openssh-5.9p1/nostrip.patch20
-rw-r--r--recipes-connectivity/openssh/openssh-5.9p1/sshd10
-rw-r--r--recipes-connectivity/openssh/openssh-5.9p1/sshd.service16
-rw-r--r--recipes-connectivity/openssh/openssh-5.9p1/sshdgenkeys26
-rw-r--r--recipes-connectivity/portmap/portmap-6.0/tcpd-config.patch30
-rw-r--r--recipes-connectivity/portmap/portmap.inc31
-rw-r--r--recipes-connectivity/portmap/portmap_6.0.bb24
16 files changed, 391 insertions, 0 deletions
diff --git a/recipes-connectivity/connman/connman-gnome_0.5.bb b/recipes-connectivity/connman/connman-gnome_0.5.bb
new file mode 100644
index 0000000..026ca45
--- /dev/null
+++ b/recipes-connectivity/connman/connman-gnome_0.5.bb
@@ -0,0 +1,33 @@
+DESCRIPTION = "gtk frontend for connman"
+HOMEPAGE = "http://connman.net/"
+SECTION = "libs/network"
+LICENSE = "GPLv2 & LGPLv2.1"
+LIC_FILES_CHKSUM = "file://COPYING;md5=eb723b61539feef013de476e68b5c50a \
+ file://properties/main.c;beginline=1;endline=20;md5=50c77c81871308b033ab7a1504626afb \
+ file://common/connman-dbus.c;beginline=1;endline=20;md5=de6b485c0e717a0236402d220187717a"
+
+DEPENDS = "gtk+ dbus"
+
+PR = "r8"
+
+SRCREV = "78d3c39db6f3f7977b466305110faa8ca5f74ec8"
+SRC_URI = "git://github.com/connectivity/connman-gnome.git;protocol=git \
+ file://3g.patch \
+ file://security-type.patch"
+
+S = "${WORKDIR}/git"
+
+inherit autotools gtk-icon-cache
+
+RRECOMMENDS_${PN} = "python \
+ python-dbus \
+ connman \
+ connman-plugin-ethernet \
+ connman-plugin-loopback \
+ connman-plugin-udhcp \
+ connman-plugin-wifi \
+ connman-plugin-fake \
+ connman-plugin-bluetooth \
+ connman-plugin-dnsproxy \
+ connman-plugin-ofono \
+ "
diff --git a/recipes-connectivity/connman/connman/add_xuser_dbus_permission.patch b/recipes-connectivity/connman/connman/add_xuser_dbus_permission.patch
new file mode 100644
index 0000000..36e7456
--- /dev/null
+++ b/recipes-connectivity/connman/connman/add_xuser_dbus_permission.patch
@@ -0,0 +1,23 @@
+Some platform (like atom-pc) enables rootless X,
+thus we need to add the xuser in the list.
+
+Upstream-Status: Inappropriate [configuration]
+
+Signed-off-by: Dongxiao Xu <dongxiao.xu@intel.com>
+
+diff -ruN connman-0.65-orig/src/connman-dbus.conf connman-0.65/src/connman-dbus.conf
+--- connman-0.65-orig/src/connman-dbus.conf 2011-03-04 09:34:49.000000000 +0800
++++ connman-0.65/src/connman-dbus.conf 2011-03-04 09:35:21.000000000 +0800
+@@ -7,6 +7,12 @@
+ <allow send_interface="net.connman.Agent"/>
+ <allow send_interface="net.connman.Counter"/>
+ </policy>
++ <policy user="xuser">
++ <allow own="net.connman"/>
++ <allow send_destination="net.connman"/>
++ <allow send_interface="net.connman.Agent"/>
++ <allow send_interface="net.connman.Counter"/>
++ </policy>
+ <policy at_console="true">
+ <allow send_destination="net.connman"/>
+ </policy>
diff --git a/recipes-connectivity/connman/connman/connman b/recipes-connectivity/connman/connman/connman
new file mode 100644
index 0000000..b8cf2c9
--- /dev/null
+++ b/recipes-connectivity/connman/connman/connman
@@ -0,0 +1,62 @@
+#!/bin/sh
+
+DAEMON=/usr/sbin/connmand
+PIDFILE=/var/run/connmand.pid
+DESC="Connection Manager"
+
+if [ -f /etc/default/connman ] ; then
+ . /etc/default/connman
+fi
+
+set -e
+
+nfsroot=0
+
+exec 9<&0 < /proc/mounts
+while read dev mtpt fstype rest; do
+ if test $mtpt = "/" ; then
+ case $fstype in
+ nfs | nfs4)
+ nfsroot=1
+ break
+ ;;
+ *)
+ ;;
+ esac
+ fi
+done
+
+do_start() {
+ EXTRA_PARAM=""
+ if test $nfsroot -eq 1 ; then
+ EXTRA_PARAM="-P ethernet"
+ fi
+ $DAEMON $EXTRA_PARAM
+}
+
+do_stop() {
+ start-stop-daemon --stop --name connmand --quiet
+}
+
+case "$1" in
+ start)
+ echo "Starting $DESC"
+ do_start
+ ;;
+ stop)
+ echo "Stopping $DESC"
+ do_stop
+ ;;
+ restart|force-reload)
+ echo "Restarting $DESC"
+ do_stop
+ sleep 1
+ do_start
+ ;;
+ *)
+ echo "Usage: $0 {start|stop|restart|force-reload}" >&2
+ exit 1
+ ;;
+esac
+
+exit 0
diff --git a/recipes-connectivity/connman/connman/ethernet_default.patch b/recipes-connectivity/connman/connman/ethernet_default.patch
new file mode 100644
index 0000000..e948e56
--- /dev/null
+++ b/recipes-connectivity/connman/connman/ethernet_default.patch
@@ -0,0 +1,22 @@
+Default to enabling the ethernet interface. If we don't do this, connman
+will shut down all the networking when it starts without any configuration
+which is usualy not what the users expects. This is particularly
+problematic with our qemu images and runtime testing using qemu.
+
+Upstream-Status: Inappropriate [Configuration]
+
+RP 2011/12/12
+
+Index: git/src/storage.c
+===================================================================
+--- git.orig/src/storage.c 2011-12-12 16:14:10.892316565 +0000
++++ git/src/storage.c 2011-12-12 16:14:13.788316431 +0000
+@@ -367,7 +367,7 @@
+ "Enable", FALSE);
+
+ g_key_file_set_boolean(keyfile, "Wired",
+- "Enable", FALSE);
++ "Enable", TRUE);
+
+ g_key_file_set_boolean(keyfile, "3G",
+ "Enable", FALSE);
diff --git a/recipes-connectivity/connman/connman_0.78.bb b/recipes-connectivity/connman/connman_0.78.bb
new file mode 100644
index 0000000..963232e
--- /dev/null
+++ b/recipes-connectivity/connman/connman_0.78.bb
@@ -0,0 +1,12 @@
+require connman.inc
+
+PR = "r6"
+
+# 0.78 tag
+SRCREV = "02f5d5fe2d7c71514a6387ba2b772b42d8e8d297"
+SRC_URI = "git://git.kernel.org/pub/scm/network/connman/connman.git \
+ file://add_xuser_dbus_permission.patch \
+ file://ethernet_default.patch \
+ file://disable_alg-test.patch \
+ file://connman"
+S = "${WORKDIR}/git"
diff --git a/recipes-connectivity/nfs-utils/files/fix-ac-prereq.patch b/recipes-connectivity/nfs-utils/files/fix-ac-prereq.patch
new file mode 100644
index 0000000..7446006
--- /dev/null
+++ b/recipes-connectivity/nfs-utils/files/fix-ac-prereq.patch
@@ -0,0 +1,15 @@
+Upstream-Status: Inappropriate [configuration]
+
+diff --git a/configure.in b/configure.in
+index f5d54fb..c105988 100644
+--- a/configure.in
++++ b/configure.in
+@@ -1,7 +1,7 @@
+ # -*- Autoconf -*-
+ # Process this file with autoconf to produce a configure script.
+
+-AC_PREREQ([2.66])
++AC_PREREQ([2.65])
+ AC_INIT([libnfsidmap],[0.24],[linux-nfs@vger.kernel.org])
+ AC_CONFIG_SRCDIR([nfsidmap.h])
+ AC_CONFIG_MACRO_DIR([m4])
diff --git a/recipes-connectivity/nfs-utils/libnfsidmap_0.24.bb b/recipes-connectivity/nfs-utils/libnfsidmap_0.24.bb
new file mode 100644
index 0000000..967977e
--- /dev/null
+++ b/recipes-connectivity/nfs-utils/libnfsidmap_0.24.bb
@@ -0,0 +1,19 @@
+SUMMARY = "NFS id mapping library"
+DESCRIPTION = "NFS id mapping library"
+HOMEPAGE = "http://www.citi.umich.edu/projects/nfsv4/linux/"
+SECTION = "libs"
+
+LICENSE = "BSD"
+LIC_FILES_CHKSUM = "file://COPYING;md5=d9c6a2a0ca6017fda7cd905ed2739b37"
+PR = "r0"
+
+SRC_URI = "http://www.citi.umich.edu/projects/nfsv4/linux/libnfsidmap/${BPN}-${PV}.tar.gz \
+ file://fix-ac-prereq.patch \
+ "
+
+SRC_URI[md5sum] = "d71a1ee9881d5b5814ff3ec41256937d"
+SRC_URI[sha256sum] = "59501432e683336d7a290da13767e92afb5b86f42ea4254041225fe218e8dd47"
+
+inherit autotools
+
+EXTRA_OECONF = "--disable-ldap"
diff --git a/recipes-connectivity/nfs-utils/nfs-utils/nfs-utils-1.0.6-uclibc.patch b/recipes-connectivity/nfs-utils/nfs-utils/nfs-utils-1.0.6-uclibc.patch
new file mode 100644
index 0000000..3c8f9fb
--- /dev/null
+++ b/recipes-connectivity/nfs-utils/nfs-utils/nfs-utils-1.0.6-uclibc.patch
@@ -0,0 +1,22 @@
+Upstream-Status: Inappropriate [embedded specific]
+
+Index: nfs-utils-1.2.3/support/nfs/svc_socket.c
+===================================================================
+--- nfs-utils-1.2.3.orig/support/nfs/svc_socket.c
++++ nfs-utils-1.2.3/support/nfs/svc_socket.c
+@@ -67,6 +67,7 @@ svc_socket (u_long number, int type, int
+ memset (&addr, 0, sizeof (addr));
+ addr.sin_family = AF_INET;
+
++#ifndef __UCLIBC__ /* neither getrpcbynumber() nor getrpcbynumber_r() is SuSv3 */
+ ret = getrpcbynumber_r (number, &rpcbuf, rpcdata, sizeof rpcdata,
+ &rpcp);
+ if (ret == 0 && rpcp != NULL)
+@@ -100,6 +101,7 @@ svc_socket (u_long number, int type, int
+ }
+ }
+ else
++#endif
+ {
+ addr.sin_port = 0;
+ if (bind (sock, (struct sockaddr *) &addr, len) < 0)
diff --git a/recipes-connectivity/nfs-utils/nfs-utils/nfs-utils-1.2.3-uclibc-libio.h.patch b/recipes-connectivity/nfs-utils/nfs-utils/nfs-utils-1.2.3-uclibc-libio.h.patch
new file mode 100644
index 0000000..b42111e
--- /dev/null
+++ b/recipes-connectivity/nfs-utils/nfs-utils/nfs-utils-1.2.3-uclibc-libio.h.patch
@@ -0,0 +1,26 @@
+[PATCH] fix build with uClibc
+
+uClibc doesn't have/need libio.h, so don't include it from sockaddr.h
+
+Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
+---
+ support/include/sockaddr.h | 5 ++++-
+ 1 file changed, 4 insertions(+), 1 deletion(-)
+
+Upstream-Status: Pending
+
+Index: nfs-utils-1.2.3/support/include/sockaddr.h
+===================================================================
+--- nfs-utils-1.2.3.orig/support/include/sockaddr.h
++++ nfs-utils-1.2.3/support/include/sockaddr.h
+@@ -20,7 +20,10 @@
+ #ifndef NFS_UTILS_SOCKADDR_H
+ #define NFS_UTILS_SOCKADDR_H
+
++/* uClibc doesn't have/need libio.h */
++#ifndef __UCLIBC__
+ #include <libio.h>
++#endif
+ #include <stdbool.h>
+ #include <sys/socket.h>
+ #include <netinet/in.h>
diff --git a/recipes-connectivity/openssh/openssh-5.9p1/nostrip.patch b/recipes-connectivity/openssh/openssh-5.9p1/nostrip.patch
new file mode 100644
index 0000000..663df5c
--- /dev/null
+++ b/recipes-connectivity/openssh/openssh-5.9p1/nostrip.patch
@@ -0,0 +1,20 @@
+Disable stripping binaries during make install.
+
+Upstream-Status: Inappropriate [configuration]
+
+Build system specific.
+
+Signed-off-by: Scott Garman <scott.a.garman@intel.com>
+
+diff -ur openssh-5.6p1.orig/Makefile.in openssh-5.6p1/Makefile.in
+--- openssh-5.6p1.orig/Makefile.in 2010-05-11 23:51:39.000000000 -0700
++++ openssh-5.6p1/Makefile.in 2010-08-30 16:49:54.000000000 -0700
+@@ -29,7 +29,7 @@
+ RAND_HELPER=$(libexecdir)/ssh-rand-helper
+ PRIVSEP_PATH=@PRIVSEP_PATH@
+ SSH_PRIVSEP_USER=@SSH_PRIVSEP_USER@
+-STRIP_OPT=@STRIP_OPT@
++STRIP_OPT=
+
+ PATHS= -DSSHDIR=\"$(sysconfdir)\" \
+ -D_PATH_SSH_PROGRAM=\"$(SSH_PROGRAM)\" \
diff --git a/recipes-connectivity/openssh/openssh-5.9p1/sshd b/recipes-connectivity/openssh/openssh-5.9p1/sshd
new file mode 100644
index 0000000..b843e37
--- /dev/null
+++ b/recipes-connectivity/openssh/openssh-5.9p1/sshd
@@ -0,0 +1,10 @@
+#%PAM-1.0
+
+auth include common-auth
+account required pam_nologin.so
+account include common-account
+password include common-password
+session optional pam_keyinit.so force revoke
+session include common-session
+session required pam_loginuid.so
+
diff --git a/recipes-connectivity/openssh/openssh-5.9p1/sshd.service b/recipes-connectivity/openssh/openssh-5.9p1/sshd.service
new file mode 100644
index 0000000..1f1ca08
--- /dev/null
+++ b/recipes-connectivity/openssh/openssh-5.9p1/sshd.service
@@ -0,0 +1,16 @@
+[Unit]
+Description=SSH Secure Shell Service
+After=connman.service
+Requires=connman.service
+
+[Service]
+ExecStartPre=/lib/systemd/scripts/sshdgenkeys
+ExecStart=/usr/sbin/sshd -D
+
+[Install]
+WantedBy=multi-user.target
+
+# Note that this is the service file for running a single SSH server for all
+# incoming connections, suitable only for systems with a large amount of SSH
+# traffic. In almost all other cases it is a better idea to use sshd.socket +
+# sshd@.service.
diff --git a/recipes-connectivity/openssh/openssh-5.9p1/sshdgenkeys b/recipes-connectivity/openssh/openssh-5.9p1/sshdgenkeys
new file mode 100644
index 0000000..61709b1
--- /dev/null
+++ b/recipes-connectivity/openssh/openssh-5.9p1/sshdgenkeys
@@ -0,0 +1,26 @@
+#!/bin/sh
+
+# This script
+# generates host keys
+# check /var/run/sshd nad creates it if not already created
+
+
+if ! [ -f /etc/ssh/ssh_host_ecdsa_key ]; then
+ /usr/bin/ssh-keygen -q -t ecdsa -N "" -f /etc/ssh/ssh_host_ecdsa_key || exit 1
+fi
+
+if ! [ -f /etc/ssh/ssh_host_rsa_key ]; then
+ /usr/bin/ssh-keygen -q -t rsa -N "" -f /etc/ssh/ssh_host_rsa_key || exit 1
+fi
+
+if ! [ -f /etc/ssh/ssh_host_dsa_key ]; then
+ /usr/bin/ssh-keygen -q -t dsa -N "" -f /etc/ssh/ssh_host_dsa_key || exit 1
+fi
+
+if [ ! -d /var/run/sshd ]; then
+ mkdir /var/run/sshd || exit 1
+ chmod 0755 /var/run/sshd || exit 1
+fi
+
+# `test' returns non-zero when it fails. Don't let this hold up ExecStart.
+exit 0 \ No newline at end of file
diff --git a/recipes-connectivity/portmap/portmap-6.0/tcpd-config.patch b/recipes-connectivity/portmap/portmap-6.0/tcpd-config.patch
new file mode 100644
index 0000000..f07ba0a
--- /dev/null
+++ b/recipes-connectivity/portmap/portmap-6.0/tcpd-config.patch
@@ -0,0 +1,30 @@
+Upstream-Status: Backport
+
+From: Mike Frysinger <vapier@gentoo.org>
+Date: Sun, 13 May 2007 21:17:32 +0000 (-0400)
+Subject: fix building with tcpd support disabled
+X-Git-Url: http://neil.brown.name/git?p=portmap;a=commitdiff_plain;h=7847207aed1b44faf077eed14a9ac9c68244eba5
+
+fix building with tcpd support disabled
+
+Make sure pmap_check.c only includes tcpd.h when HOSTS_ACCESS is defined.
+
+Signed-off-by: Timothy Redaelli <drizzt@gentoo.org>
+Signed-off-by: Mike Frysinger <vapier@gentoo.org>
+Signed-off-by: Neil Brown <neilb@suse.de>
+---
+
+diff --git a/pmap_check.c b/pmap_check.c
+index 84f2c12..443a822 100644
+--- a/pmap_check.c
++++ b/pmap_check.c
+@@ -44,7 +44,9 @@
+ #include <netinet/in.h>
+ #include <rpc/rpcent.h>
+ #endif
++#ifdef HOSTS_ACCESS
+ #include <tcpd.h>
++#endif
+ #include <arpa/inet.h>
+ #include <grp.h>
+
diff --git a/recipes-connectivity/portmap/portmap.inc b/recipes-connectivity/portmap/portmap.inc
new file mode 100644
index 0000000..7271fb2
--- /dev/null
+++ b/recipes-connectivity/portmap/portmap.inc
@@ -0,0 +1,31 @@
+DESCRIPTION = "RPC program number mapper."
+HOMEPAGE = "http://neil.brown.name/portmap/"
+SECTION = "console/network"
+LICENSE = "BSD"
+LIC_FILES_CHKSUM = "file://portmap.c;beginline=2;endline=31;md5=51ff67e66ec84b2009b017b1f94afbf4 \
+ file://from_local.c;beginline=9;endline=35;md5=1bec938a2268b8b423c58801ace3adc1"
+DEPENDS = "virtual/fakeroot-native"
+
+SRC_URI = "${DEBIAN_MIRROR}/main/p/portmap/portmap_5.orig.tar.gz \
+ ${DEBIAN_MIRROR}/main/p/portmap/portmap_${PV}.diff.gz \
+ file://portmap.init \
+ file://make.patch;apply=yes"
+S = "${WORKDIR}/portmap_5beta"
+
+INITSCRIPT_NAME = "portmap"
+INITSCRIPT_PARAMS = "start 43 S . start 32 0 6 . stop 81 1 ."
+
+#inherit update-rc.d
+
+sbindir = "/sbin"
+
+fakeroot do_install() {
+# install -d ${D}${sysconfdir}/init.d
+ install -d ${D}${base_sbindir}
+# install -m 0755 ${WORKDIR}/portmap.init ${D}${sysconfdir}/init.d/portmap
+ oe_runmake 'docdir=${docdir}/portmap' 'DESTDIR=${D}' install
+}
+
+PACKAGES =+ "portmap-utils"
+FILES_portmap-utils = "/sbin/pmap_set /sbin/pmap_dump"
+FILES_${PN}-doc += "${docdir}"
diff --git a/recipes-connectivity/portmap/portmap_6.0.bb b/recipes-connectivity/portmap/portmap_6.0.bb
new file mode 100644
index 0000000..ebebd85
--- /dev/null
+++ b/recipes-connectivity/portmap/portmap_6.0.bb
@@ -0,0 +1,24 @@
+require portmap.inc
+
+DEPENDS += "tcp-wrappers"
+PR = "r7"
+
+SRC_URI = "http://www.sourcefiles.org/Networking/Tools/Miscellanenous/portmap-6.0.tgz \
+ file://destdir-no-strip.patch \
+ file://tcpd-config.patch \
+ file://portmap.init"
+
+SRC_URI[md5sum] = "ac108ab68bf0f34477f8317791aaf1ff"
+SRC_URI[sha256sum] = "02c820d39f3e6e729d1bea3287a2d8a6c684f1006fb9612f97dcad4a281d41de"
+
+S = "${WORKDIR}/${BPN}_${PV}/"
+
+CPPFLAGS += "-DFACILITY=LOG_DAEMON -DENABLE_DNS -DHOSTS_ACCESS"
+CFLAGS += "-Wall -Wstrict-prototypes -fPIC"
+
+fakeroot do_install() {
+ #install -d ${D}${mandir}/man8/ ${D}${base_sbindir} ${D}${sysconfdir}/init.d
+ install -d ${D}${mandir}/man8/ ${D}${base_sbindir}
+ #install -m 0755 ${WORKDIR}/portmap.init ${D}${sysconfdir}/init.d/portmap
+ oe_runmake install DESTDIR=${D}
+}