aboutsummaryrefslogtreecommitdiffstats
path: root/meta-v1000/recipes-devtools/glslang
diff options
context:
space:
mode:
Diffstat (limited to 'meta-v1000/recipes-devtools/glslang')
-rw-r--r--meta-v1000/recipes-devtools/glslang/glslang/0002-spirv-do-not-install-conflicting-headers.patch30
-rw-r--r--meta-v1000/recipes-devtools/glslang/glslang_git.bb23
2 files changed, 53 insertions, 0 deletions
diff --git a/meta-v1000/recipes-devtools/glslang/glslang/0002-spirv-do-not-install-conflicting-headers.patch b/meta-v1000/recipes-devtools/glslang/glslang/0002-spirv-do-not-install-conflicting-headers.patch
new file mode 100644
index 00000000..69e64060
--- /dev/null
+++ b/meta-v1000/recipes-devtools/glslang/glslang/0002-spirv-do-not-install-conflicting-headers.patch
@@ -0,0 +1,30 @@
+From 1823de236f38fc7eb7caedec666c9dde956832cd Mon Sep 17 00:00:00 2001
+From: Awais Belal <awais_belal@mentor.com>
+Date: Wed, 31 May 2017 13:04:42 +0500
+Subject: [PATCH] spirv: do not install conflicting headers
+
+These headers are already provided by the
+spirv-tools package so there's no need of
+installing them here again.
+
+Signed-off-by: Awais Belal <awais_belal@mentor.com>
+---
+ SPIRV/CMakeLists.txt | 2 --
+ 1 file changed, 2 deletions(-)
+
+diff --git a/SPIRV/CMakeLists.txt b/SPIRV/CMakeLists.txt
+index aaf11780..d5c43723 100755
+--- a/SPIRV/CMakeLists.txt
++++ b/SPIRV/CMakeLists.txt
+@@ -12,8 +12,6 @@ set(SPVREMAP_SOURCES
+
+ set(HEADERS
+ bitutils.h
+- spirv.hpp
+- GLSL.std.450.h
+ GLSL.ext.KHR.h
+ GlslangToSpv.h
+ hex_float.h
+--
+2.11.1
+
diff --git a/meta-v1000/recipes-devtools/glslang/glslang_git.bb b/meta-v1000/recipes-devtools/glslang/glslang_git.bb
new file mode 100644
index 00000000..bc749b40
--- /dev/null
+++ b/meta-v1000/recipes-devtools/glslang/glslang_git.bb
@@ -0,0 +1,23 @@
+SUMMARY = "An OpenGL and OpenGL ES shader front end and validator."
+DESCRIPTION = "Glslang is the official reference compiler front end \
+ for the OpenGL ES and OpenGL shading languages. It \
+ implements a strict interpretation of the specifications \
+ for these languages. It is open and free for anyone to use, \
+ either from a command line or programmatically."
+SECTION = "graphics"
+HOMEPAGE = "https://www.khronos.org/opengles/sdk/tools/Reference-Compiler"
+
+inherit cmake
+
+LICENSE = "BSD"
+LIC_FILES_CHKSUM = "file://glslang/Include/Types.h;beginline=1;endline=36;md5=9dbd36d87d27a0c98a6f4d72afaa9cf8"
+
+S = "${WORKDIR}/git"
+
+SRCREV = "2651ccaec8170b3257642b3c438f50dc4f181fdd"
+SRC_URI = "git://github.com/KhronosGroup/glslang \
+ file://0002-spirv-do-not-install-conflicting-headers.patch"
+
+FILES_${PN} += "${libdir}/*"
+
+BBCLASSEXTEND = "native nativesdk"