aboutsummaryrefslogtreecommitdiffstats
path: root/meta-v1000/recipes-devtools
diff options
context:
space:
mode:
Diffstat (limited to 'meta-v1000/recipes-devtools')
-rw-r--r--meta-v1000/recipes-devtools/glslang/glslang/0002-spirv-do-not-install-conflicting-headers.patch30
-rw-r--r--meta-v1000/recipes-devtools/glslang/glslang_git.bb23
-rw-r--r--meta-v1000/recipes-devtools/spirv/spirv-tools/0002-spirv-lesspipe.sh-allow-using-generic-shells.patch27
-rw-r--r--meta-v1000/recipes-devtools/spirv/spirv-tools_git.bb28
4 files changed, 108 insertions, 0 deletions
diff --git a/meta-v1000/recipes-devtools/glslang/glslang/0002-spirv-do-not-install-conflicting-headers.patch b/meta-v1000/recipes-devtools/glslang/glslang/0002-spirv-do-not-install-conflicting-headers.patch
new file mode 100644
index 00000000..69e64060
--- /dev/null
+++ b/meta-v1000/recipes-devtools/glslang/glslang/0002-spirv-do-not-install-conflicting-headers.patch
@@ -0,0 +1,30 @@
+From 1823de236f38fc7eb7caedec666c9dde956832cd Mon Sep 17 00:00:00 2001
+From: Awais Belal <awais_belal@mentor.com>
+Date: Wed, 31 May 2017 13:04:42 +0500
+Subject: [PATCH] spirv: do not install conflicting headers
+
+These headers are already provided by the
+spirv-tools package so there's no need of
+installing them here again.
+
+Signed-off-by: Awais Belal <awais_belal@mentor.com>
+---
+ SPIRV/CMakeLists.txt | 2 --
+ 1 file changed, 2 deletions(-)
+
+diff --git a/SPIRV/CMakeLists.txt b/SPIRV/CMakeLists.txt
+index aaf11780..d5c43723 100755
+--- a/SPIRV/CMakeLists.txt
++++ b/SPIRV/CMakeLists.txt
+@@ -12,8 +12,6 @@ set(SPVREMAP_SOURCES
+
+ set(HEADERS
+ bitutils.h
+- spirv.hpp
+- GLSL.std.450.h
+ GLSL.ext.KHR.h
+ GlslangToSpv.h
+ hex_float.h
+--
+2.11.1
+
diff --git a/meta-v1000/recipes-devtools/glslang/glslang_git.bb b/meta-v1000/recipes-devtools/glslang/glslang_git.bb
new file mode 100644
index 00000000..bc749b40
--- /dev/null
+++ b/meta-v1000/recipes-devtools/glslang/glslang_git.bb
@@ -0,0 +1,23 @@
+SUMMARY = "An OpenGL and OpenGL ES shader front end and validator."
+DESCRIPTION = "Glslang is the official reference compiler front end \
+ for the OpenGL ES and OpenGL shading languages. It \
+ implements a strict interpretation of the specifications \
+ for these languages. It is open and free for anyone to use, \
+ either from a command line or programmatically."
+SECTION = "graphics"
+HOMEPAGE = "https://www.khronos.org/opengles/sdk/tools/Reference-Compiler"
+
+inherit cmake
+
+LICENSE = "BSD"
+LIC_FILES_CHKSUM = "file://glslang/Include/Types.h;beginline=1;endline=36;md5=9dbd36d87d27a0c98a6f4d72afaa9cf8"
+
+S = "${WORKDIR}/git"
+
+SRCREV = "2651ccaec8170b3257642b3c438f50dc4f181fdd"
+SRC_URI = "git://github.com/KhronosGroup/glslang \
+ file://0002-spirv-do-not-install-conflicting-headers.patch"
+
+FILES_${PN} += "${libdir}/*"
+
+BBCLASSEXTEND = "native nativesdk"
diff --git a/meta-v1000/recipes-devtools/spirv/spirv-tools/0002-spirv-lesspipe.sh-allow-using-generic-shells.patch b/meta-v1000/recipes-devtools/spirv/spirv-tools/0002-spirv-lesspipe.sh-allow-using-generic-shells.patch
new file mode 100644
index 00000000..40bc477a
--- /dev/null
+++ b/meta-v1000/recipes-devtools/spirv/spirv-tools/0002-spirv-lesspipe.sh-allow-using-generic-shells.patch
@@ -0,0 +1,27 @@
+From f6c173b1c32e6dcbac510a4bcb60e6bb080c146a Mon Sep 17 00:00:00 2001
+From: Awais Belal <awais_belal@mentor.com>
+Date: Wed, 31 May 2017 12:26:04 +0500
+Subject: [PATCH 2/2] spirv-lesspipe.sh: allow using generic shells
+
+The script is harmless for any type of shell and
+shouldn't be tied with bash to allow catering
+more possibilities.
+
+Signed-off-by: Awais Belal <awais_belal@mentor.com>
+---
+ tools/lesspipe/spirv-lesspipe.sh | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/tools/lesspipe/spirv-lesspipe.sh b/tools/lesspipe/spirv-lesspipe.sh
+index 81e3355..f955259 100644
+--- a/tools/lesspipe/spirv-lesspipe.sh
++++ b/tools/lesspipe/spirv-lesspipe.sh
+@@ -1,4 +1,4 @@
+-#!/bin/bash
++#!/bin/sh
+ # Copyright (c) 2016 The Khronos Group Inc.
+
+ # Licensed under the Apache License, Version 2.0 (the "License");
+--
+2.11.1
+
diff --git a/meta-v1000/recipes-devtools/spirv/spirv-tools_git.bb b/meta-v1000/recipes-devtools/spirv/spirv-tools_git.bb
new file mode 100644
index 00000000..a4da04e2
--- /dev/null
+++ b/meta-v1000/recipes-devtools/spirv/spirv-tools_git.bb
@@ -0,0 +1,28 @@
+SUMMARY = "SPIR-V Tools"
+DESCRIPTION = "SPIR-V is a binary intermediate language for representing \
+ graphical-shader stages and compute kernels for multiple \
+ Khronos APIs, such as OpenCL, OpenGL, and Vulkan."
+SECTION = "graphics"
+HOMEPAGE = "https://www.khronos.org/registry/spir-v"
+
+inherit cmake python3native
+
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57"
+
+S = "${WORKDIR}/git"
+SPIRV_HEADERS_LOCATION = "${S}/external/spirv-headers"
+HEADERS_VERSION = "1.1"
+
+SRCREV_spirv-tools = "9e19fc0f31ceaf1f6bc907dbf17dcfded85f2ce8"
+SRCREV_spirv-headers = "ce309203d7eceaf908bea8862c27f3e0749f7d00"
+SRC_URI = "git://github.com/KhronosGroup/SPIRV-Tools;protocol=http;name=spirv-tools \
+ git://github.com/KhronosGroup/SPIRV-Headers;name=spirv-headers;destsuffix=${SPIRV_HEADERS_LOCATION} \
+ file://0002-spirv-lesspipe.sh-allow-using-generic-shells.patch"
+
+do_install_append() {
+ if test -d ${SPIRV_HEADERS_LOCATION}/include/spirv/${HEADERS_VERSION}; then
+ install -d ${D}/${includedir}/SPIRV
+ install -m 0644 ${SPIRV_HEADERS_LOCATION}/include/spirv/${HEADERS_VERSION}/* ${D}/${includedir}/SPIRV
+ fi
+}