aboutsummaryrefslogtreecommitdiffstats
path: root/meta/packages/qemu
diff options
context:
space:
mode:
Diffstat (limited to 'meta/packages/qemu')
-rw-r--r--meta/packages/qemu/qemu-0.12.4/fix-nogl.patch44
-rw-r--r--meta/packages/qemu/qemu.inc4
-rw-r--r--meta/packages/qemu/qemu_0.12.4.bb2
3 files changed, 39 insertions, 11 deletions
diff --git a/meta/packages/qemu/qemu-0.12.4/fix-nogl.patch b/meta/packages/qemu/qemu-0.12.4/fix-nogl.patch
index 68efab3a1f..528b6f0d18 100644
--- a/meta/packages/qemu/qemu-0.12.4/fix-nogl.patch
+++ b/meta/packages/qemu/qemu-0.12.4/fix-nogl.patch
@@ -1,21 +1,22 @@
-Index: qemu/Makefile.target
+Index: qemu-0.12.4/Makefile.target
===================================================================
---- qemu.orig/Makefile.target 2010-05-11 16:53:34.545811866 -0400
-+++ qemu/Makefile.target 2010-05-11 16:53:37.743809704 -0400
-@@ -47,6 +47,9 @@ libobj-$(CONFIG_NOSOFTFLOAT) += fpu/soft
+--- qemu-0.12.4.orig/Makefile.target 2010-06-24 07:59:15.669394205 +0100
++++ qemu-0.12.4/Makefile.target 2010-06-24 08:07:38.739399512 +0100
+@@ -47,6 +47,10 @@
libobj-y += op_helper.o helper.o
libobj-$(CONFIG_NEED_MMU) += mmu.o
libobj-$(TARGET_I386) += helper_opengl.o opengl_exec.o
+libobj-$(TARGET_X86_64) += helper_opengl.o opengl_exec.o
+libobj-$(TARGET_ARM) += dummygl.o
+libobj-$(TARGET_MIPS) += dummygl.o
++libobj-$(TARGET_PPC) += dummygl.o
libobj-$(TARGET_ARM) += neon_helper.o iwmmxt_helper.o
libobj-$(TARGET_ALPHA) += alpha_palcode.o
-Index: qemu/target-arm/dummygl.c
+Index: qemu-0.12.4/target-arm/dummygl.c
===================================================================
--- /dev/null 1970-01-01 00:00:00.000000000 +0000
-+++ qemu/target-arm/dummygl.c 2010-05-11 16:53:37.743809704 -0400
++++ qemu-0.12.4/target-arm/dummygl.c 2010-06-24 07:59:15.899401748 +0100
@@ -0,0 +1,22 @@
+#include <string.h>
+#include <stdlib.h>
@@ -39,10 +40,37 @@ Index: qemu/target-arm/dummygl.c
+{
+
+}
-Index: qemu/target-mips/dummygl.c
+Index: qemu-0.12.4/target-mips/dummygl.c
===================================================================
--- /dev/null 1970-01-01 00:00:00.000000000 +0000
-+++ qemu/target-mips/dummygl.c 2010-05-11 16:53:37.744811919 -0400
++++ qemu-0.12.4/target-mips/dummygl.c 2010-06-24 07:59:15.899401748 +0100
+@@ -0,0 +1,22 @@
++#include <string.h>
++#include <stdlib.h>
++#include <assert.h>
++#include <stdint.h>
++#include <X11/Xlib.h>
++#include <X11/Xutil.h>
++
++void opengl_exec_set_parent_window(Display* _dpy, Window _parent_window)
++{
++
++}
++
++void opengl_process_enable(void)
++{
++
++}
++
++
++void mem_opengl(uint64_t ptr)
++{
++
++}
+Index: qemu-0.12.4/target-ppc/dummygl.c
+===================================================================
+--- /dev/null 1970-01-01 00:00:00.000000000 +0000
++++ qemu-0.12.4/target-ppc/dummygl.c 2010-06-24 08:07:59.070712946 +0100
@@ -0,0 +1,22 @@
+#include <string.h>
+#include <stdlib.h>
diff --git a/meta/packages/qemu/qemu.inc b/meta/packages/qemu/qemu.inc
index c744990d0f..5711596cc2 100644
--- a/meta/packages/qemu/qemu.inc
+++ b/meta/packages/qemu/qemu.inc
@@ -3,7 +3,7 @@ HOMEPAGE = "http://qemu.org"
LICENSE = "GPL"
DEPENDS = "zlib"
-EXTRA_OECONF = "--target-list=arm-linux-user,arm-softmmu,i386-softmmu,x86_64-softmmu,mips-linux-user,mips-softmmu --disable-werror --disable-vnc-tls"
+EXTRA_OECONF = "--target-list=arm-linux-user,arm-softmmu,i386-softmmu,x86_64-softmmu,mips-linux-user,mips-softmmu,ppc-softmmu --disable-werror --disable-vnc-tls"
#EXTRA_OECONF += "--disable-sdl"
inherit autotools
@@ -33,6 +33,6 @@ do_configure() {
SRC_URI_append_virtclass-nativesdk = " file://glflags.patch;patch=1"
DEPENDS_virtclass-nativesdk = "zlib-nativesdk libsdl-nativesdk qemugl-nativesdk"
RDEPENDS_virtclass-nativesdk = "libsdl-nativesdk"
-EXTRA_OECONF_virtclass-nativesdk = "--target-list=arm-linux-user,arm-softmmu,i386-softmmu,x86_64-softmmu,mips-linux-user,mips-softmmu --disable-vnc-tls --cross-prefix=${TARGET_PREFIX}"
+EXTRA_OECONF_virtclass-nativesdk = "--target-list=arm-linux-user,arm-softmmu,i386-softmmu,x86_64-softmmu,mips-linux-user,mips-softmmu,ppc-softmmu --disable-vnc-tls --cross-prefix=${TARGET_PREFIX}"
BBCLASSEXTEND = "native nativesdk"
diff --git a/meta/packages/qemu/qemu_0.12.4.bb b/meta/packages/qemu/qemu_0.12.4.bb
index 79b0749f32..20cc8e8a5a 100644
--- a/meta/packages/qemu/qemu_0.12.4.bb
+++ b/meta/packages/qemu/qemu_0.12.4.bb
@@ -1,6 +1,6 @@
require qemu.inc
-PR = "r14"
+PR = "r15"
FILESPATH = "${FILE_DIRNAME}/qemu-${PV}"
FILESDIR = "${WORKDIR}"