aboutsummaryrefslogtreecommitdiffstats
path: root/meta/packages/linux/linux-rp-2.6.19+2.6.20-rc4/add-oz-release-string.patch
diff options
context:
space:
mode:
Diffstat (limited to 'meta/packages/linux/linux-rp-2.6.19+2.6.20-rc4/add-oz-release-string.patch')
-rw-r--r--meta/packages/linux/linux-rp-2.6.19+2.6.20-rc4/add-oz-release-string.patch28
1 files changed, 28 insertions, 0 deletions
diff --git a/meta/packages/linux/linux-rp-2.6.19+2.6.20-rc4/add-oz-release-string.patch b/meta/packages/linux/linux-rp-2.6.19+2.6.20-rc4/add-oz-release-string.patch
new file mode 100644
index 0000000000..a80a1d5528
--- /dev/null
+++ b/meta/packages/linux/linux-rp-2.6.19+2.6.20-rc4/add-oz-release-string.patch
@@ -0,0 +1,28 @@
+---
+ Makefile | 1 +
+ init/version.c | 2 +-
+ 2 files changed, 2 insertions(+), 1 deletion(-)
+
+Index: git/init/version.c
+===================================================================
+--- git.orig/init/version.c 2006-10-31 16:09:47.000000000 +0000
++++ git/init/version.c 2006-10-31 16:24:54.000000000 +0000
+@@ -35,5 +35,5 @@ struct uts_namespace init_uts_ns = {
+ EXPORT_SYMBOL_GPL(init_uts_ns);
+
+ const char linux_banner[] =
+- "Linux version " UTS_RELEASE " (" LINUX_COMPILE_BY "@"
++ "Linux version " UTS_RELEASE OPENZAURUS_RELEASE " (" LINUX_COMPILE_BY "@"
+ LINUX_COMPILE_HOST ") (" LINUX_COMPILER ") " UTS_VERSION "\n";
+Index: git/Makefile
+===================================================================
+--- git.orig/Makefile 2006-10-31 16:08:28.000000000 +0000
++++ git/Makefile 2006-10-31 16:27:02.000000000 +0000
+@@ -905,6 +905,7 @@ endef
+ define filechk_version.h
+ (echo \#define LINUX_VERSION_CODE $(shell \
+ expr $(VERSION) \* 65536 + $(PATCHLEVEL) \* 256 + $(SUBLEVEL)); \
++ echo \#define OPENZAURUS_RELEASE \"$(OPENZAURUS_RELEASE)\"; \
+ echo '#define KERNEL_VERSION(a,b,c) (((a) << 16) + ((b) << 8) + (c))';)
+ endef
+