aboutsummaryrefslogtreecommitdiffstats
path: root/meta/packages/hostap/hostap-modules
diff options
context:
space:
mode:
Diffstat (limited to 'meta/packages/hostap/hostap-modules')
-rw-r--r--meta/packages/hostap/hostap-modules/Makefile.patch11
-rw-r--r--meta/packages/hostap/hostap-modules/add_event.patch28
-rw-r--r--meta/packages/hostap/hostap-modules/hostap-utsname.patch77
-rw-r--r--meta/packages/hostap/hostap-modules/hostap_cardid.patch70
-rw-r--r--meta/packages/hostap/hostap-modules/ipaq_compat.patch11
-rw-r--r--meta/packages/hostap/hostap-modules/kernel_updates.patch192
-rw-r--r--meta/packages/hostap/hostap-modules/mtx_compat.diff20
-rw-r--r--meta/packages/hostap/hostap-modules/mtx_hostap_deferred_irq.diff81
8 files changed, 490 insertions, 0 deletions
diff --git a/meta/packages/hostap/hostap-modules/Makefile.patch b/meta/packages/hostap/hostap-modules/Makefile.patch
new file mode 100644
index 0000000000..2fc5e9ed4b
--- /dev/null
+++ b/meta/packages/hostap/hostap-modules/Makefile.patch
@@ -0,0 +1,11 @@
+--- hostap-driver-0.2.4/Makefile.old 2004-07-31 10:35:50.000000000 +0100
++++ hostap-driver-0.2.4/Makefile 2004-07-31 10:35:56.000000000 +0100
+@@ -51,7 +51,7 @@
+
+ VERFILE := $(KERNEL_PATH)/include/linux/version.h
+ KERNELRELEASE := $(shell if [ -r $(VERFILE) ]; \
+- then (cat $(VERFILE); echo UTS_RELEASE) | $(CC) $(INCLUDES) $(CFLAGS) -E - | tail -1 | xargs echo; \
++ then (cat $(VERFILE); echo UTS_RELEASE) | $(CC) $(INCLUDES) $(CFLAGS) -E - | tail -n 1 | xargs echo; \
+ else uname -r; fi)
+ KERNELVER := $(shell echo "$(KERNELRELEASE)" | \
+ sed "s/\([0-9]*\.[0-9]*\.[0-9]*\).*/\1/")
diff --git a/meta/packages/hostap/hostap-modules/add_event.patch b/meta/packages/hostap/hostap-modules/add_event.patch
new file mode 100644
index 0000000000..d5f2a10e86
--- /dev/null
+++ b/meta/packages/hostap/hostap-modules/add_event.patch
@@ -0,0 +1,28 @@
+Index: hostap-driver-0.3.7/driver/modules/hostap_cs.c
+===================================================================
+--- hostap-driver-0.3.7.orig/driver/modules/hostap_cs.c 2005-08-03 17:05:53.000000000 +0100
++++ hostap-driver-0.3.7/driver/modules/hostap_cs.c 2005-08-03 17:07:59.000000000 +0100
+@@ -526,11 +526,13 @@
+ dev_list = link;
+ client_reg.dev_info = &dev_info;
+ client_reg.Attributes = INFO_IO_CLIENT;
++#if (LINUX_VERSION_CODE < KERNEL_VERSION(2,6,13))
+ client_reg.EventMask = CS_EVENT_CARD_INSERTION |
+ CS_EVENT_CARD_REMOVAL |
+ CS_EVENT_RESET_PHYSICAL | CS_EVENT_CARD_RESET |
+ CS_EVENT_PM_SUSPEND | CS_EVENT_PM_RESUME;
+ client_reg.event_handler = &prism2_event;
++#endif
+ client_reg.Version = 0x0210;
+ client_reg.event_callback_args.client_data = link;
+ ret = pcmcia_register_client(&link->handle, &client_reg);
+@@ -913,6 +915,9 @@
+ .name = "hostap_cs",
+ },
+ .attach = prism2_attach,
++#if (LINUX_VERSION_CODE > KERNEL_VERSION(2,6,12))
++ .event = prism2_event,
++#endif
+ .detach = prism2_detach,
+ .owner = THIS_MODULE,
+ };
diff --git a/meta/packages/hostap/hostap-modules/hostap-utsname.patch b/meta/packages/hostap/hostap-modules/hostap-utsname.patch
new file mode 100644
index 0000000000..c29cc8d2c9
--- /dev/null
+++ b/meta/packages/hostap/hostap-modules/hostap-utsname.patch
@@ -0,0 +1,77 @@
+diff -r -U 3 hostap-driver-0.3.7.orig/driver/modules/hostap.c hostap-driver-0.3.7/driver/modules/hostap.c
+--- hostap-driver-0.3.7.orig/driver/modules/hostap.c 2005-07-25 09:14:01.995965088 +0000
++++ hostap-driver-0.3.7/driver/modules/hostap.c 2005-07-25 09:13:22.301999488 +0000
+@@ -25,6 +25,7 @@
+ #include <linux/if_arp.h>
+ #include <linux/delay.h>
+ #include <linux/random.h>
++#include <linux/utsname.h>
+ #if (LINUX_VERSION_CODE < KERNEL_VERSION(2,5,44))
+ #include <linux/tqueue.h>
+ #else
+diff -r -U 3 hostap-driver-0.3.7.orig/driver/modules/hostap_crypt_ccmp.c hostap-driver-0.3.7/driver/modules/hostap_crypt_ccmp.c
+--- hostap-driver-0.3.7.orig/driver/modules/hostap_crypt_ccmp.c 2005-07-25 09:14:01.996964936 +0000
++++ hostap-driver-0.3.7/driver/modules/hostap_crypt_ccmp.c 2005-07-25 09:13:22.302999336 +0000
+@@ -19,6 +19,7 @@
+ #include <linux/netdevice.h>
+ #include <linux/if_ether.h>
+ #include <linux/if_arp.h>
++#include <linux/utsname.h>
+ #include <asm/string.h>
+
+ #include "hostap_crypt.h"
+diff -r -U 3 hostap-driver-0.3.7.orig/driver/modules/hostap_crypt_tkip.c hostap-driver-0.3.7/driver/modules/hostap_crypt_tkip.c
+--- hostap-driver-0.3.7.orig/driver/modules/hostap_crypt_tkip.c 2005-07-25 09:14:01.996964936 +0000
++++ hostap-driver-0.3.7/driver/modules/hostap_crypt_tkip.c 2005-07-25 09:13:22.302999336 +0000
+@@ -19,6 +19,7 @@
+ #include <linux/netdevice.h>
+ #include <linux/if_ether.h>
+ #include <linux/if_arp.h>
++#include <linux/utsname.h>
+ #include <asm/string.h>
+
+ #include "hostap_crypt.h"
+diff -r -U 3 hostap-driver-0.3.7.orig/driver/modules/hostap_crypt_wep.c hostap-driver-0.3.7/driver/modules/hostap_crypt_wep.c
+--- hostap-driver-0.3.7.orig/driver/modules/hostap_crypt_wep.c 2005-07-25 09:14:01.996964936 +0000
++++ hostap-driver-0.3.7/driver/modules/hostap_crypt_wep.c 2005-07-25 09:13:22.302999336 +0000
+@@ -15,6 +15,7 @@
+ #include <linux/init.h>
+ #include <linux/slab.h>
+ #include <linux/random.h>
++#include <linux/utsname.h>
+ #if (LINUX_VERSION_CODE < KERNEL_VERSION(2,5,44))
+ #include <linux/tqueue.h>
+ #else
+diff -r -U 3 hostap-driver-0.3.7.orig/driver/modules/hostap_cs.c hostap-driver-0.3.7/driver/modules/hostap_cs.c
+--- hostap-driver-0.3.7.orig/driver/modules/hostap_cs.c 2005-07-25 09:14:01.997964784 +0000
++++ hostap-driver-0.3.7/driver/modules/hostap_cs.c 2005-07-25 09:13:22.302999336 +0000
+@@ -12,6 +12,7 @@
+ #include <linux/timer.h>
+ #include <linux/skbuff.h>
+ #include <linux/netdevice.h>
++#include <linux/utsname.h>
+ #if (LINUX_VERSION_CODE < KERNEL_VERSION(2,5,44))
+ #include <linux/tqueue.h>
+ #else
+diff -r -U 3 hostap-driver-0.3.7.orig/driver/modules/hostap_pci.c hostap-driver-0.3.7/driver/modules/hostap_pci.c
+--- hostap-driver-0.3.7.orig/driver/modules/hostap_pci.c 2005-07-25 09:14:01.997964784 +0000
++++ hostap-driver-0.3.7/driver/modules/hostap_pci.c 2005-07-25 09:13:22.303999184 +0000
+@@ -11,6 +11,7 @@
+ #include <linux/if.h>
+ #include <linux/skbuff.h>
+ #include <linux/netdevice.h>
++#include <linux/utsname.h>
+ #if (LINUX_VERSION_CODE < KERNEL_VERSION(2,5,44))
+ #include <linux/tqueue.h>
+ #else
+diff -r -U 3 hostap-driver-0.3.7.orig/driver/modules/hostap_plx.c hostap-driver-0.3.7/driver/modules/hostap_plx.c
+--- hostap-driver-0.3.7.orig/driver/modules/hostap_plx.c 2005-07-25 09:14:01.997964784 +0000
++++ hostap-driver-0.3.7/driver/modules/hostap_plx.c 2005-07-25 09:13:22.303999184 +0000
+@@ -14,6 +14,7 @@
+ #include <linux/if.h>
+ #include <linux/skbuff.h>
+ #include <linux/netdevice.h>
++#include <linux/utsname.h>
+ #if (LINUX_VERSION_CODE < KERNEL_VERSION(2,5,44))
+ #include <linux/tqueue.h>
+ #else
diff --git a/meta/packages/hostap/hostap-modules/hostap_cardid.patch b/meta/packages/hostap/hostap-modules/hostap_cardid.patch
new file mode 100644
index 0000000000..05f716e22f
--- /dev/null
+++ b/meta/packages/hostap/hostap-modules/hostap_cardid.patch
@@ -0,0 +1,70 @@
+Index: hostap-driver-0.3.9/driver/modules/hostap_cs.c
+===================================================================
+--- hostap-driver-0.3.9.orig/driver/modules/hostap_cs.c 2005-08-24 10:11:47.000000000 +0100
++++ hostap-driver-0.3.9/driver/modules/hostap_cs.c 2005-08-24 10:39:10.000000000 +0100
+@@ -908,6 +908,57 @@
+ return 0;
+ }
+
++#if (LINUX_VERSION_CODE > KERNEL_VERSION(2,6,12))
++static struct pcmcia_device_id hostap_cs_ids[] = {
++ PCMCIA_DEVICE_MANF_CARD(0x000b, 0x7100),
++ PCMCIA_DEVICE_MANF_CARD(0x000b, 0x7300),
++ PCMCIA_DEVICE_MANF_CARD(0x0101, 0x0777),
++ PCMCIA_DEVICE_MANF_CARD(0x0126, 0x8000),
++ PCMCIA_DEVICE_MANF_CARD(0x0138, 0x0002),
++ PCMCIA_DEVICE_MANF_CARD(0x0156, 0x0002),
++ PCMCIA_DEVICE_MANF_CARD(0x0250, 0x0002),
++ PCMCIA_DEVICE_MANF_CARD(0x0274, 0x1612),
++ PCMCIA_DEVICE_MANF_CARD(0x0274, 0x1613),
++ PCMCIA_DEVICE_MANF_CARD(0x028a, 0x0002),
++ PCMCIA_DEVICE_MANF_CARD(0x02aa, 0x0002),
++ PCMCIA_DEVICE_MANF_CARD(0x02d2, 0x0001),
++ PCMCIA_DEVICE_MANF_CARD(0x50c2, 0x0001),
++ PCMCIA_DEVICE_MANF_CARD(0x50c2, 0x7300),
++ PCMCIA_DEVICE_MANF_CARD(0xc00f, 0x0000),
++ PCMCIA_DEVICE_MANF_CARD(0xd601, 0x0002),
++ PCMCIA_DEVICE_MANF_CARD(0xd601, 0x0005),
++ PCMCIA_DEVICE_MANF_CARD(0xd601, 0x0010),
++ PCMCIA_MFC_DEVICE_PROD_ID12(0, "SanDisk", "ConnectPlus",
++ 0x7a954bd9, 0x74be00c6),
++ PCMCIA_DEVICE_PROD_ID1234(
++ "Intersil", "PRISM 2_5 PCMCIA ADAPTER", "ISL37300P",
++ "Eval-RevA",
++ 0x4b801a17, 0x6345a0bf, 0xc9049a39, 0xc23adc0e),
++ PCMCIA_DEVICE_PROD_ID123(
++ "Addtron", "AWP-100 Wireless PCMCIA", "Version 01.02",
++ 0xe6ec52ce, 0x08649af2, 0x4b74baa0),
++ PCMCIA_DEVICE_PROD_ID123(
++ "D", "Link DWL-650 11Mbps WLAN Card", "Version 01.02",
++ 0x71b18589, 0xb6f1b0ab, 0x4b74baa0),
++ PCMCIA_DEVICE_PROD_ID123(
++ "Instant Wireless ", " Network PC CARD", "Version 01.02",
++ 0x11d901af, 0x6e9bd926, 0x4b74baa0),
++ PCMCIA_DEVICE_PROD_ID123(
++ "SMC", "SMC2632W", "Version 01.02",
++ 0xc4f8b18b, 0x474a1f2a, 0x4b74baa0),
++ PCMCIA_DEVICE_PROD_ID12("Compaq", "WL200_11Mbps_Wireless_PCI_Card",
++ 0x54f7c49c, 0x15a75e5b),
++ PCMCIA_DEVICE_PROD_ID12("INTERSIL", "HFA384x/IEEE",
++ 0x74c5e40d, 0xdb472a18),
++ PCMCIA_DEVICE_PROD_ID12("Linksys", "Wireless CompactFlash Card",
++ 0x0733cc81, 0x0c52f395),
++ PCMCIA_DEVICE_PROD_ID12(
++ "ZoomAir 11Mbps High", "Rate wireless Networking",
++ 0x273fe3db, 0x32a1eaee),
++ PCMCIA_DEVICE_NULL
++};
++MODULE_DEVICE_TABLE(pcmcia, hostap_cs_ids);
++#endif
+
+ #if LINUX_VERSION_CODE > KERNEL_VERSION(2,5,67)
+ static struct pcmcia_driver hostap_driver = {
+@@ -917,6 +968,7 @@
+ .attach = prism2_attach,
+ #if (LINUX_VERSION_CODE > KERNEL_VERSION(2,6,12))
+ .event = prism2_event,
++ .id_table = hostap_cs_ids,
+ #endif
+ .detach = prism2_detach,
+ .owner = THIS_MODULE,
diff --git a/meta/packages/hostap/hostap-modules/ipaq_compat.patch b/meta/packages/hostap/hostap-modules/ipaq_compat.patch
new file mode 100644
index 0000000000..b139ef38f1
--- /dev/null
+++ b/meta/packages/hostap/hostap-modules/ipaq_compat.patch
@@ -0,0 +1,11 @@
+--- hostap-driver-0.3.7/driver/modules/hostap_compat.h.old 2005-04-17 09:12:38.304421464 +0100
++++ hostap-driver-0.3.7/driver/modules/hostap_compat.h 2005-04-17 09:13:04.413452288 +0100
+@@ -5,7 +5,7 @@
+ #define NEW_MODULE_CODE
+ #endif
+
+-#if (LINUX_VERSION_CODE < KERNEL_VERSION(2,5,44))
++#if (LINUX_VERSION_CODE < KERNEL_VERSION(2,5,44)) && !defined(CONFIG_IPAQ_HANDHELD)
+
+ #define HOSTAP_QUEUE struct tq_struct
+
diff --git a/meta/packages/hostap/hostap-modules/kernel_updates.patch b/meta/packages/hostap/hostap-modules/kernel_updates.patch
new file mode 100644
index 0000000000..70487a96f8
--- /dev/null
+++ b/meta/packages/hostap/hostap-modules/kernel_updates.patch
@@ -0,0 +1,192 @@
+Index: hostap-driver-0.4.4/driver/modules/hostap_cs.c
+===================================================================
+--- hostap-driver-0.4.4.orig/driver/modules/hostap_cs.c 2005-08-21 20:23:21.000000000 +0100
++++ hostap-driver-0.4.4/driver/modules/hostap_cs.c 2005-09-17 17:09:05.000000000 +0100
+@@ -207,12 +207,17 @@
+ #include "hostap_hw.c"
+
+
+-
++#if (LINUX_VERSION_CODE < KERNEL_VERSION(2,6,15))
+ static void prism2_detach(dev_link_t *link);
++#else
++static void prism2_detach(struct pcmcia_device *p_dev);
++#endif
++
+ static void prism2_release(u_long arg);
++#if (LINUX_VERSION_CODE < KERNEL_VERSION(2,6,15))
+ static int prism2_event(event_t event, int priority,
+ event_callback_args_t *args);
+-
++#endif
+
+ static int prism2_pccard_card_present(local_info_t *local)
+ {
+@@ -508,25 +513,36 @@
+ }
+ #endif
+
++static int prism2_config(dev_link_t *link);
+
+ /* allocate local data and register with CardServices
+ * initialize dev_link structure, but do not configure the card yet */
++#if (LINUX_VERSION_CODE < KERNEL_VERSION(2,6,15))
+ static dev_link_t *prism2_attach(void)
++#else
++static int prism2_attach(struct pcmcia_device *p_dev)
++#endif
+ {
+ dev_link_t *link;
++#if (LINUX_VERSION_CODE < KERNEL_VERSION(2,6,15))
+ client_reg_t client_reg;
+ int ret;
++#endif
+
+ link = kmalloc(sizeof(dev_link_t), GFP_KERNEL);
+ if (link == NULL)
++#if (LINUX_VERSION_CODE < KERNEL_VERSION(2,6,15))
+ return NULL;
+-
++#else
++ return -ENOMEM;
++#endif
+ memset(link, 0, sizeof(dev_link_t));
+
+ PDEBUG(DEBUG_HW, "%s: setting Vcc=33 (constant)\n", dev_info);
+ link->conf.Vcc = 33;
+ link->conf.IntType = INT_MEMORY_AND_IO;
+
++#if (LINUX_VERSION_CODE < KERNEL_VERSION(2,6,15))
+ /* register with CardServices */
+ link->next = dev_list;
+ dev_list = link;
+@@ -547,12 +563,28 @@
+ prism2_detach(link);
+ return NULL;
+ }
++
+ return link;
+-}
++#else
++ link->handle = p_dev;
++ p_dev->instance = link;
++
++ link->state |= DEV_PRESENT | DEV_CONFIG_PENDING;
++ prism2_config(link);
+
++ return 0;
++#endif
++}
+
++#if (LINUX_VERSION_CODE < KERNEL_VERSION(2,6,15))
+ static void prism2_detach(dev_link_t *link)
++#else
++static void prism2_detach(struct pcmcia_device *p_dev)
++#endif
+ {
++#if (LINUX_VERSION_CODE >= KERNEL_VERSION(2,6,15))
++ dev_link_t *link = dev_to_instance(p_dev);
++#endif
+ dev_link_t **linkp;
+
+ PDEBUG(DEBUG_FLOW, "prism2_detach\n");
+@@ -570,6 +602,7 @@
+ prism2_release((u_long)link);
+ }
+
++#if (LINUX_VERSION_CODE < KERNEL_VERSION(2,6,15))
+ if (link->handle) {
+ int res = pcmcia_deregister_client(link->handle);
+ if (res) {
+@@ -577,6 +610,7 @@
+ cs_error(link->handle, DeregisterClient, res);
+ }
+ }
++#endif
+
+ *linkp = link->next;
+ /* release net devices */
+@@ -855,7 +889,53 @@
+ PDEBUG(DEBUG_FLOW, "release - done\n");
+ }
+
++#if (LINUX_VERSION_CODE >= KERNEL_VERSION(2,6,15))
++static int prism2_suspend1(struct pcmcia_device *dev)
++{
++ dev_link_t *link = dev_to_instance(dev);
++ struct net_device *ndev = (struct net_device *) link->priv;
++
++ PDEBUG(DEBUG_EXTRA, "%s: CS_EVENT_PM_SUSPEND\n", dev_info);
++ link->state |= DEV_SUSPEND;
++ /* fall through */
+
++ if (link->state & DEV_CONFIG) {
++ if (link->open) {
++ netif_stop_queue(ndev);
++ netif_device_detach(ndev);
++ }
++ prism2_suspend(ndev);
++ pcmcia_release_configuration(link->handle);
++ }
++
++ return 0;
++}
++
++static int prism2_resume1(struct pcmcia_device *dev)
++{
++ dev_link_t *link = dev_to_instance(dev);
++ struct net_device *ndev = (struct net_device *) link->priv;
++
++ PDEBUG(DEBUG_EXTRA, "%s: CS_EVENT_PM_RESUME\n", dev_info);
++
++ link->state &= ~DEV_SUSPEND;
++ /* fall through */
++
++ if (link->state & DEV_CONFIG) {
++ pcmcia_request_configuration(link->handle, &link->conf);
++ prism2_hw_shutdown(ndev, 1);
++ prism2_hw_config(ndev, link->open ? 0 : 1);
++ if (link->open) {
++ netif_device_attach(ndev);
++ netif_start_queue(ndev);
++ }
++ }
++
++ return 0;
++}
++#endif
++
++#if (LINUX_VERSION_CODE < KERNEL_VERSION(2,6,15))
+ static int prism2_event(event_t event, int priority,
+ event_callback_args_t *args)
+ {
+@@ -924,7 +1004,7 @@
+ }
+ return 0;
+ }
+-
++#endif
+
+ #if LINUX_VERSION_CODE > KERNEL_VERSION(2,5,67)
+ #if (LINUX_VERSION_CODE >= KERNEL_VERSION(2,6,13))
+@@ -983,11 +1063,20 @@
+ .drv = {
+ .name = "hostap_cs",
+ },
++#if (LINUX_VERSION_CODE >= KERNEL_VERSION(2,6,15))
++ .probe = prism2_attach,
++ .remove = prism2_detach,
++ .suspend = prism2_suspend1,
++ .resume = prism2_resume1,
++#else
+ .attach = prism2_attach,
+ .detach = prism2_detach,
++#endif
+ .owner = THIS_MODULE,
+ #if (LINUX_VERSION_CODE >= KERNEL_VERSION(2,6,13))
++#if (LINUX_VERSION_CODE < KERNEL_VERSION(2,6,15))
+ .event = prism2_event,
++#endif
+ .id_table = hostap_cs_ids,
+ #endif
+ };
diff --git a/meta/packages/hostap/hostap-modules/mtx_compat.diff b/meta/packages/hostap/hostap-modules/mtx_compat.diff
new file mode 100644
index 0000000000..c2d6662d69
--- /dev/null
+++ b/meta/packages/hostap/hostap-modules/mtx_compat.diff
@@ -0,0 +1,20 @@
+--- driver/modules/hostap_compat.h.orig 2004-08-09 16:16:48.359929856 +0200
++++ driver/modules/hostap_compat.h 2004-08-09 16:17:12.383277752 +0200
+@@ -13,7 +13,7 @@
+ MOD_INC_USE_COUNT; \
+ if (schedule_task((q)) == 0) \
+ MOD_DEC_USE_COUNT;
+-
++/*
+ static inline void flush_scheduled_work(void)
+ {
+ flush_scheduled_tasks();
+@@ -27,7 +27,7 @@
+ tq->routine = routine;
+ tq->data = data;
+ }
+-
++*/
+ #else /* kernel < 2.5.44 */
+
+ #define HOSTAP_QUEUE struct work_struct
diff --git a/meta/packages/hostap/hostap-modules/mtx_hostap_deferred_irq.diff b/meta/packages/hostap/hostap-modules/mtx_hostap_deferred_irq.diff
new file mode 100644
index 0000000000..e979b72d93
--- /dev/null
+++ b/meta/packages/hostap/hostap-modules/mtx_hostap_deferred_irq.diff
@@ -0,0 +1,81 @@
+--- driver/modules/hostap_pci.c.orig 2004-11-30 06:41:48.000000000 +0100
++++ driver/modules/hostap_pci.c 2005-01-17 19:47:33.710400496 +0100
+@@ -50,6 +50,13 @@
+ };
+
+
++#define DEFERRED_IRQ_INITIALIZATION
++
++#ifdef DEFERRED_IRQ_INITIALIZATION
++struct net_device *devb[MAX_PARM_DEVICES];
++#endif
++
++
+ #ifdef PRISM2_IO_DEBUG
+
+ static inline void hfa384x_outb_debug(struct net_device *dev, int a, u8 v)
+@@ -280,6 +287,10 @@
+
+ pci_set_drvdata(pdev, dev);
+
++#ifdef DEFERRED_IRQ_INITIALIZATION
++ printk("%s: deferred initialization of IRQs\n", dev_info);
++ devb[cards_found-1] = dev;
++#else
+ if (request_irq(dev->irq, prism2_interrupt, SA_SHIRQ, dev->name,
+ dev)) {
+ printk(KERN_WARNING "%s: request_irq failed\n", dev->name);
+@@ -295,7 +306,7 @@
+
+ printk(KERN_INFO "%s: Intersil Prism2.5 PCI: "
+ "mem=0x%lx, irq=%d\n", dev->name, phymem, dev->irq);
+-
++#endif
+ return hostap_hw_ready(dev);
+
+ fail:
+@@ -399,18 +410,43 @@
+ };
+
+
++#ifdef DEFERRED_IRQ_INITIALIZATION
++static void deferred_init(int num_devices)
++{
++ int n;
++ for (n=0; n<num_devices && n<MAX_PARM_DEVICES; n++)
++ {
++ if (request_irq(devb[n]->irq, prism2_interrupt, SA_SHIRQ, devb[n]->name,
++ devb[n])) {
++ printk(KERN_WARNING "%s: request_irq failed\n", devb[n]->name);
++ }
++ if (prism2_hw_config(devb[n], 1)) {
++ printk(KERN_DEBUG "%s: hardware initialization failed\n", devb[n]->name)
++;
++ }
++ printk(KERN_INFO "%s: Intersil Prism2.5 PCI: irq=%d\n", devb[n]->name, devb[n]->
++irq);
++ }
++}
++#endif
++
+ static int __init init_prism2_pci(void)
+ {
+ printk(KERN_INFO "%s: %s\n", dev_info, version);
+
+ #if (LINUX_VERSION_CODE < KERNEL_VERSION(2,6,10))
+- if (pci_register_driver(&prism2_pci_drv_id) <= 0) {
++ int n;
++ if ((n=pci_register_driver(&prism2_pci_drv_id)) <= 0) {
+ printk("hostap_pci: No devices found, driver not "
+ "installed.\n");
+ pci_unregister_driver(&prism2_pci_drv_id);
+ return -ENODEV;
+ }
+
++#ifdef DEFERRED_IRQ_INITIALIZATION
++ deferred_init(n);
++#endif
++
+ return 0;
+ #else
+ return pci_register_driver(&prism2_pci_drv_id);