aboutsummaryrefslogtreecommitdiffstats
path: root/documentation/poky-ref-manual/examples/hello-single/hello.bb
diff options
context:
space:
mode:
Diffstat (limited to 'documentation/poky-ref-manual/examples/hello-single/hello.bb')
-rw-r--r--documentation/poky-ref-manual/examples/hello-single/hello.bb16
1 files changed, 16 insertions, 0 deletions
diff --git a/documentation/poky-ref-manual/examples/hello-single/hello.bb b/documentation/poky-ref-manual/examples/hello-single/hello.bb
new file mode 100644
index 0000000000..d815b1ed73
--- /dev/null
+++ b/documentation/poky-ref-manual/examples/hello-single/hello.bb
@@ -0,0 +1,16 @@
+DESCRIPTION = "Simple helloworld application"
+SECTION = "examples"
+LICENSE = "MIT"
+
+SRC_URI = "file://helloworld.c"
+
+S = "${WORKDIR}"
+
+do_compile() {
+ ${CC} helloworld.c -o helloworld
+}
+
+do_install() {
+ install -d ${D}${bindir}
+ install -m 0755 helloworld ${D}${bindir}
+}