aboutsummaryrefslogtreecommitdiffstats
path: root/meta-xilinx-standalone-experimental/recipes-libraries/xilfpga-example_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-xilinx-standalone-experimental/recipes-libraries/xilfpga-example_git.bb')
-rw-r--r--meta-xilinx-standalone-experimental/recipes-libraries/xilfpga-example_git.bb6
1 files changed, 4 insertions, 2 deletions
diff --git a/meta-xilinx-standalone-experimental/recipes-libraries/xilfpga-example_git.bb b/meta-xilinx-standalone-experimental/recipes-libraries/xilfpga-example_git.bb
index e1af36e0..df5c1bbe 100644
--- a/meta-xilinx-standalone-experimental/recipes-libraries/xilfpga-example_git.bb
+++ b/meta-xilinx-standalone-experimental/recipes-libraries/xilfpga-example_git.bb
@@ -5,10 +5,12 @@ ESW_COMPONENT_SRC = "/lib/sw_services/xilfpga/examples/"
DEPENDS += "xilfpga"
do_configure:prepend() {
+ (
cd ${S}
lopper ${DTS_FILE} -- baremetallinker_xlnx.py ${ESW_MACHINE} ${S}/${ESW_COMPONENT_SRC}
install -m 0755 memory.ld ${S}/${ESW_COMPONENT_SRC}/
install -m 0755 *.cmake ${S}/${ESW_COMPONENT_SRC}/
+ )
}
ESW_CUSTOM_LINKER_FILE ?= "None"
@@ -20,8 +22,8 @@ do_install() {
}
do_deploy() {
- install -d ${DEPLOYDIR}/${MACHINE}-${BPN}/
- install -Dm 0644 ${WORKDIR}/package/${base_libdir}/firmware/*.elf ${DEPLOYDIR}/${MACHINE}-${BPN}/
+ install -d ${DEPLOYDIR}/${BPN}/
+ install -Dm 0644 ${WORKDIR}/package/${base_libdir}/firmware/*.elf ${DEPLOYDIR}/${BPN}/
}
addtask deploy before do_build after do_package