aboutsummaryrefslogtreecommitdiffstats
path: root/meta-xilinx-core/recipes-bsp/libdfx/libdfx_1.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-xilinx-core/recipes-bsp/libdfx/libdfx_1.0.bb')
-rw-r--r--meta-xilinx-core/recipes-bsp/libdfx/libdfx_1.0.bb21
1 files changed, 5 insertions, 16 deletions
diff --git a/meta-xilinx-core/recipes-bsp/libdfx/libdfx_1.0.bb b/meta-xilinx-core/recipes-bsp/libdfx/libdfx_1.0.bb
index 93f3b621..4ec38467 100644
--- a/meta-xilinx-core/recipes-bsp/libdfx/libdfx_1.0.bb
+++ b/meta-xilinx-core/recipes-bsp/libdfx/libdfx_1.0.bb
@@ -4,11 +4,11 @@ DESCRIPTION = "Xilinx libdfx Library and headers"
LICENSE = "GPLv2"
LIC_FILES_CHKSUM = "file://LICENSE.md;md5=94aba86aec117f003b958a52f019f1a7"
-BRANCH ?= "xlnx_rel_v2022.1"
+BRANCH ?= "xlnx_rel_v2022.2"
REPO ?= "git://github.com/Xilinx/libdfx.git;protocol=https"
BRANCHARG = "${@['nobranch=1', 'branch=${BRANCH}'][d.getVar('BRANCH', True) != '']}"
SRC_URI = "${REPO};${BRANCHARG}"
-SRCREV = "6d423bbafd9ac14194a6a80f4d276c9024d2defa"
+SRCREV = "f2b7bbca9d6936141024becfb92266600eeefc2b"
COMPATIBLE_MACHINE = "^$"
COMPATIBLE_MACHINE:zynqmp = "zynqmp"
@@ -18,17 +18,6 @@ S = "${WORKDIR}/git"
inherit cmake
-do_install () {
- install -d ${D}${libdir}
- install -d ${D}${includedir}
- install -d ${D}${bindir}
- oe_libinstall -so -C ${B}/src/ libdfx ${D}${libdir}
- install -m 0644 ${B}/src/libdfx.a ${D}${libdir}
- install -m 0644 ${B}/include/libdfx.h ${D}${includedir}
- install -m 0755 ${B}/apps/dfx_app ${D}${bindir}
-}
-
-SOLIBSDEV = ".so"
-FILES:${PN} += "${libdir}/libdfx.so ${bindir}/*"
-FILES:${PN}-staticdev = "${libdir}/libdfx.a"
-FILES:${PN}-dev = "${includedir}"
+# Due to an update where the soname/version was defined, we need to use an RREPLACES
+# so updates will work properly.
+RREPLACES:${PN} = "libdfx"