aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--conf/machine/include/machine-xilinx-default.inc2
-rw-r--r--recipes-bsp/u-boot/u-boot-elf.inc15
-rw-r--r--recipes-bsp/u-boot/u-boot-xlnx-dev.bb1
-rw-r--r--recipes-bsp/u-boot/u-boot-xlnx_2015.01.bb1
4 files changed, 2 insertions, 17 deletions
diff --git a/conf/machine/include/machine-xilinx-default.inc b/conf/machine/include/machine-xilinx-default.inc
index bf789519..d4b858de 100644
--- a/conf/machine/include/machine-xilinx-default.inc
+++ b/conf/machine/include/machine-xilinx-default.inc
@@ -25,6 +25,8 @@ UBOOT_SUFFIX ?= "img"
UBOOT_SUFFIX_zynqmp ?= "bin"
UBOOT_BINARY ?= "u-boot.${UBOOT_SUFFIX}"
UBOOT_BINARY_zynq ?= "u-boot-dtb.${UBOOT_SUFFIX}"
+UBOOT_ELF ?= "u-boot"
+UBOOT_ELF_aarch64 ?= "u-boot.elf"
# Device Trees
MACHINE_ESSENTIAL_EXTRA_RDEPENDS_append_zynq += "device-tree"
diff --git a/recipes-bsp/u-boot/u-boot-elf.inc b/recipes-bsp/u-boot/u-boot-elf.inc
deleted file mode 100644
index 547a9fd3..00000000
--- a/recipes-bsp/u-boot/u-boot-elf.inc
+++ /dev/null
@@ -1,15 +0,0 @@
-# U-Boot deploy ELF
-UBOOT_ELF = "u-boot"
-UBOOT_ELF_aarch64 = "u-boot.elf"
-UBOOT_ELF_IMAGE ?= "u-boot-${MACHINE}-${PV}-${PR}.elf"
-UBOOT_ELF_BINARY ?= "u-boot.elf"
-UBOOT_ELF_SYMLINK ?= "u-boot-${MACHINE}.elf"
-
-do_deploy_append() {
- if [ ! -z "${UBOOT_ELF}" ]; then
- install ${S}/${UBOOT_ELF} ${DEPLOYDIR}/${UBOOT_ELF_IMAGE}
- rm -f ${DEPLOYDIR}/${UBOOT_ELF_BINARY} ${DEPLOYDIR}/${UBOOT_ELF_SYMLINK}
- ln -sf ${UBOOT_ELF_IMAGE} ${DEPLOYDIR}/${UBOOT_ELF_BINARY}
- ln -sf ${UBOOT_ELF_IMAGE} ${DEPLOYDIR}/${UBOOT_ELF_SYMLINK}
- fi
-}
diff --git a/recipes-bsp/u-boot/u-boot-xlnx-dev.bb b/recipes-bsp/u-boot/u-boot-xlnx-dev.bb
index 20d3636d..823d3035 100644
--- a/recipes-bsp/u-boot/u-boot-xlnx-dev.bb
+++ b/recipes-bsp/u-boot/u-boot-xlnx-dev.bb
@@ -7,7 +7,6 @@
UBRANCH ?= "master"
include u-boot-xlnx.inc
-include u-boot-elf.inc
include u-boot-extra.inc
DEPENDS += "openssl-native"
diff --git a/recipes-bsp/u-boot/u-boot-xlnx_2015.01.bb b/recipes-bsp/u-boot/u-boot-xlnx_2015.01.bb
index ad0b8de7..81499125 100644
--- a/recipes-bsp/u-boot/u-boot-xlnx_2015.01.bb
+++ b/recipes-bsp/u-boot/u-boot-xlnx_2015.01.bb
@@ -1,6 +1,5 @@
include u-boot-xlnx.inc
include u-boot-xlnx-2015.01.inc
-include u-boot-elf.inc
include u-boot-extra.inc
UBOOT_ENV_zc702-zynq7 = "uEnv"