aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-bsp/trusted-firmware-a/trusted-firmware-a_%.bbappend
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-bsp/trusted-firmware-a/trusted-firmware-a_%.bbappend')
-rw-r--r--recipes-bsp/trusted-firmware-a/trusted-firmware-a_%.bbappend35
1 files changed, 32 insertions, 3 deletions
diff --git a/recipes-bsp/trusted-firmware-a/trusted-firmware-a_%.bbappend b/recipes-bsp/trusted-firmware-a/trusted-firmware-a_%.bbappend
index 965c99d4..70406724 100644
--- a/recipes-bsp/trusted-firmware-a/trusted-firmware-a_%.bbappend
+++ b/recipes-bsp/trusted-firmware-a/trusted-firmware-a_%.bbappend
@@ -1,6 +1,6 @@
-PV_k3 = "2.6"
+PV_k3 = "2.8+git${SRCPV}"
LIC_FILES_CHKSUM_k3 = "file://license.rst;md5=1dd070c98a281d18d9eefd938729b031"
-SRCREV_tfa_k3 = "453abc80b2eacbf2816c838e47e40f063227d934"
+SRCREV_tfa_k3 = "2fcd408bb3a6756767a43c073c597cef06e7f2d5"
COMPATIBLE_MACHINE_k3 = "k3"
TFA_BUILD_TARGET_k3 = "all"
TFA_INSTALL_TARGET_k3 = "bl31"
@@ -27,10 +27,22 @@ do_compile_append_am65xx-hs-evm() {
tfa_sign_k3hs
}
-do_compile_append_am64xx-hs-evm() {
+do_compile_append_am64xx-evm() {
tfa_sign_k3hs
}
+do_compile_append_am62xx-evm() {
+ tfa_sign_k3hs
+}
+
+do_compile_append_am62xx-lp-evm() {
+ tfa_sign_k3hs
+}
+
+do_compile_append_am62axx-evm() {
+ tfa_sign_k3hs
+}
+
do_compile_append_j7-hs-evm() {
tfa_sign_k3hs
}
@@ -42,3 +54,20 @@ do_compile_append_j7200-hs-evm() {
do_compile_append_j721s2-hs-evm() {
tfa_sign_k3hs
}
+
+do_compile_append_j784s4-hs-evm() {
+ tfa_sign_k3hs
+}
+
+do_install_append_k3() {
+ if [ -f $BUILD_PLAT/bl31.bin.unsigned ]; then
+ echo "Install bl31.bin.unsigned"
+ install -m 0644 $BUILD_PLAT/bl31.bin.unsigned \
+ ${D}/firmware/bl31.bin.unsigned
+ else
+ echo "Install bl31.bin.unsigned"
+ install -m 0644 $BUILD_PLAT/bl31.bin \
+ ${D}/firmware/bl31.bin.unsigned
+ fi
+}
+